aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-01-26 20:51:45 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-01-26 20:51:45 +0000
commit4f02141413b7e972b9acda4ed20ea850d295702c (patch)
treec93fe2e28694fd00b0019bf7968e88412fcbc3c9 /textproc
parentb3ca7e5ae0ef2271e60837f82cd30834edaee1fa (diff)
downloadports-4f02141413b7e972b9acda4ed20ea850d295702c.tar.gz
ports-4f02141413b7e972b9acda4ed20ea850d295702c.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/foiltex/Makefile27
1 files changed, 8 insertions, 19 deletions
diff --git a/textproc/foiltex/Makefile b/textproc/foiltex/Makefile
index 2973de662d4e..6814ead0b1bd 100644
--- a/textproc/foiltex/Makefile
+++ b/textproc/foiltex/Makefile
@@ -23,12 +23,13 @@ FOIL_DIR= share/texmf/tex/latex/${PORTNAME}
FOIL_FILES= foil17.clo foil20.clo foil25.clo foil30.clo foils.cls \
foils.sty foilshrt.clo fltfonts.def
+OPTIONS_DEFINE= DOCS EXAMPLES
+
PORTDOCS= foiltex.dtx foiltex.dvi
PORTEXAMPLES= sampfoil.tex
PLIST_FILES= ${FOIL_FILES:S,^,${FOIL_DIR}/,}
PLIST_DIRS= ${FOIL_DIR}
-NO_STAGE= yes
do-extract:
${MKDIR} ${WRKDIR}
${CP} ${DISTDIR}/foiltex.ins ${WRKDIR}/foiltex.ins
@@ -41,29 +42,17 @@ do-build:
${LATEX_CMD} foiltex.dtx
do-install:
-# install data files
- @${MKDIR} ${PREFIX}/${FOIL_DIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${FOIL_DIR}
.for file in ${FOIL_FILES}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/${FOIL_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/${FOIL_DIR}
.endfor
-# install docs and example file?
-.if !defined(NOPORTDOCS)
-# install docs...
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.if !defined(NOPORTEXAMPLES)
-# ...and examples
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for file in ${PORTEXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${EXAMPLESDIR}
.endfor
-.endif
-
-post-install:
- ${SETENV} LOCALBASE=${LOCALBASE} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>