aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 16:07:59 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 16:07:59 +0000
commit534fffca27bb18f7529d548c46ee3326505a89c7 (patch)
treea09ac440edd299d85a3517dea62caa2b115543fc /textproc
parent5bc499ce47fa1a8da853b36cc61cddf06075d203 (diff)
downloadports-534fffca27bb18f7529d548c46ee3326505a89c7.tar.gz
ports-534fffca27bb18f7529d548c46ee3326505a89c7.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/cwtext/Makefile3
-rw-r--r--textproc/gxmlviewer/Makefile3
-rw-r--r--textproc/html2fo/Makefile4
-rw-r--r--textproc/htmltolatex/Makefile3
-rw-r--r--textproc/libxml++/Makefile3
-rw-r--r--textproc/libxml++26/Makefile3
-rw-r--r--textproc/minidom/Makefile3
-rw-r--r--textproc/pybook/Makefile3
-rw-r--r--textproc/rtf2htm/Makefile6
-rw-r--r--textproc/tex2im/Makefile4
-rw-r--r--textproc/xmlpp/Makefile5
-rw-r--r--textproc/xmlppm/Makefile3
12 files changed, 29 insertions, 14 deletions
diff --git a/textproc/cwtext/Makefile b/textproc/cwtext/Makefile
index 5fb947a14331..48841fc9eb12 100644
--- a/textproc/cwtext/Makefile
+++ b/textproc/cwtext/Makefile
@@ -14,12 +14,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_GMAKE= yes
MAKEFILE= makefile
ALL_TARGET= ALL
post-patch:
- @${PERL} -pi -e "s,^PREFIX,#PREFIX,g ; \
+ @${REINPLACE_CMD} -e "s,^PREFIX,#PREFIX,g ; \
s,gcc,${CC} ${CFLAGS},g" ${WRKSRC}/${MAKEFILE}
do-install:
diff --git a/textproc/gxmlviewer/Makefile b/textproc/gxmlviewer/Makefile
index 5e3e85fcacc4..b4e6fd4d4f2a 100644
--- a/textproc/gxmlviewer/Makefile
+++ b/textproc/gxmlviewer/Makefile
@@ -16,11 +16,12 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
post-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/textproc/html2fo/Makefile b/textproc/html2fo/Makefile
index d7866a57cb54..baff5d7115cd 100644
--- a/textproc/html2fo/Makefile
+++ b/textproc/html2fo/Makefile
@@ -14,8 +14,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
+
post-patch:
- @${PERL} -pi -e "s,^CC,#CC,g ; \
+ @${REINPLACE_CMD} -e "s,^CC,#CC,g ; \
s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
do-install:
diff --git a/textproc/htmltolatex/Makefile b/textproc/htmltolatex/Makefile
index 87e61eb2ef7d..d3111109b0e7 100644
--- a/textproc/htmltolatex/Makefile
+++ b/textproc/htmltolatex/Makefile
@@ -16,13 +16,14 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= Magick:${PORTSDIR}/graphics/ImageMagick
+USE_REINPLACE= yes
USE_BISON= yes
MAKEFILE= GNUmakefile
CXXFLAGS+= -I${LOCALBASE}/include -DUNIX
USE_GMAKE= yes
post-patch:
- @${PERL} -pi -e "s,^CXXFLAGS,#CXXFLAGS,g ; \
+ @${REINPLACE_CMD} -e "s,^CXXFLAGS,#CXXFLAGS,g ; \
s,^CXX,#CXX,g" ${WRKSRC}/${MAKEFILE}
do-install:
diff --git a/textproc/libxml++/Makefile b/textproc/libxml++/Makefile
index bd5a3a25c655..0c9777e7a444 100644
--- a/textproc/libxml++/Makefile
+++ b/textproc/libxml++/Makefile
@@ -19,10 +19,11 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+USE_REINPLACE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
post-patch:
- @${PERL} -pi -e "s|xml-config|xml2-config|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s|xml-config|xml2-config|g" ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/textproc/libxml++26/Makefile b/textproc/libxml++26/Makefile
index bd5a3a25c655..0c9777e7a444 100644
--- a/textproc/libxml++26/Makefile
+++ b/textproc/libxml++26/Makefile
@@ -19,10 +19,11 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+USE_REINPLACE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
post-patch:
- @${PERL} -pi -e "s|xml-config|xml2-config|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s|xml-config|xml2-config|g" ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/textproc/minidom/Makefile b/textproc/minidom/Makefile
index 5e0894bc969b..b3be0c486e2d 100644
--- a/textproc/minidom/Makefile
+++ b/textproc/minidom/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
iconv.3:${PORTSDIR}/converters/libiconv
+USE_REINPLACE= yes
USE_GNOMENG= yes
USE_GNOME= glib12
USE_LIBTOOL= yes
@@ -26,7 +27,7 @@ CONFIGURE_ARGS= --with-libxml2=yes
INSTALLS_SHLIB= yes
post-patch:
- @${PERL} -pi -e 's|-lglib|-lglib12|g ; \
+ @${REINPLACE_CMD} -e 's|-lglib|-lglib12|g ; \
s|glib-config|${GLIB_CONFIG}|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/textproc/pybook/Makefile b/textproc/pybook/Makefile
index b534363c7b8e..f25cbaefcf4d 100644
--- a/textproc/pybook/Makefile
+++ b/textproc/pybook/Makefile
@@ -13,11 +13,12 @@ MASTER_SITES= http://silmarill.org/pybook/
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
post-patch:
- @${PERL} -pi -e "s,python2,python,g" ${WRKSRC}/pybook.py
+ @${REINPLACE_CMD} -e "s,python2,python,g" ${WRKSRC}/pybook.py
post-install:
@${MV} -f ${PREFIX}/bin/pybook.py ${PREFIX}/bin/pybook
diff --git a/textproc/rtf2htm/Makefile b/textproc/rtf2htm/Makefile
index 24cdab7bdd4f..f8415aecaaf1 100644
--- a/textproc/rtf2htm/Makefile
+++ b/textproc/rtf2htm/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= http://www.geocities.com/tuorfa/
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKEFILE= makefile
@@ -20,8 +22,8 @@ MANCOMPRESSED= no
MAN1= rtf2htm.1
post-patch:
- @${PERL} -pi -e "s,^CC,#CC,g ; s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/${MAKEFILE}
- @${PERL} -pi -e 's|malloc.h|stdlib.h|' ${WRKSRC}/malloc.c
+ @${REINPLACE_CMD} -e "s,^CC,#CC,g ; s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/malloc.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rtf2htm ${PREFIX}/bin
diff --git a/textproc/tex2im/Makefile b/textproc/tex2im/Makefile
index bf333f1653f7..174783806d1f 100644
--- a/textproc/tex2im/Makefile
+++ b/textproc/tex2im/Makefile
@@ -17,10 +17,12 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
latex:${PORTSDIR}/print/teTeX \
convert:${PORTSDIR}/graphics/ImageMagick
+USE_REINPLACE= yes
+
NO_BUILD= yes
post-patch:
- @${PERL} -pi -e "s,^#!/bin/bash,#!${LOCALBASE}/bin/bash,g" ${WRKSRC}/tex2im
+ @${REINPLACE_CMD} -e "s,^#!/bin/bash,#!${LOCALBASE}/bin/bash,g" ${WRKSRC}/tex2im
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/tex2im ${PREFIX}/bin
diff --git a/textproc/xmlpp/Makefile b/textproc/xmlpp/Makefile
index b9a14c882c23..cb79b5d0ce3c 100644
--- a/textproc/xmlpp/Makefile
+++ b/textproc/xmlpp/Makefile
@@ -13,12 +13,13 @@ MASTER_SITES= http://www.root.at/download/gpl/
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
FETCH_CMD= /usr/bin/fetch
USE_GMAKE= yes
USE_LIBTOOL= yes
pre-patch:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|/usr/local/share|\$$\(datadir\)|g'
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|/usr/local/share|$$(datadir)|g'
.include <bsd.port.mk>
diff --git a/textproc/xmlppm/Makefile b/textproc/xmlppm/Makefile
index 5d70ab20e41e..7d9c534b0a71 100644
--- a/textproc/xmlppm/Makefile
+++ b/textproc/xmlppm/Makefile
@@ -20,10 +20,11 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= expat.3:${PORTSDIR}/textproc/expat2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+USE_REINPLACE= yes
USE_GMAKE= yes
post-patch:
- @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
do-install:
@(cd ${WRKSRC} ; ${INSTALL_PROGRAM} xmlppm xmlunppm ${PREFIX}/bin)