aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2010-05-05 11:34:27 +0000
committerAnton Berezin <tobez@FreeBSD.org>2010-05-05 11:34:27 +0000
commit95409a3ba7f8d08ffcbde72afa56ac3e5dbb33b7 (patch)
treee8e328a6d6199a97d87f45afd443aedd10aaad49 /textproc
parenteda2e2c4a7b2167e5cbaf3671348219e0a1abeea (diff)
downloadports-95409a3ba7f8d08ffcbde72afa56ac3e5dbb33b7.tar.gz
ports-95409a3ba7f8d08ffcbde72afa56ac3e5dbb33b7.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Data-Phrasebook/Makefile30
-rw-r--r--textproc/p5-Data-Phrasebook/distinfo3
-rw-r--r--textproc/p5-Data-Phrasebook/pkg-descr9
-rw-r--r--textproc/p5-Data-Phrasebook/pkg-plist16
5 files changed, 59 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 02c934ccb67a..501fd0948ecc 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -425,6 +425,7 @@
SUBDIR += p5-Class-CSV
SUBDIR += p5-Data-FormValidator
SUBDIR += p5-Data-FormValidator-Constraints-DateTime
+ SUBDIR += p5-Data-Phrasebook
SUBDIR += p5-Data-Report
SUBDIR += p5-Data-SpreadPagination
SUBDIR += p5-DelimMatch
diff --git a/textproc/p5-Data-Phrasebook/Makefile b/textproc/p5-Data-Phrasebook/Makefile
new file mode 100644
index 000000000000..7b02834c3acd
--- /dev/null
+++ b/textproc/p5-Data-Phrasebook/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: textproc/p5-Data-Phrasebook
+# Date created: 05 May 2010
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Phrasebook
+PORTVERSION= 0.29
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Accessing phrasebooks from various data sources
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Phrasebook.3 \
+ Data::Phrasebook::Debug.3 \
+ Data::Phrasebook::Generic.3 \
+ Data::Phrasebook::Loader.3 \
+ Data::Phrasebook::Loader::Base.3 \
+ Data::Phrasebook::Loader::Text.3 \
+ Data::Phrasebook::Plain.3 \
+ Data::Phrasebook::SQL.3 \
+ Data::Phrasebook::SQL::Query.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Data-Phrasebook/distinfo b/textproc/p5-Data-Phrasebook/distinfo
new file mode 100644
index 000000000000..807bcdbda40c
--- /dev/null
+++ b/textproc/p5-Data-Phrasebook/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Phrasebook-0.29.tar.gz) = 376cdd0d8dd239d9e184beca062d223e
+SHA256 (Data-Phrasebook-0.29.tar.gz) = 3e06a8616d254747b4234d18d47a9c8029763fb3046b052154faa55632385d39
+SIZE (Data-Phrasebook-0.29.tar.gz) = 30681
diff --git a/textproc/p5-Data-Phrasebook/pkg-descr b/textproc/p5-Data-Phrasebook/pkg-descr
new file mode 100644
index 000000000000..cdb9f538e7f5
--- /dev/null
+++ b/textproc/p5-Data-Phrasebook/pkg-descr
@@ -0,0 +1,9 @@
+Data::Phrasebook is a collection of modules for accessing phrasebooks
+from various data sources.
+
+Common uses of phrasebooks are in handling error codes, accessing
+databases via SQL queries and written language phrases. Examples are the
+mime.types file and the hosts file, both of which use a simple
+phrasebook design.
+
+WWW: http://search.cpan.org/dist/Data-Phrasebook/
diff --git a/textproc/p5-Data-Phrasebook/pkg-plist b/textproc/p5-Data-Phrasebook/pkg-plist
new file mode 100644
index 000000000000..f19a43f156eb
--- /dev/null
+++ b/textproc/p5-Data-Phrasebook/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/Data/Phrasebook.pm
+%%SITE_PERL%%/Data/Phrasebook/Debug.pm
+%%SITE_PERL%%/Data/Phrasebook/Generic.pm
+%%SITE_PERL%%/Data/Phrasebook/Loader.pm
+%%SITE_PERL%%/Data/Phrasebook/Loader/Base.pm
+%%SITE_PERL%%/Data/Phrasebook/Loader/Text.pm
+%%SITE_PERL%%/Data/Phrasebook/Plain.pm
+%%SITE_PERL%%/Data/Phrasebook/SQL.pm
+%%SITE_PERL%%/Data/Phrasebook/SQL/Query.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Phrasebook/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Phrasebook
+@dirrmtry %%SITE_PERL%%/Data/Phrasebook/Loader
+@dirrmtry %%SITE_PERL%%/Data/Phrasebook/SQL
+@dirrmtry %%SITE_PERL%%/Data/Phrasebook
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data