aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2006-01-24 19:36:51 +0000
committerAndrey Slusar <anray@FreeBSD.org>2006-01-24 19:36:51 +0000
commitc81c30081562a0bcd77290aed06d22fbfc2655cb (patch)
tree684528ac3998754e61abf8361973104e33fac398 /textproc
parent4abf18c5bf87bb5e15c7cc371eac9d3edfa3a0ed (diff)
downloadports-c81c30081562a0bcd77290aed06d22fbfc2655cb.tar.gz
ports-c81c30081562a0bcd77290aed06d22fbfc2655cb.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/libtext-charwidth-perl/Makefile34
-rw-r--r--textproc/libtext-charwidth-perl/distinfo3
-rw-r--r--textproc/libtext-charwidth-perl/pkg-descr12
-rw-r--r--textproc/libtext-charwidth-perl/pkg-plist7
5 files changed, 57 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 8ade52692bc4..8bfa8af6df9a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -222,6 +222,7 @@
SUBDIR += liblrdf
SUBDIR += libparsifal
SUBDIR += libpathan
+ SUBDIR += libtext-charwidth-perl
SUBDIR += libtranslate
SUBDIR += libtre
SUBDIR += libuninameslist
diff --git a/textproc/libtext-charwidth-perl/Makefile b/textproc/libtext-charwidth-perl/Makefile
new file mode 100644
index 000000000000..c7ea14418720
--- /dev/null
+++ b/textproc/libtext-charwidth-perl/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libtext-charwidth-perl
+# Date created: 08 Januar 2006
+# Whom: Meno Abels <meno.abels@adviser.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtext-charwidth-perl
+PORTVERSION= 0.04
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= pool/main/libt/libtext-charwidth-perl
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+
+MAINTAINER= Meno.Abels@Adviser.com
+COMMENT= Documentation gettext tools
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::CharWidth.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= perl 5.8 or newer required. Install lang/perl5.8 and try again
+.endif
+
+post-extract:
+ @${MV} ${WRKSRC}.orig ${WRKSRC}
+
+.include <bsd.port.post.mk>
diff --git a/textproc/libtext-charwidth-perl/distinfo b/textproc/libtext-charwidth-perl/distinfo
new file mode 100644
index 000000000000..58d16f666b2e
--- /dev/null
+++ b/textproc/libtext-charwidth-perl/distinfo
@@ -0,0 +1,3 @@
+MD5 (libtext-charwidth-perl_0.04.orig.tar.gz) = 2dcb114a179e778b964f760852c313b9
+SHA256 (libtext-charwidth-perl_0.04.orig.tar.gz) = 37affbcd5835ce80d36c3916b8a4462f2f55136c354b46a31c275c562d7f6563
+SIZE (libtext-charwidth-perl_0.04.orig.tar.gz) = 8397
diff --git a/textproc/libtext-charwidth-perl/pkg-descr b/textproc/libtext-charwidth-perl/pkg-descr
new file mode 100644
index 000000000000..7ceafd39fd0c
--- /dev/null
+++ b/textproc/libtext-charwidth-perl/pkg-descr
@@ -0,0 +1,12 @@
+This is a part of fakeroot project.
+Fakeroot runs a command in an environment were it appears to have
+root privileges for file manipulation, by setting LD_PRELOAD to a
+library with alternative versions of getuid(), stat(), etc. This
+is useful for allowing users to create archives (tar, ar, .deb .rpm
+etc.) with files in them with root permissions/ownership. Without
+fakeroot one would have to have root privileges to create the
+constituent files of the archives with the correct permissions and
+ownership, and then pack them up, or one would have to construct
+the archives directly, without using the archiver.
+
+WWW: http://freshmeat.net/projects/fakeroot
diff --git a/textproc/libtext-charwidth-perl/pkg-plist b/textproc/libtext-charwidth-perl/pkg-plist
new file mode 100644
index 000000000000..ed13545449fb
--- /dev/null
+++ b/textproc/libtext-charwidth-perl/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/CharWidth/CharWidth.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/CharWidth/CharWidth.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/CharWidth/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/CharWidth.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/CharWidth
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Text