aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-05-27 08:47:16 +0000
committerWen Heping <wen@FreeBSD.org>2010-05-27 08:47:16 +0000
commitd97f1e3dc49da986cb518ed1347abdfe60e9cfdc (patch)
tree939555abf9388e0d4deb7509a3a3850ac8e8ad8f /textproc
parent2e293815ed5bf6447899ba7af99a147aec6251fb (diff)
downloadports-d97f1e3dc49da986cb518ed1347abdfe60e9cfdc.tar.gz
ports-d97f1e3dc49da986cb518ed1347abdfe60e9cfdc.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Pod-Elemental/Makefile57
-rw-r--r--textproc/p5-Pod-Elemental/distinfo3
-rw-r--r--textproc/p5-Pod-Elemental/pkg-descr7
-rw-r--r--textproc/p5-Pod-Elemental/pkg-plist34
5 files changed, 102 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 446de46becc7..fd44fdd6d74b 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -565,6 +565,7 @@
SUBDIR += p5-Pod-Autopod
SUBDIR += p5-Pod-Constants
SUBDIR += p5-Pod-DocBook
+ SUBDIR += p5-Pod-Elemental
SUBDIR += p5-Pod-Escapes
SUBDIR += p5-Pod-Eventual
SUBDIR += p5-Pod-HtmlEasy
diff --git a/textproc/p5-Pod-Elemental/Makefile b/textproc/p5-Pod-Elemental/Makefile
new file mode 100644
index 000000000000..14867fd3f051
--- /dev/null
+++ b/textproc/p5-Pod-Elemental/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: textproc/p5-Pod-Elemental
+# Date created: May 26, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pod-Elemental
+PORTVERSION= 0.100220
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Treating a Pod documents as trees of elements
+
+BUILD_DEPENDS= p5-Pod-Eventual>=0:${PORTSDIR}/textproc/p5-Pod-Eventual \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean \
+ p5-Moose-Autobox>=0.10:${PORTSDIR}/devel/p5-Moose-Autobox \
+ p5-MooseX-Types>=0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-String-RewritePrefix>=0:${PORTSDIR}/textproc/p5-String-RewritePrefix \
+ p5-String-Truncate>=0:${PORTSDIR}/textproc/p5-String-Truncate \
+ p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences \
+ p5-Sub-Exporter-ForMethods>=0:${PORTSDIR}/devel/p5-Sub-Exporter-ForMethods
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Pod::Elemental.3 \
+ Pod::Elemental::Autoblank.3 \
+ Pod::Elemental::Autochomp.3 \
+ Pod::Elemental::Command.3 \
+ Pod::Elemental::Document.3 \
+ Pod::Elemental::Element::Generic::Blank.3 \
+ Pod::Elemental::Element::Generic::Command.3 \
+ Pod::Elemental::Element::Generic::Nonpod.3 \
+ Pod::Elemental::Element::Generic::Text.3 \
+ Pod::Elemental::Element::Nested.3 \
+ Pod::Elemental::Element::Pod5::Command.3 \
+ Pod::Elemental::Element::Pod5::Data.3 \
+ Pod::Elemental::Element::Pod5::Nonpod.3 \
+ Pod::Elemental::Element::Pod5::Ordinary.3 \
+ Pod::Elemental::Element::Pod5::Region.3 \
+ Pod::Elemental::Element::Pod5::Verbatim.3 \
+ Pod::Elemental::Flat.3 \
+ Pod::Elemental::Node.3 \
+ Pod::Elemental::Objectifier.3 \
+ Pod::Elemental::Paragraph.3 \
+ Pod::Elemental::Selectors.3 \
+ Pod::Elemental::Transformer.3 \
+ Pod::Elemental::Transformer::Gatherer.3 \
+ Pod::Elemental::Transformer::Nester.3 \
+ Pod::Elemental::Transformer::Pod5.3 \
+ Pod::Elemental::Types.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-Elemental/distinfo b/textproc/p5-Pod-Elemental/distinfo
new file mode 100644
index 000000000000..ca8e1d61d5ca
--- /dev/null
+++ b/textproc/p5-Pod-Elemental/distinfo
@@ -0,0 +1,3 @@
+MD5 (Pod-Elemental-0.100220.tar.gz) = 276396eaef3afb210d3d46005291dfa3
+SHA256 (Pod-Elemental-0.100220.tar.gz) = f2651c5591e2a323f78ab5d414c85dcd12e197c2567459ef5d4faf2632d723b5
+SIZE (Pod-Elemental-0.100220.tar.gz) = 28363
diff --git a/textproc/p5-Pod-Elemental/pkg-descr b/textproc/p5-Pod-Elemental/pkg-descr
new file mode 100644
index 000000000000..a291c51919b5
--- /dev/null
+++ b/textproc/p5-Pod-Elemental/pkg-descr
@@ -0,0 +1,7 @@
+Pod::Elemental is a system for treating a Pod (plain old documentation)
+documents as trees of elements. This model may be familiar from many other
+document systems, especially the HTML DOM. Pod::Elemental's document
+object model is much less sophisticated than the HTML DOM, but still makes
+a lot of document transformations easy.
+
+WWW: http://search.cpan.org/dist/Pod-Elemental/
diff --git a/textproc/p5-Pod-Elemental/pkg-plist b/textproc/p5-Pod-Elemental/pkg-plist
new file mode 100644
index 000000000000..daa435c21ac8
--- /dev/null
+++ b/textproc/p5-Pod-Elemental/pkg-plist
@@ -0,0 +1,34 @@
+%%SITE_PERL%%/Pod/Elemental/Element/Generic/Blank.pm
+%%SITE_PERL%%/Pod/Elemental/Element/Generic/Text.pm
+%%SITE_PERL%%/Pod/Elemental/Element/Generic/Nonpod.pm
+%%SITE_PERL%%/Pod/Elemental/Element/Generic/Command.pm
+%%SITE_PERL%%/Pod/Elemental/Element/Pod5/Region.pm
+%%SITE_PERL%%/Pod/Elemental/Element/Pod5/Command.pm
+%%SITE_PERL%%/Pod/Elemental/Element/Pod5/Nonpod.pm
+%%SITE_PERL%%/Pod/Elemental/Element/Pod5/Verbatim.pm
+%%SITE_PERL%%/Pod/Elemental/Element/Pod5/Data.pm
+%%SITE_PERL%%/Pod/Elemental/Element/Pod5/Ordinary.pm
+%%SITE_PERL%%/Pod/Elemental/Element/Nested.pm
+%%SITE_PERL%%/Pod/Elemental/Transformer/Nester.pm
+%%SITE_PERL%%/Pod/Elemental/Transformer/Gatherer.pm
+%%SITE_PERL%%/Pod/Elemental/Transformer/Pod5.pm
+%%SITE_PERL%%/Pod/Elemental/Autoblank.pm
+%%SITE_PERL%%/Pod/Elemental/Autochomp.pm
+%%SITE_PERL%%/Pod/Elemental/Command.pm
+%%SITE_PERL%%/Pod/Elemental/Flat.pm
+%%SITE_PERL%%/Pod/Elemental/Document.pm
+%%SITE_PERL%%/Pod/Elemental/Node.pm
+%%SITE_PERL%%/Pod/Elemental/Objectifier.pm
+%%SITE_PERL%%/Pod/Elemental/Paragraph.pm
+%%SITE_PERL%%/Pod/Elemental/Selectors.pm
+%%SITE_PERL%%/Pod/Elemental/Transformer.pm
+%%SITE_PERL%%/Pod/Elemental/Types.pm
+%%SITE_PERL%%/Pod/Elemental.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Elemental/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Elemental
+@dirrmtry %%SITE_PERL%%/Pod/Elemental/Element/Generic
+@dirrmtry %%SITE_PERL%%/Pod/Elemental/Element/Pod5
+@dirrmtry %%SITE_PERL%%/Pod/Elemental/Transformer
+@dirrmtry %%SITE_PERL%%/Pod/Elemental/Element
+@dirrmtry %%SITE_PERL%%/Pod/Elemental
+@dirrmtry %%SITE_PERL%%/Pod