aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /textproc
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/gnome-doc-utils/Makefile42
-rw-r--r--textproc/gnome-doc-utils/distinfo2
-rw-r--r--textproc/gnome-doc-utils/pkg-descr1
-rw-r--r--textproc/gnome-doc-utils/pkg-plist101
-rw-r--r--textproc/gnomedocutils/Makefile42
-rw-r--r--textproc/gnomedocutils/distinfo2
-rw-r--r--textproc/gnomedocutils/pkg-descr1
-rw-r--r--textproc/gnomedocutils/pkg-plist101
9 files changed, 293 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 3f9bef2e1807..dc2e3fe27ea3 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -129,6 +129,7 @@
SUBDIR += gmat
SUBDIR += gmetadom
SUBDIR += gnome-translate
+ SUBDIR += gnomedocutils
SUBDIR += gnomespell
SUBDIR += gpp
SUBDIR += grap
diff --git a/textproc/gnome-doc-utils/Makefile b/textproc/gnome-doc-utils/Makefile
new file mode 100644
index 000000000000..171377df0cde
--- /dev/null
+++ b/textproc/gnome-doc-utils/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: gnome-doc-utils
+# Date created: 11 November 2004
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomedocutils
+PORTVERSION= 0.1.3
+CATEGORIES= textproc gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gnome-doc-utils/0.1
+DISTNAME= gnome-doc-utils-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME doc utils
+
+BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
+RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
+
+PREFIX?= ${X11BASE}
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehier gnometarget gnomehack libxslt
+USE_PYTHON= yes
+INSTALLS_OMF= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-omf-dir=${PREFIX}/share/gnome/omf
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= xml2po.1
+
+DOCBOOK_VERSION=4.1.2
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|4\.2|${DOCBOOK_VERSION}|g' \
+ ${WRKSRC}/doc/xslt/C/gnome-doc-xslt.xml \
+ ${WRKSRC}/doc/gnome-doc-make/C/gnome-doc-make.xml
+
+.include <bsd.port.mk>
diff --git a/textproc/gnome-doc-utils/distinfo b/textproc/gnome-doc-utils/distinfo
new file mode 100644
index 000000000000..21849b8ee2a4
--- /dev/null
+++ b/textproc/gnome-doc-utils/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome-doc-utils-0.1.3.tar.bz2) = d59875bb5924fd098a19a7d229af63cc
+SIZE (gnome-doc-utils-0.1.3.tar.bz2) = 287482
diff --git a/textproc/gnome-doc-utils/pkg-descr b/textproc/gnome-doc-utils/pkg-descr
new file mode 100644
index 000000000000..f68a678220af
--- /dev/null
+++ b/textproc/gnome-doc-utils/pkg-descr
@@ -0,0 +1 @@
+Insert decent comment here.
diff --git a/textproc/gnome-doc-utils/pkg-plist b/textproc/gnome-doc-utils/pkg-plist
new file mode 100644
index 000000000000..156055279b27
--- /dev/null
+++ b/textproc/gnome-doc-utils/pkg-plist
@@ -0,0 +1,101 @@
+bin/gnome-doc-prepare
+bin/xml2po
+libdata/pkgconfig/gnome-doc-utils.pc
+libdata/pkgconfig/xml2po.pc
+share/aclocal/gnome-doc-utils.m4
+share/gnome-doc-utils/gnome-doc-utils.make
+share/gnome/help/gnome-doc-make/C/gnome-doc-make.xml
+share/gnome/help/gnome-doc-make/C/legal.xml
+share/gnome/help/gnome-doc-make/C/make-ref.xml
+share/gnome/help/gnome-doc-xslt/C/db-chunk.xml
+share/gnome/help/gnome-doc-xslt/C/db-common.xml
+share/gnome/help/gnome-doc-xslt/C/db-format.xml
+share/gnome/help/gnome-doc-xslt/C/db-label.xml
+share/gnome/help/gnome-doc-xslt/C/db-title.xml
+share/gnome/help/gnome-doc-xslt/C/db-xref.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-admon.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-autotoc.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-block.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-callout.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-classsynopsis.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-cmdsynopsis.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-css.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-division.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-ebnf.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-funcsynopsis.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-info.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-inline.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-list.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-media.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-qanda.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-refentry.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-suppressed.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-table.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-title.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-xref.xml
+share/gnome/help/gnome-doc-xslt/C/db2html.xml
+share/gnome/help/gnome-doc-xslt/C/db2omf.xml
+share/gnome/help/gnome-doc-xslt/C/format2xsl.xml
+share/gnome/help/gnome-doc-xslt/C/gettext.xml
+share/gnome/help/gnome-doc-xslt/C/gnome-doc-xslt.xml
+share/gnome/help/gnome-doc-xslt/C/legal.xml
+share/gnome/help/gnome-doc-xslt/C/translating.xml
+share/gnome/help/gnome-doc-xslt/C/xsldoc.xml
+share/gnome/omf/gnome-doc-make/gnome-doc-make-C.omf
+share/gnome/omf/gnome-doc-xslt/gnome-doc-xslt-C.omf
+share/xml/gnome/xslt/docbook/common/db-chunk.xsl
+share/xml/gnome/xslt/docbook/common/db-common.xsl
+share/xml/gnome/xslt/docbook/common/db-format.xsl
+share/xml/gnome/xslt/docbook/common/db-label.xsl
+share/xml/gnome/xslt/docbook/common/db-title.xsl
+share/xml/gnome/xslt/docbook/common/db-xref.xsl
+share/xml/gnome/xslt/docbook/html/db2html-admon.xsl
+share/xml/gnome/xslt/docbook/html/db2html-autotoc.xsl
+share/xml/gnome/xslt/docbook/html/db2html-block.xsl
+share/xml/gnome/xslt/docbook/html/db2html-callout.xsl
+share/xml/gnome/xslt/docbook/html/db2html-classsynopsis.xsl
+share/xml/gnome/xslt/docbook/html/db2html-cmdsynopsis.xsl
+share/xml/gnome/xslt/docbook/html/db2html-css.xsl
+share/xml/gnome/xslt/docbook/html/db2html-division.xsl
+share/xml/gnome/xslt/docbook/html/db2html-ebnf.xsl
+share/xml/gnome/xslt/docbook/html/db2html-funcsynopsis.xsl
+share/xml/gnome/xslt/docbook/html/db2html-info.xsl
+share/xml/gnome/xslt/docbook/html/db2html-inline.xsl
+share/xml/gnome/xslt/docbook/html/db2html-list.xsl
+share/xml/gnome/xslt/docbook/html/db2html-media.xsl
+share/xml/gnome/xslt/docbook/html/db2html-qanda.xsl
+share/xml/gnome/xslt/docbook/html/db2html-refentry.xsl
+share/xml/gnome/xslt/docbook/html/db2html-suppressed.xsl
+share/xml/gnome/xslt/docbook/html/db2html-table.xsl
+share/xml/gnome/xslt/docbook/html/db2html-title.xsl
+share/xml/gnome/xslt/docbook/html/db2html-xref.xsl
+share/xml/gnome/xslt/docbook/html/db2html.xsl
+share/xml/gnome/xslt/docbook/omf/db2omf.xsl
+share/xml/gnome/xslt/docbook/utils/chunks.xsl
+share/xml/gnome/xslt/docbook/utils/credits.xsl
+share/xml/gnome/xslt/docbook/utils/ids.xsl
+share/xml/gnome/xslt/gettext/format2xsl.xsl
+share/xml/gnome/xslt/gettext/gettext.xsl
+share/xml/gnome/xslt/gettext/l10n.xml
+share/xml/gnome/xslt/xsldoc/xsldoc.xsl
+share/xml2po/docbook.py
+share/xml2po/empty.py
+share/xml2po/gs.py
+@dirrm share/xml2po
+@dirrm share/xml/gnome/xslt/xsldoc
+@dirrm share/xml/gnome/xslt/gettext
+@dirrm share/xml/gnome/xslt/docbook/utils
+@dirrm share/xml/gnome/xslt/docbook/omf
+@dirrm share/xml/gnome/xslt/docbook/html
+@dirrm share/xml/gnome/xslt/docbook/common
+@dirrm share/xml/gnome/xslt/docbook
+@dirrm share/xml/gnome/xslt
+@dirrm share/xml/gnome
+@dirrm share/xml
+@dirrm share/gnome/omf/gnome-doc-xslt
+@dirrm share/gnome/omf/gnome-doc-make
+@dirrm share/gnome/help/gnome-doc-xslt/C
+@dirrm share/gnome/help/gnome-doc-xslt
+@dirrm share/gnome/help/gnome-doc-make/C
+@dirrm share/gnome/help/gnome-doc-make
+@dirrm share/gnome-doc-utils
diff --git a/textproc/gnomedocutils/Makefile b/textproc/gnomedocutils/Makefile
new file mode 100644
index 000000000000..171377df0cde
--- /dev/null
+++ b/textproc/gnomedocutils/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: gnome-doc-utils
+# Date created: 11 November 2004
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomedocutils
+PORTVERSION= 0.1.3
+CATEGORIES= textproc gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gnome-doc-utils/0.1
+DISTNAME= gnome-doc-utils-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME doc utils
+
+BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
+RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
+
+PREFIX?= ${X11BASE}
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehier gnometarget gnomehack libxslt
+USE_PYTHON= yes
+INSTALLS_OMF= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-omf-dir=${PREFIX}/share/gnome/omf
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= xml2po.1
+
+DOCBOOK_VERSION=4.1.2
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|4\.2|${DOCBOOK_VERSION}|g' \
+ ${WRKSRC}/doc/xslt/C/gnome-doc-xslt.xml \
+ ${WRKSRC}/doc/gnome-doc-make/C/gnome-doc-make.xml
+
+.include <bsd.port.mk>
diff --git a/textproc/gnomedocutils/distinfo b/textproc/gnomedocutils/distinfo
new file mode 100644
index 000000000000..21849b8ee2a4
--- /dev/null
+++ b/textproc/gnomedocutils/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome-doc-utils-0.1.3.tar.bz2) = d59875bb5924fd098a19a7d229af63cc
+SIZE (gnome-doc-utils-0.1.3.tar.bz2) = 287482
diff --git a/textproc/gnomedocutils/pkg-descr b/textproc/gnomedocutils/pkg-descr
new file mode 100644
index 000000000000..f68a678220af
--- /dev/null
+++ b/textproc/gnomedocutils/pkg-descr
@@ -0,0 +1 @@
+Insert decent comment here.
diff --git a/textproc/gnomedocutils/pkg-plist b/textproc/gnomedocutils/pkg-plist
new file mode 100644
index 000000000000..156055279b27
--- /dev/null
+++ b/textproc/gnomedocutils/pkg-plist
@@ -0,0 +1,101 @@
+bin/gnome-doc-prepare
+bin/xml2po
+libdata/pkgconfig/gnome-doc-utils.pc
+libdata/pkgconfig/xml2po.pc
+share/aclocal/gnome-doc-utils.m4
+share/gnome-doc-utils/gnome-doc-utils.make
+share/gnome/help/gnome-doc-make/C/gnome-doc-make.xml
+share/gnome/help/gnome-doc-make/C/legal.xml
+share/gnome/help/gnome-doc-make/C/make-ref.xml
+share/gnome/help/gnome-doc-xslt/C/db-chunk.xml
+share/gnome/help/gnome-doc-xslt/C/db-common.xml
+share/gnome/help/gnome-doc-xslt/C/db-format.xml
+share/gnome/help/gnome-doc-xslt/C/db-label.xml
+share/gnome/help/gnome-doc-xslt/C/db-title.xml
+share/gnome/help/gnome-doc-xslt/C/db-xref.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-admon.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-autotoc.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-block.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-callout.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-classsynopsis.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-cmdsynopsis.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-css.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-division.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-ebnf.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-funcsynopsis.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-info.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-inline.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-list.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-media.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-qanda.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-refentry.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-suppressed.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-table.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-title.xml
+share/gnome/help/gnome-doc-xslt/C/db2html-xref.xml
+share/gnome/help/gnome-doc-xslt/C/db2html.xml
+share/gnome/help/gnome-doc-xslt/C/db2omf.xml
+share/gnome/help/gnome-doc-xslt/C/format2xsl.xml
+share/gnome/help/gnome-doc-xslt/C/gettext.xml
+share/gnome/help/gnome-doc-xslt/C/gnome-doc-xslt.xml
+share/gnome/help/gnome-doc-xslt/C/legal.xml
+share/gnome/help/gnome-doc-xslt/C/translating.xml
+share/gnome/help/gnome-doc-xslt/C/xsldoc.xml
+share/gnome/omf/gnome-doc-make/gnome-doc-make-C.omf
+share/gnome/omf/gnome-doc-xslt/gnome-doc-xslt-C.omf
+share/xml/gnome/xslt/docbook/common/db-chunk.xsl
+share/xml/gnome/xslt/docbook/common/db-common.xsl
+share/xml/gnome/xslt/docbook/common/db-format.xsl
+share/xml/gnome/xslt/docbook/common/db-label.xsl
+share/xml/gnome/xslt/docbook/common/db-title.xsl
+share/xml/gnome/xslt/docbook/common/db-xref.xsl
+share/xml/gnome/xslt/docbook/html/db2html-admon.xsl
+share/xml/gnome/xslt/docbook/html/db2html-autotoc.xsl
+share/xml/gnome/xslt/docbook/html/db2html-block.xsl
+share/xml/gnome/xslt/docbook/html/db2html-callout.xsl
+share/xml/gnome/xslt/docbook/html/db2html-classsynopsis.xsl
+share/xml/gnome/xslt/docbook/html/db2html-cmdsynopsis.xsl
+share/xml/gnome/xslt/docbook/html/db2html-css.xsl
+share/xml/gnome/xslt/docbook/html/db2html-division.xsl
+share/xml/gnome/xslt/docbook/html/db2html-ebnf.xsl
+share/xml/gnome/xslt/docbook/html/db2html-funcsynopsis.xsl
+share/xml/gnome/xslt/docbook/html/db2html-info.xsl
+share/xml/gnome/xslt/docbook/html/db2html-inline.xsl
+share/xml/gnome/xslt/docbook/html/db2html-list.xsl
+share/xml/gnome/xslt/docbook/html/db2html-media.xsl
+share/xml/gnome/xslt/docbook/html/db2html-qanda.xsl
+share/xml/gnome/xslt/docbook/html/db2html-refentry.xsl
+share/xml/gnome/xslt/docbook/html/db2html-suppressed.xsl
+share/xml/gnome/xslt/docbook/html/db2html-table.xsl
+share/xml/gnome/xslt/docbook/html/db2html-title.xsl
+share/xml/gnome/xslt/docbook/html/db2html-xref.xsl
+share/xml/gnome/xslt/docbook/html/db2html.xsl
+share/xml/gnome/xslt/docbook/omf/db2omf.xsl
+share/xml/gnome/xslt/docbook/utils/chunks.xsl
+share/xml/gnome/xslt/docbook/utils/credits.xsl
+share/xml/gnome/xslt/docbook/utils/ids.xsl
+share/xml/gnome/xslt/gettext/format2xsl.xsl
+share/xml/gnome/xslt/gettext/gettext.xsl
+share/xml/gnome/xslt/gettext/l10n.xml
+share/xml/gnome/xslt/xsldoc/xsldoc.xsl
+share/xml2po/docbook.py
+share/xml2po/empty.py
+share/xml2po/gs.py
+@dirrm share/xml2po
+@dirrm share/xml/gnome/xslt/xsldoc
+@dirrm share/xml/gnome/xslt/gettext
+@dirrm share/xml/gnome/xslt/docbook/utils
+@dirrm share/xml/gnome/xslt/docbook/omf
+@dirrm share/xml/gnome/xslt/docbook/html
+@dirrm share/xml/gnome/xslt/docbook/common
+@dirrm share/xml/gnome/xslt/docbook
+@dirrm share/xml/gnome/xslt
+@dirrm share/xml/gnome
+@dirrm share/xml
+@dirrm share/gnome/omf/gnome-doc-xslt
+@dirrm share/gnome/omf/gnome-doc-make
+@dirrm share/gnome/help/gnome-doc-xslt/C
+@dirrm share/gnome/help/gnome-doc-xslt
+@dirrm share/gnome/help/gnome-doc-make/C
+@dirrm share/gnome/help/gnome-doc-make
+@dirrm share/gnome-doc-utils