aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2005-04-27 15:29:21 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2005-04-27 15:29:21 +0000
commit3c8c8b5ab24efc7810a689fc37475935fd439e3d (patch)
treee1c26d715f4b8bc02123aaf851e29e41bbe77284 /textproc
parent29bec46caf8494d5e40ab16a319cc4e97946b787 (diff)
downloadports-3c8c8b5ab24efc7810a689fc37475935fd439e3d.tar.gz
ports-3c8c8b5ab24efc7810a689fc37475935fd439e3d.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-Parser-Lite-Tree/Makefile26
-rw-r--r--textproc/p5-XML-Parser-Lite-Tree/distinfo2
-rw-r--r--textproc/p5-XML-Parser-Lite-Tree/pkg-descr6
-rw-r--r--textproc/p5-XML-Parser-Lite-Tree/pkg-plist9
5 files changed, 44 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 74e71e817fec..1870726077ff 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -458,6 +458,7 @@
SUBDIR += p5-XML-NodeFilter
SUBDIR += p5-XML-Parser
SUBDIR += p5-XML-Parser-EasyTree
+ SUBDIR += p5-XML-Parser-Lite-Tree
SUBDIR += p5-XML-Parser-Style-Elemental
SUBDIR += p5-XML-Quote
SUBDIR += p5-XML-RAI
diff --git a/textproc/p5-XML-Parser-Lite-Tree/Makefile b/textproc/p5-XML-Parser-Lite-Tree/Makefile
new file mode 100644
index 000000000000..548f6aebde25
--- /dev/null
+++ b/textproc/p5-XML-Parser-Lite-Tree/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: XML::Parser::Lite::Tree
+# Date created: Apr 27, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Parser-Lite-Tree
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Lightweight XML tree builder
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/Parser/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Parser::Lite::Tree.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Parser-Lite-Tree/distinfo b/textproc/p5-XML-Parser-Lite-Tree/distinfo
new file mode 100644
index 000000000000..26cc0506c532
--- /dev/null
+++ b/textproc/p5-XML-Parser-Lite-Tree/distinfo
@@ -0,0 +1,2 @@
+MD5 (XML-Parser-Lite-Tree-0.03.tar.gz) = 9435bb1e1f64433d657c35287388302d
+SIZE (XML-Parser-Lite-Tree-0.03.tar.gz) = 2294
diff --git a/textproc/p5-XML-Parser-Lite-Tree/pkg-descr b/textproc/p5-XML-Parser-Lite-Tree/pkg-descr
new file mode 100644
index 000000000000..e508b60ee21d
--- /dev/null
+++ b/textproc/p5-XML-Parser-Lite-Tree/pkg-descr
@@ -0,0 +1,6 @@
+This is a singleton class for parsing XML into a tree structure. How does this
+differ from other XML tree generators? By using XML::Parser::Lite, which is a
+pure perl XML parser. Using this module you can tree-ify simple XML without
+having to compile any C.
+
+WWW: http://search.cpan.org/dist/XML-Parser-Lite-Tree/
diff --git a/textproc/p5-XML-Parser-Lite-Tree/pkg-plist b/textproc/p5-XML-Parser-Lite-Tree/pkg-plist
new file mode 100644
index 000000000000..b54e32340f97
--- /dev/null
+++ b/textproc/p5-XML-Parser-Lite-Tree/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/XML/Parser/Lite/Tree.pm
+@unexec rmdir %D/%%SITE_PERL%%/XML/Parser/Lite 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/XML/Parser 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/XML 2>/dev/null || true
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Parser/Lite/Tree/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Parser/Lite/Tree
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Parser/Lite 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Parser 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true