aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2008-04-25 14:34:52 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2008-04-25 14:34:52 +0000
commit4994d1f521a87ce5d31782209d14f3f0bac6df0b (patch)
treed92d937c8769c4c3161c8fec7509b874e29ca627 /textproc
parent17d8f1145ab0bb2e869dd93cdb75ebced4fdfe60 (diff)
downloadports-4994d1f521a87ce5d31782209d14f3f0bac6df0b.tar.gz
ports-4994d1f521a87ce5d31782209d14f3f0bac6df0b.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Regexp-Common-Email-Address/Makefile25
-rw-r--r--textproc/p5-Regexp-Common-Email-Address/distinfo3
-rw-r--r--textproc/p5-Regexp-Common-Email-Address/pkg-descr4
-rw-r--r--textproc/p5-Regexp-Common-Email-Address/pkg-plist9
5 files changed, 42 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4c64d1808e6c..e9bc3061bf01 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -495,6 +495,7 @@
SUBDIR += p5-RTF-Writer
SUBDIR += p5-Regex-PreSuf
SUBDIR += p5-Regexp-Common
+ SUBDIR += p5-Regexp-Common-Email-Address
SUBDIR += p5-Regexp-Common-profanity_us
SUBDIR += p5-Regexp-Copy
SUBDIR += p5-Regexp-DefaultFlags
diff --git a/textproc/p5-Regexp-Common-Email-Address/Makefile b/textproc/p5-Regexp-Common-Email-Address/Makefile
new file mode 100644
index 000000000000..178172c1dd59
--- /dev/null
+++ b/textproc/p5-Regexp-Common-Email-Address/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: Regexp-Common-Email-Address
+# Date created: 25 Apr 2008
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Regexp-Common-Email-Address
+PORTVERSION= 1.01
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Regex pattern for Email Addresses
+
+BUILD_DEPENDS= ${SITE_PERL}/Email/Address.pm:${PORTSDIR}/mail/p5-Email-Address \
+ ${SITE_PERL}/Regexp/Common.pm:${PORTSDIR}/textproc/p5-Regexp-Common
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Regexp::Common::Email::Address.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Regexp-Common-Email-Address/distinfo b/textproc/p5-Regexp-Common-Email-Address/distinfo
new file mode 100644
index 000000000000..22708dc896db
--- /dev/null
+++ b/textproc/p5-Regexp-Common-Email-Address/distinfo
@@ -0,0 +1,3 @@
+MD5 (Regexp-Common-Email-Address-1.01.tar.gz) = 2acdadc696649b102f43dcff99f85792
+SHA256 (Regexp-Common-Email-Address-1.01.tar.gz) = d0411cd2df37f28eed7033b1a1611f7ac119abb4eb33c50f6d35a1134138734c
+SIZE (Regexp-Common-Email-Address-1.01.tar.gz) = 1955
diff --git a/textproc/p5-Regexp-Common-Email-Address/pkg-descr b/textproc/p5-Regexp-Common-Email-Address/pkg-descr
new file mode 100644
index 000000000000..a9d61da40c79
--- /dev/null
+++ b/textproc/p5-Regexp-Common-Email-Address/pkg-descr
@@ -0,0 +1,4 @@
+Regexp::Common::Email::Address provides a regex to match email addresses
+as defined by RFC 2822.
+
+WWW: http://search.cpan.org/dist/Regexp-Common-Email-Address/
diff --git a/textproc/p5-Regexp-Common-Email-Address/pkg-plist b/textproc/p5-Regexp-Common-Email-Address/pkg-plist
new file mode 100644
index 000000000000..f15c48b0f72a
--- /dev/null
+++ b/textproc/p5-Regexp-Common-Email-Address/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp/Common/Email/Address/.packlist
+%%SITE_PERL%%/Regexp/Common/Email/Address.pm
+@dirrmtry %%SITE_PERL%%/Regexp/Common/Email
+@dirrmtry %%SITE_PERL%%/Regexp/Common
+@dirrmtry %%SITE_PERL%%/Regexp
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp/Common/Email/Address
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp/Common/Email
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp/Common
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp