aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-06-09 00:41:21 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-06-09 00:41:21 +0000
commit99b882c2416b9d8f786fb0dd08503bd18b212b39 (patch)
treedcea21b73eebc5949aba351ef076d065557ff840 /textproc
parent59cb6c5ffacec801f431e8f2054e30c00dcc4bb9 (diff)
downloadports-99b882c2416b9d8f786fb0dd08503bd18b212b39.tar.gz
ports-99b882c2416b9d8f786fb0dd08503bd18b212b39.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-qt4-xml/Makefile33
-rw-r--r--textproc/py-qt4-xml/pkg-plist10
-rw-r--r--textproc/py-qt4-xmlpatterns/Makefile33
-rw-r--r--textproc/py-qt4-xmlpatterns/pkg-plist32
4 files changed, 43 insertions, 65 deletions
diff --git a/textproc/py-qt4-xml/Makefile b/textproc/py-qt4-xml/Makefile
index ccf894bd59ab..2ed8c60bbae8 100644
--- a/textproc/py-qt4-xml/Makefile
+++ b/textproc/py-qt4-xml/Makefile
@@ -24,29 +24,28 @@ HAS_CONFIGURE= yes
USE_PYTHON= 2.5+
USE_QT4= xml qmake_build moc_build
-OPTIONS= API "Install QtXml API for QScintilla2" on \
- DEBUG "Enable debugging in generated code" off \
- SIPFILES "Install the QtXml SIP files" on \
- TRACING "Enable tracing in generated code" off
+OPTIONS= API "Install QtXml API for QScintilla2" on
PATCHDIR= ${PORTSDIR}/devel/py-qt4-core/files
OPTIONSFILE?= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
SIPDIR= ${PREFIX}/share/py-sip
QSCIDIR= ${PREFIX}/share/qt4/qsci
CONFIGURE_ENV+= PYQT4_COMPONENT="${PORTNAME}"
-ARGS= -b ${PREFIX}/bin\
- -d ${PYTHONPREFIX_SITELIBDIR}\
- -p ${PREFIX}/${QT_PLUGINDIR_REL}\
- -q ${QMAKE}\
- --confirm-license\
+ARGS= -b ${PREFIX}/bin \
+ -d ${PYTHONPREFIX_SITELIBDIR} \
+ -p ${PREFIX}/${QT_PLUGINDIR_REL} \
+ -q ${QMAKE} \
+ --confirm-license \
+ --sipdir ${SIPDIR} \
--enable QtXml
+.if defined(WITH_DEBUG)
+ARGS+= --debug --trace
+.endif
+
.include "../../devel/py-sip/files/bsd.pyqt.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
-ARGS+= --debug
-.endif
.if defined(WITHOUT_API)
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
@@ -55,16 +54,6 @@ LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
-.if defined(WITHOUT_SIPFILES)
-ARGS+= --no-sip-files
-PLIST_SUB+= SIP="@comment "
-.else
-ARGS+= --sipdir ${SIPDIR}
-PLIST_SUB+= SIP=""
-.endif
-.if defined(WITH_TRACING)
-ARGS+= --trace
-.endif
do-configure:
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV}\
diff --git a/textproc/py-qt4-xml/pkg-plist b/textproc/py-qt4-xml/pkg-plist
index ee547e023ca6..01d0f64a1a12 100644
--- a/textproc/py-qt4-xml/pkg-plist
+++ b/textproc/py-qt4-xml/pkg-plist
@@ -1,10 +1,10 @@
bin/pylupdate4
bin/pyrcc4
%%PYTHON_SITELIBDIR%%/PyQt4/QtXml.so
-%%SIP%%share/py-sip/QtXml/QtXmlmod.sip
-%%SIP%%share/py-sip/QtXml/qdom.sip
-%%SIP%%share/py-sip/QtXml/qxml.sip
-%%SIP%%share/py-sip/QtXml/qxmlstream.sip
+share/py-sip/QtXml/QtXmlmod.sip
+share/py-sip/QtXml/qdom.sip
+share/py-sip/QtXml/qxml.sip
+share/py-sip/QtXml/qxmlstream.sip
%%API%%share/qt4/qsci/api/python/QtXml.api
-%%SIP%%@dirrm share/py-sip/QtXml
+@dirrm share/py-sip/QtXml
@dirrmtry %%PYTHON_SITELIBDIR%%/PyQt4
diff --git a/textproc/py-qt4-xmlpatterns/Makefile b/textproc/py-qt4-xmlpatterns/Makefile
index 0b61dbe05670..07b0fedf2b36 100644
--- a/textproc/py-qt4-xmlpatterns/Makefile
+++ b/textproc/py-qt4-xmlpatterns/Makefile
@@ -23,29 +23,28 @@ HAS_CONFIGURE= yes
USE_PYTHON= 2.5+
USE_QT4= xmlpatterns qmake_build
-OPTIONS= API "Install QtXml API for QScintilla2" on \
- DEBUG "Enable debugging in generated code" off \
- SIPFILES "Install the QtXml SIP files" on \
- TRACING "Enable tracing in generated code" off
+OPTIONS= API "Install QtXml API for QScintilla2" on
PATCHDIR= ${PORTSDIR}/devel/py-qt4-core/files
OPTIONSFILE?= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
SIPDIR= ${PREFIX}/share/py-sip
QSCIDIR= ${PREFIX}/share/qt4/qsci
CONFIGURE_ENV+= PYQT4_COMPONENT="${PORTNAME}"
-ARGS= -b ${PREFIX}/bin\
- -d ${PYTHONPREFIX_SITELIBDIR}\
- -p ${PREFIX}/${QT_PLUGINDIR_REL}\
- -q ${QMAKE}\
- --confirm-license\
+ARGS= -b ${PREFIX}/bin \
+ -d ${PYTHONPREFIX_SITELIBDIR} \
+ -p ${PREFIX}/${QT_PLUGINDIR_REL} \
+ -q ${QMAKE} \
+ --confirm-license \
+ --sipdir ${SIPDIR} \
--enable QtXmlPatterns
+.if defined(WITH_DEBUG)
+ARGS+= --debug --trace
+.endif
+
.include "../../devel/py-sip/files/bsd.pyqt.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
-ARGS+= --debug
-.endif
.if defined(WITHOUT_API)
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
@@ -54,16 +53,6 @@ LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
-.if defined(WITHOUT_SIPFILES)
-ARGS+= --no-sip-files
-PLIST_SUB+= SIP="@comment "
-.else
-ARGS+= --sipdir ${SIPDIR}
-PLIST_SUB+= SIP=""
-.endif
-.if defined(WITH_TRACING)
-ARGS+= --trace
-.endif
do-configure:
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV}\
diff --git a/textproc/py-qt4-xmlpatterns/pkg-plist b/textproc/py-qt4-xmlpatterns/pkg-plist
index aecc7b4a2380..c3abc1f8d997 100644
--- a/textproc/py-qt4-xmlpatterns/pkg-plist
+++ b/textproc/py-qt4-xmlpatterns/pkg-plist
@@ -1,19 +1,19 @@
%%PYTHON_SITELIBDIR%%/PyQt4/QtXmlPatterns.so
-%%SIP%%share/py-sip/QtXmlPatterns/QtXmlPatternsmod.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qabstractmessagehandler.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qabstracturiresolver.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qabstractxmlnodemodel.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qabstractxmlreceiver.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qsimplexmlnodemodel.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qsourcelocation.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qxmlformatter.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qxmlname.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qxmlnamepool.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qxmlquery.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qxmlresultitems.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qxmlschema.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qxmlschemavalidator.sip
-%%SIP%%share/py-sip/QtXmlPatterns/qxmlserializer.sip
+share/py-sip/QtXmlPatterns/QtXmlPatternsmod.sip
+share/py-sip/QtXmlPatterns/qabstractmessagehandler.sip
+share/py-sip/QtXmlPatterns/qabstracturiresolver.sip
+share/py-sip/QtXmlPatterns/qabstractxmlnodemodel.sip
+share/py-sip/QtXmlPatterns/qabstractxmlreceiver.sip
+share/py-sip/QtXmlPatterns/qsimplexmlnodemodel.sip
+share/py-sip/QtXmlPatterns/qsourcelocation.sip
+share/py-sip/QtXmlPatterns/qxmlformatter.sip
+share/py-sip/QtXmlPatterns/qxmlname.sip
+share/py-sip/QtXmlPatterns/qxmlnamepool.sip
+share/py-sip/QtXmlPatterns/qxmlquery.sip
+share/py-sip/QtXmlPatterns/qxmlresultitems.sip
+share/py-sip/QtXmlPatterns/qxmlschema.sip
+share/py-sip/QtXmlPatterns/qxmlschemavalidator.sip
+share/py-sip/QtXmlPatterns/qxmlserializer.sip
%%API%%share/qt4/qsci/api/python/QtXmlPatterns.api
-%%SIP%%@dirrm share/py-sip/QtXmlPatterns
+@dirrm share/py-sip/QtXmlPatterns
@dirrmtry %%PYTHON_SITELIBDIR%%/PyQt4