aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-31 22:22:54 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-31 22:22:54 +0000
commita06f3ec5bc4789d4e82fae75cadab4cd9cb9d24e (patch)
tree017da5f38834a8077cd0851fe4436495c3bffe29 /textproc
parent97b84588d27b313f20c5a5f4cc5878b69673c921 (diff)
downloadports-a06f3ec5bc4789d4e82fae75cadab4cd9cb9d24e.tar.gz
ports-a06f3ec5bc4789d4e82fae75cadab4cd9cb9d24e.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rubygem-liquid-tag-parser/Makefile22
-rw-r--r--textproc/rubygem-liquid-tag-parser/distinfo3
-rw-r--r--textproc/rubygem-liquid-tag-parser/pkg-descr7
4 files changed, 33 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index be9224b0bda4..c11418769d0c 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1525,6 +1525,7 @@
SUBDIR += rubygem-libxml-ruby
SUBDIR += rubygem-linguistics
SUBDIR += rubygem-liquid
+ SUBDIR += rubygem-liquid-tag-parser
SUBDIR += rubygem-loggability
SUBDIR += rubygem-loofah
SUBDIR += rubygem-ltsv
diff --git a/textproc/rubygem-liquid-tag-parser/Makefile b/textproc/rubygem-liquid-tag-parser/Makefile
new file mode 100644
index 000000000000..03dfc17a1513
--- /dev/null
+++ b/textproc/rubygem-liquid-tag-parser/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= liquid-tag-parser
+PORTVERSION= 1.8.0
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Parse liquid tags easily
+
+LICENSE= MIT
+
+BUILD_DEPENDS= rubygem-rdoc>=5.0.0:devel/rubygem-rdoc
+RUN_DEPENDS= rubygem-extras>=0.3:devel/rubygem-extras \
+ rubygem-liquid>=3.0:textproc/rubygem-liquid
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-liquid-tag-parser/distinfo b/textproc/rubygem-liquid-tag-parser/distinfo
new file mode 100644
index 000000000000..3b55f6389559
--- /dev/null
+++ b/textproc/rubygem-liquid-tag-parser/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511439506
+SHA256 (rubygem/liquid-tag-parser-1.8.0.gem) = 835a3e313112c798c2961108c60705d7ec105fa03455fe356409de6dcbd57fe9
+SIZE (rubygem/liquid-tag-parser-1.8.0.gem) = 7168
diff --git a/textproc/rubygem-liquid-tag-parser/pkg-descr b/textproc/rubygem-liquid-tag-parser/pkg-descr
new file mode 100644
index 000000000000..1902dee44de1
--- /dev/null
+++ b/textproc/rubygem-liquid-tag-parser/pkg-descr
@@ -0,0 +1,7 @@
+Liquid Tag parser provides a robust interface to parsing your tag syntax in a
+way that makes sense, it uses Shellwords, along with escapes to allow users to
+do extremely robust arguments, giving you back a hash, that you get to play
+with. It also has the concept of argv1, deep hashes, and even defaults if you
+give them to us.
+
+WWW: https://github.com/envygeeks/liquid-tag-parser