aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-02-13 11:27:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-02-13 11:27:29 +0000
commitc6cad2390f239de2f68cc73bd2361ff4a9a57336 (patch)
treef2e51cd3c44344b14f206fe5f609de465255cfc3 /textproc
parentc29b862b754d453c9fe092c9694c15d6f235c15a (diff)
downloadports-c6cad2390f239de2f68cc73bd2361ff4a9a57336.tar.gz
ports-c6cad2390f239de2f68cc73bd2361ff4a9a57336.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/xml-commons/Makefile30
-rw-r--r--textproc/xml-commons/distinfo3
-rw-r--r--textproc/xml-commons/pkg-descr11
4 files changed, 45 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index dabe18bb7a5e..715ed42248f3 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1226,6 +1226,7 @@
SUBDIR += xlhtml
SUBDIR += xlreader
SUBDIR += xls2xml
+ SUBDIR += xml-commons
SUBDIR += xml-i18n-tools
SUBDIR += xml-lite.el
SUBDIR += xml-parse.el
diff --git a/textproc/xml-commons/Makefile b/textproc/xml-commons/Makefile
new file mode 100644
index 000000000000..bd400edb32a8
--- /dev/null
+++ b/textproc/xml-commons/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xml-commons
+# Date created: 11 February 2010
+# Whom: rfarmer@predatorlabs.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= xml-commons
+PORTVERSION= 1.4.01
+CATEGORIES= textproc java
+MASTER_SITES= APACHE/xml/commons
+DISTNAME= ${PORTNAME}-external-${PORTVERSION}
+EXTRACT_SUFX= -bin.tar.gz
+
+MAINTAINER= rfarmer@predatorlabs.net
+COMMENT= Provides common XML code for Apache projects
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+JAVA_RUN= yes
+NO_BUILD= yes
+
+PLIST_FILES= %%JAVAJARDIR%%/xml-apis-ext.jar \
+ %%JAVAJARDIR%%/xml-apis.jar
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/xml-apis-ext.jar ${JAVAJARDIR}
+ ${INSTALL_DATA} ${WRKSRC}/xml-apis.jar ${JAVAJARDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/xml-commons/distinfo b/textproc/xml-commons/distinfo
new file mode 100644
index 000000000000..43720a526a6a
--- /dev/null
+++ b/textproc/xml-commons/distinfo
@@ -0,0 +1,3 @@
+MD5 (xml-commons-external-1.4.01-bin.tar.gz) = 8bd2f6634886c9f5dc88fb3e9181d714
+SHA256 (xml-commons-external-1.4.01-bin.tar.gz) = a22c64d0a95d09c74ba322196b3eac5eab38e2896ecb95056dab7eeaff2daaaf
+SIZE (xml-commons-external-1.4.01-bin.tar.gz) = 1610345
diff --git a/textproc/xml-commons/pkg-descr b/textproc/xml-commons/pkg-descr
new file mode 100644
index 000000000000..499fd4bfb51c
--- /dev/null
+++ b/textproc/xml-commons/pkg-descr
@@ -0,0 +1,11 @@
+xml-commons is focussed on common code and guidelines for xml projects. The
+first focus will be to organize and have common packaging for the various
+externally-defined standards code relating to XML - things like the DOM,
+SAX, and JAXP interfaces.
+
+As the xml-commons community forms, we also hope to serve as a holding area
+for other common xml-related utilities and code, and to help promulgate
+common packaging, testing, documentation, and other guidelines across all
+xml.apache.org subprojects.
+
+WWW: http://xml.apache.org/commons/