aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-12-31 12:51:16 +0000
committerRene Ladan <rene@FreeBSD.org>2020-12-31 12:51:16 +0000
commit45e5de12ae2201d7e2d92a4bdb4009cee80273d4 (patch)
treeee591ec39f80cd5eadf410872de224d87c24533c /textproc
parent7a1e6c657f98cb39c805643372b6671059396ec6 (diff)
downloadports-45e5de12ae2201d7e2d92a4bdb4009cee80273d4.tar.gz
ports-45e5de12ae2201d7e2d92a4bdb4009cee80273d4.zip
Fix bad MOVED commit.
Pointy hat: rene
Notes
Notes: svn path=/head/; revision=559732
Diffstat (limited to 'textproc')
-rw-r--r--textproc/docproj/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/textproc/docproj/Makefile b/textproc/docproj/Makefile
index 3a853a232be9..1f7ca0a4c94e 100644
--- a/textproc/docproj/Makefile
+++ b/textproc/docproj/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= docproj
-PORTVERSION= 2.0
-PORTREVISION= 14
+PORTVERSION= 2.1
CATEGORIES= textproc
MAINTAINER= doceng@FreeBSD.org
@@ -26,19 +25,16 @@ RUN_DEPENDS= ${LOCALBASE}/share/xml/dtd/xhtml/xhtml.soc:textproc/xhtml \
USES= ghostscript:run metaport perl5
USE_PERL5= run
-OPTIONS_DEFINE= CJK DBLATEX FOP GROFF IGOR JING SVN TRANSLATOR
-OPTIONS_DEFAULT= CJK GROFF IGOR TRANSLATOR
-.if !exists(/usr/bin/svnlite) && !exists(/usr/bin/svn)
-OPTIONS_DEFAULT+= SVN
-.endif
+OPTIONS_DEFINE= CJK DBLATEX FOP GIT GROFF IGOR JING TRANSLATOR
+OPTIONS_DEFAULT= CJK GIT GROFF IGOR TRANSLATOR
CJK_DESC= CJK support
DBLATEX_DESC= dblatex PDF renderer (experimental, requires TeXLive)
FOP_DESC= FOP PDF renderer (requires Java)
+GIT_DESC= Git support from ports
GROFF_DESC= Groff support from ports
IGOR_DESC= Igor automated proofreader for documentation
JING_DESC= Jing for advanced RELAX NG validation
-SVN_DESC= Subversion support from ports
TRANSLATOR_DESC= Tools for translators
CJK_RUN_DEPENDS= html2text:textproc/html2text
@@ -46,10 +42,10 @@ DBLATEX_RUN_DEPENDS= dblatex:textproc/dblatex
DBLATEX_USE= TEX=xetex
FOP_RUN_DEPENDS= ${_FONTS} \
fop:textproc/fop
+GIT_RUN_DEPENDS= git:devel/git
GROFF_USES= groff:run
IGOR_RUN_DEPENDS= igor:textproc/igor
JING_RUN_DEPENDS= jing:textproc/jing
-SVN_RUN_DEPENDS= ${LOCALBASE}/bin/svn:devel/subversion
TRANSLATOR_RUN_DEPENDS= itstool:textproc/itstool \
msgcat:devel/gettext-tools
@@ -65,7 +61,7 @@ _FONTS_CJK= ${LOCALBASE}/share/fonts/ipa/ipam.otf:japanese/font-ipa \
.if ${PORT_OPTIONS:MFOP} || ${PORT_OPTIONS:MDBLATEX}
ONLY_FOR_ARCHS= amd64 i386
-CJK_RUN_DEPENDS= ${_FONTS_CJK}
+CJK_RUN_DEPENDS+= ${_FONTS_CJK}
.endif
# generate MINIMALDOCPORTS for src/release/Makefile.inc.docports.