aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-09-02 17:49:07 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-09-02 17:49:07 +0000
commit309d264df7a9348134821177ee65cd51e9f99e09 (patch)
tree7c04abd3e75e774e048b519cc0ed667d8faeb41b /textproc
parent85a1c744e3b81d8071f24e0f43227fbc90ec7329 (diff)
downloadports-309d264df7a9348134821177ee65cd51e9f99e09.tar.gz
ports-309d264df7a9348134821177ee65cd51e9f99e09.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/minised/Makefile27
-rw-r--r--textproc/minised/distinfo3
-rw-r--r--textproc/minised/pkg-descr16
4 files changed, 47 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 30e8f98ccc3a..2e52d8ddab39 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -279,6 +279,7 @@
SUBDIR += mifluz
SUBDIR += mini-xml
SUBDIR += minidom
+ SUBDIR += minised
SUBDIR += mk-aspell
SUBDIR += mkcatalog
SUBDIR += mn-aspell
diff --git a/textproc/minised/Makefile b/textproc/minised/Makefile
new file mode 100644
index 000000000000..8e692a5baf89
--- /dev/null
+++ b/textproc/minised/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: minised
+# Date created: 2 September 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= minised
+PORTVERSION= 1.9
+CATEGORIES= textproc
+MASTER_SITES= http://dl.exactcode.de/oss/minised/ CSME
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Smaller, cheaper, faster sed implementation
+
+ALL_TARGET= ${PORTNAME}
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/LFLAGS/LDFLAGS/' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/textproc/minised/distinfo b/textproc/minised/distinfo
new file mode 100644
index 000000000000..141b4de28cd5
--- /dev/null
+++ b/textproc/minised/distinfo
@@ -0,0 +1,3 @@
+MD5 (minised-1.9.tar.gz) = 09f329037974270a30d6241401633c66
+SHA256 (minised-1.9.tar.gz) = 06d345715903e56a146fb2e352a3915acdaf1113b95fe84f50e8bf082661e1c2
+SIZE (minised-1.9.tar.gz) = 26831
diff --git a/textproc/minised/pkg-descr b/textproc/minised/pkg-descr
new file mode 100644
index 000000000000..f376d05e4413
--- /dev/null
+++ b/textproc/minised/pkg-descr
@@ -0,0 +1,16 @@
+This is a smaller, cheaper, faster SED implementation. Minix uses it. GNU
+used to use it, until they built their own sed around an extended (some
+would say over-extended) regexp package.
+
+For embedded use we searched for a tiny sed implementation especially for
+use with the dietlibc and found Eric S. Raymond's sed implementation quite
+handy. Though it suffered several bugs and was not under active maintenance
+anymore. After sending a bunch of fixes we agreed to continue maintaining
+this lovely, historic sed implementation.
+
+Along a lot fixes and cleanups, further speedups, and some missing features
+and POSIX conformance, we also added a test-suite to the package, so
+regressions are quickly and easily uncovered.
+
+WWW: http://www.exactcode.de/oss/minised/
+Author: ExactCode <info@exactcode.de>