aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2016-12-08 14:33:51 +0000
committerLars Engels <lme@FreeBSD.org>2016-12-08 14:33:51 +0000
commit803483e33ea91003ced24df77f31badcdb1c9d04 (patch)
tree0f1037da7f14ff03582e63d43336fada1d1ffd24 /textproc
parent09256983f9fde8f6ad67573dbda435156cfafd1c (diff)
downloadports-803483e33ea91003ced24df77f31badcdb1c9d04.tar.gz
ports-803483e33ea91003ced24df77f31badcdb1c9d04.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/qrcodegen/Makefile44
-rw-r--r--textproc/qrcodegen/distinfo3
-rw-r--r--textproc/qrcodegen/files/qrcodegen.in6
-rw-r--r--textproc/qrcodegen/pkg-descr23
-rw-r--r--textproc/qrcodegen/pkg-plist6
6 files changed, 83 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index a8db636f6938..cb9b4159792c 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1350,6 +1350,7 @@
SUBDIR += py3-pager
SUBDIR += pychm
SUBDIR += qprint
+ SUBDIR += qrcodegen
SUBDIR += qstardict
SUBDIR += qt4-xml
SUBDIR += qt4-xmlpatterns
diff --git a/textproc/qrcodegen/Makefile b/textproc/qrcodegen/Makefile
new file mode 100644
index 000000000000..7520d378cc12
--- /dev/null
+++ b/textproc/qrcodegen/Makefile
@@ -0,0 +1,44 @@
+# Created by: Lars Engels <lme@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= qrcodegen
+PORTVERSION= 1.14.2
+CATEGORIES= textproc java
+MASTER_SITES= http://bsd-geek.de/FreeBSD/distfiles/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= lme@FreeBSD.org
+COMMENT= GUI to generate QR codes
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+NO_BUILD= yes
+USES= zip:infozip
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+SUB_FILES= qrcodegen
+
+INSTALLFILES= FAQ.txt Installation.txt NOTICE QRCodeGen.jar Version.html
+
+DESKTOP_ENTRIES="Portable QR-Code Generator" \
+ "${COMMENT}" \
+ "" \
+ "qrcodegen" \
+ "Utility;2DGraphics;Java;" \
+ false
+
+do-extract:
+ @${RM} -r ${WRKDIR}
+ @${MKDIR} ${WRKSRC}
+ @${UNZIP_CMD} -q -j -d ${WRKSRC} ${DISTDIR}/${EXTRACT_ONLY}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+.for i in ${INSTALLFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DATADIR}/
+.endfor
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/textproc/qrcodegen/distinfo b/textproc/qrcodegen/distinfo
new file mode 100644
index 000000000000..eb49c5ef9bcc
--- /dev/null
+++ b/textproc/qrcodegen/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481205035
+SHA256 (qrcodegen_1.14.2.zip) = 48144b8d2f309f4324a85fcd7261244581678fb438a0a49f3a84b8ffcf07b09b
+SIZE (qrcodegen_1.14.2.zip) = 697748
diff --git a/textproc/qrcodegen/files/qrcodegen.in b/textproc/qrcodegen/files/qrcodegen.in
new file mode 100644
index 000000000000..71cb66d6665f
--- /dev/null
+++ b/textproc/qrcodegen/files/qrcodegen.in
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+cd %%DATADIR%%
+JAVA_VERSION="%%JAVA_VERSION%%" exec %%LOCALBASE%%/bin/java \
+ -jar QRCodeGen.jar "$@"
+
diff --git a/textproc/qrcodegen/pkg-descr b/textproc/qrcodegen/pkg-descr
new file mode 100644
index 000000000000..be6bff8998ba
--- /dev/null
+++ b/textproc/qrcodegen/pkg-descr
@@ -0,0 +1,23 @@
+The 'Portable QR-Code Generator' is a free Java program which generates QR
+Codes from
+
+- WLAN credentials: SSID, network key and and network type
+ (WEP, WPA/WPA2, not encrypted)
+- VCard-Import
+ o Inlined images can optionally be removed to reduce the size of the
+ generated QR Code
+ o VCards up to version 3 (inclusive) are supported
+ o You can import the cards via drag&drop or by selecting them in a file
+ chooser dialog
+ o Supports a broad range of character encodings (ISO-8859-1, UTF-8, UTF-16,)
+ the actual number depends on the Java Virtual Machine you are using.
+- VCard generator
+- e-mail addresses
+- URLs
+- free text
+- geographic coordinates
+
+The QR Code can be printed, saved as BMP, GIF or PNG, or copied to clipboard to
+use in other applications.
+
+WWW: https://sites.google.com/site/qrcodeforwn/home/qr-code-generator-for-wireless-networks
diff --git a/textproc/qrcodegen/pkg-plist b/textproc/qrcodegen/pkg-plist
new file mode 100644
index 000000000000..82eb9d41d353
--- /dev/null
+++ b/textproc/qrcodegen/pkg-plist
@@ -0,0 +1,6 @@
+bin/qrcodegen
+%%DATADIR%%/FAQ.txt
+%%DATADIR%%/Installation.txt
+%%DATADIR%%/NOTICE
+%%DATADIR%%/QRCodeGen.jar
+%%DATADIR%%/Version.html