aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-01 12:26:26 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-01 12:26:26 +0000
commitb83b882d467f5be4245203fab737aa8bdca5619f (patch)
tree9a69b95b09c958e506364d5fa549646904b1ebcd /textproc
parent39761517a6d2d759a1b25f22a8f6c1b7bb85c3cf (diff)
downloadports-b83b882d467f5be4245203fab737aa8bdca5619f.tar.gz
ports-b83b882d467f5be4245203fab737aa8bdca5619f.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-Literal/Makefile28
-rw-r--r--textproc/p5-XML-Literal/distinfo3
-rw-r--r--textproc/p5-XML-Literal/pkg-descr8
-rw-r--r--textproc/p5-XML-Literal/pkg-plist6
5 files changed, 46 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 808e46805a57..4741a69b85ad 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -589,6 +589,7 @@
SUBDIR += p5-XML-LibXML-XPathContext
SUBDIR += p5-XML-LibXSLT
SUBDIR += p5-XML-Liberal
+ SUBDIR += p5-XML-Literal
SUBDIR += p5-XML-Mini
SUBDIR += p5-XML-NamespaceSupport
SUBDIR += p5-XML-Node
diff --git a/textproc/p5-XML-Literal/Makefile b/textproc/p5-XML-Literal/Makefile
new file mode 100644
index 000000000000..cff96c47b73b
--- /dev/null
+++ b/textproc/p5-XML-Literal/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-XML-Literal
+# Date created: 2006-08-01
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Literal
+PORTVERSION= 0.01
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Syntax suppor for XML literals
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Literal.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6.0 or newer, install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-Literal/distinfo b/textproc/p5-XML-Literal/distinfo
new file mode 100644
index 000000000000..ad7b5066a12b
--- /dev/null
+++ b/textproc/p5-XML-Literal/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-Literal-0.01.tar.gz) = ab95fe07e61aa7525250546d7c9a97c8
+SHA256 (XML-Literal-0.01.tar.gz) = 0f87fce67b76334ae22bd0e01b2b425244780107cb92817568acd18d76b17b9d
+SIZE (XML-Literal-0.01.tar.gz) = 24468
diff --git a/textproc/p5-XML-Literal/pkg-descr b/textproc/p5-XML-Literal/pkg-descr
new file mode 100644
index 000000000000..68cb85d1f7da
--- /dev/null
+++ b/textproc/p5-XML-Literal/pkg-descr
@@ -0,0 +1,8 @@
+This module takes one function at its use line. Afterwards, all
+single-line <...> calls that looks like a XML literal will be
+processed with that function, instead of the built-in shell glob.
+
+Support for qx<...> overriding for multiline XML literals is planned
+for Perl 5.10.
+
+WWW: http://search.cpan.org/dist/XML-Literal/
diff --git a/textproc/p5-XML-Literal/pkg-plist b/textproc/p5-XML-Literal/pkg-plist
new file mode 100644
index 000000000000..dcc970da6918
--- /dev/null
+++ b/textproc/p5-XML-Literal/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Literal/.packlist
+%%SITE_PERL%%/XML/Literal.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Literal
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML