aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-08-19 06:01:46 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-08-19 06:01:46 +0000
commitc31f4d547d4e920339967e330f390f986a0f750e (patch)
tree2102fa2b84e3234a52165621e5cab885cdbf4197 /textproc
parentdf09ef5a58d00770c7a0d3513c6c8005d8c32504 (diff)
downloadports-c31f4d547d4e920339967e330f390f986a0f750e.tar.gz
ports-c31f4d547d4e920339967e330f390f986a0f750e.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/openfts/Makefile53
-rw-r--r--textproc/openfts/distinfo1
-rw-r--r--textproc/openfts/pkg-descr7
-rw-r--r--textproc/openfts/pkg-plist38
5 files changed, 100 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 0d66967f14f5..cb5e48daedd9 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -160,6 +160,7 @@
SUBDIR += no-aspell
SUBDIR += ocaml-pxp
SUBDIR += ocaml-yaxpo
+ SUBDIR += openfts
SUBDIR += openjade
SUBDIR += opensched
SUBDIR += opensp
diff --git a/textproc/openfts/Makefile b/textproc/openfts/Makefile
new file mode 100644
index 000000000000..515f9ff9f5f9
--- /dev/null
+++ b/textproc/openfts/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: OpenFTS
+# Date Created: 15 Aug, 2003
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openfts
+PORTVERSION= 0.34
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= openfts
+PKGNAMEPREFIX= p5-
+DISTNAME= Search-OpenFTS-${PORTVERSION}
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Open Source Full Text Search engine
+
+EXTRACT_DEPENDS=/nonexistent:${PORTSDIR}/databases/postgresql7:configure
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+
+PERL_CONFIGURE= yes
+USE_REINPLACE= yes
+
+MAN3= Search::OpenFTS.3 Search::OpenFTS::Base.3 \
+ Search::OpenFTS::Dict::PorterEng.3 Search::OpenFTS::Dict::Snowball.3 \
+ Search::OpenFTS::Dict::UnknownDict.3 Search::OpenFTS::Index.3 \
+ Search::OpenFTS::Morph::ISpell.3 Search::OpenFTS::Parser.3
+
+PGSRC= `cd ${PORTSDIR}/databases/postgresql7; ${MAKE} -VWRKSRC`/contrib
+PGMAKE= ${GMAKE} docdir=${PREFIX}/share/doc
+
+post-extract:
+ cd ${WRKSRC} && ${CP} -r pgsql_contrib_openfts ${PGSRC}/
+
+post-build:
+ cd ${PGSRC}/tsearch && ${GMAKE} && \
+ ${REINPLACE_CMD} 's,$$libdir,${PREFIX}/lib/postgresql,' tsearch.sql
+ cd ${PGSRC}/pgsql_contrib_openfts && ${GMAKE}
+
+post-install:
+ cd ${PGSRC}/tsearch && ${PGMAKE} install
+ cd ${PGSRC}/pgsql_contrib_openfts && ${PGMAKE} install
+
+# Sample DB initialization.
+DBNAME?= openfts
+create-database:
+ createdb ${DBNAME}
+ cd ${PREFIX}/share/postgresql/contrib && \
+ psql ${DBNAME} < tsearch.sql && \
+ psql ${DBNAME} < openfts.sql
+
+.include <bsd.port.mk>
diff --git a/textproc/openfts/distinfo b/textproc/openfts/distinfo
new file mode 100644
index 000000000000..428933ec4c2c
--- /dev/null
+++ b/textproc/openfts/distinfo
@@ -0,0 +1 @@
+MD5 (Search-OpenFTS-0.34.tar.gz) = a9b264ba8a3e3ffe108137bea5d74afa
diff --git a/textproc/openfts/pkg-descr b/textproc/openfts/pkg-descr
new file mode 100644
index 000000000000..8c615cf4eac5
--- /dev/null
+++ b/textproc/openfts/pkg-descr
@@ -0,0 +1,7 @@
+OpenFTS (Open Source Full Text Search engine) is an advanced
+PostgreSQL-based search engine that provides online indexing of data
+and relevance ranking for database searching.
+Close integration with database allows use of metadata to restrict
+search results.
+
+WWW: http://openfts.sourceforge.net/
diff --git a/textproc/openfts/pkg-plist b/textproc/openfts/pkg-plist
new file mode 100644
index 000000000000..450880d8cbe6
--- /dev/null
+++ b/textproc/openfts/pkg-plist
@@ -0,0 +1,38 @@
+lib/postgresql/openfts.so
+lib/postgresql/tsearch.so
+share/doc/postgresql/contrib/README.openfts
+share/doc/postgresql/contrib/README.tsearch
+share/postgresql/contrib/openfts.sql
+share/postgresql/contrib/tsearch.sql
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Base.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Dict/PorterEng.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Dict/Snowball.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Dict/UnknownDict.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Index.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Morph/ISpell.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Parser.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Dict/PorterEng/PorterEng.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Dict/PorterEng/PorterEng.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Dict/PorterEng/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Morph/ISpell/ISpell.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Morph/ISpell/ISpell.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Morph/ISpell/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Parser/Parser.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Parser/Parser.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Parser/autosplit.ix
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Dict/PorterEng
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Dict
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Morph/ISpell
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Morph
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Parser
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Dict
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS/Morph
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Search 2>/dev/null
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search 2>/dev/null
+@dirrm share/doc/postgresql/contrib
+@dirrm share/doc/postgresql
+@dirrm share/postgresql/contrib