aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-05-28 12:40:05 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-05-28 12:40:05 +0000
commitf945c80e689506122c26339aba9e49cb3176f705 (patch)
treee770596e415cdca461917e65fb904c981ef2aef1 /textproc
parent9680598cb00cd438614e5b1fc47e62646a682803 (diff)
downloadports-f945c80e689506122c26339aba9e49cb3176f705.tar.gz
ports-f945c80e689506122c26339aba9e49cb3176f705.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xmlto/Makefile41
-rw-r--r--textproc/xmlto/files/patch-xmlto.in12
-rw-r--r--textproc/xmlto/pkg-descr4
-rw-r--r--textproc/xmlto/pkg-plist8
4 files changed, 42 insertions, 23 deletions
diff --git a/textproc/xmlto/Makefile b/textproc/xmlto/Makefile
index 671efccdc72a..69a879c47860 100644
--- a/textproc/xmlto/Makefile
+++ b/textproc/xmlto/Makefile
@@ -5,15 +5,14 @@
# $FreeBSD$
#
-# The following compile-time options are available:
-# WITH_PASSIVETEX Enable PassiveTex support for DVI/PDF/PS output
-
PORTNAME= xmlto
PORTVERSION= 0.0.20
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://cyberelk.net/tim/data/xmlto/stable/
+# Master Site is subject to change with 0.0.21 release
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= matthias.andree@gmx.de
COMMENT= Front-end to an XSL toolchain
BUILD_DEPENDS= ${BASH_CMD}:${PORTSDIR}/shells/bash \
@@ -23,12 +22,7 @@ BUILD_DEPENDS= ${BASH_CMD}:${PORTSDIR}/shells/bash \
${XSL_DIR}:${PORTSDIR}/textproc/docbook-xsl
RUN_DEPENDS= ${BUILD_DEPENDS}
-.if defined(WITH_PASSIVETEX) || exists(${PASSIVETEX})
-BUILD_DEPENDS+= ${PASSIVETEX}:${PORTSDIR}/print/passivetex
-PLIST_SUB= PASSIVETEX=""
-.else
-PLIST_SUB= PASSIVETEX="@comment "
-.endif
+OPTIONS= PASSIVETEX "Enable PassiveTeX support for DVI/PS/PDF" OFF
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -37,15 +31,30 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
BASH_CMD= ${LOCALBASE}/bin/bash
GETOPT_CMD= ${LOCALBASE}/bin/getopt
-PASSIVETEX?= mktexlsr
XSL_DIR= ${LOCALBASE}/share/xsl/docbook
MAN1= xmlif.1 xmlto.1
-DOCS= AUTHORS NEWS
+PORTDOCS= AUTHORS COPYING ChangeLog NEWS THANKS
+# these two documentation files do not convey information useful for
+# the FreeBSD port at this time:
+# PORTDOCS+= FAQ README
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PASSIVETEX)
+BUILD_DEPENDS+= ${LOCALBASE}/share/texmf-local/tex/passivetex/fotex.sty:${PORTSDIR}/print/passivetex
+RUN_DEPENDS+= ${LOCALBASE}/share/texmf-local/tex/passivetex/fotex.sty:${PORTSDIR}/print/passivetex
+PLIST_SUB= PASSIVETEX=""
+.else
+PLIST_SUB= PASSIVETEX="@comment "
+.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-a|-PpR|' \
- ${WRKSRC}/format/docbook/man
+.for i in docbook/htmlhelp docbook/xhtml-nochunks docbook/javahelp \
+ docbook/html docbook/html-nochunks docbook/xhtml docbook/fo \
+ docbook/man fo/dvi fo/pdf
+ @${REINPLACE_CMD} -e 's|-a|-PpR|' ${WRKSRC}/format/${i}
+.endfor
.if !defined(WITH_PASSIVETEX)
@${REINPLACE_CMD} -e '/format\/fo\//d' ${WRKSRC}/Makefile.in
.endif
@@ -57,7 +66,7 @@ post-build:
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/xmlto/files/patch-xmlto.in b/textproc/xmlto/files/patch-xmlto.in
index 9688da9c45d0..87c972bc773e 100644
--- a/textproc/xmlto/files/patch-xmlto.in
+++ b/textproc/xmlto/files/patch-xmlto.in
@@ -1,8 +1,16 @@
---- xmlto.in.orig Mon Jan 5 09:20:01 2004
-+++ xmlto.in Mon Jan 5 09:20:32 2004
+--- xmlto.in.orig 2008-01-17 10:39:02.000000000 +0100
++++ xmlto.in 2008-05-25 13:43:48.000000000 +0200
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!@BASH@
#
# @PACKAGE@ - apply an XSL stylesheet to an XML document
# Copyright (C) 2001, 2002, 2003 Tim Waugh <twaugh@redhat.com>
+@@ -326,6 +326,7 @@
+ # Ask the format script what stylesheet to use.
+ XSLT_PROCESSOR=xsltproc # We only know about xsltproc right now.
+ export XSLT_PROCESSOR
++export USE_BACKEND
+ if [ -z "$STYLESHEET" ]
+ then
+ STYLESHEET="$(${BASH} "$FORMAT" stylesheet)" || exit 1
diff --git a/textproc/xmlto/pkg-descr b/textproc/xmlto/pkg-descr
index ce2836f25255..ef0f94b458ee 100644
--- a/textproc/xmlto/pkg-descr
+++ b/textproc/xmlto/pkg-descr
@@ -8,5 +8,5 @@ htmlhelp, javahelp, man, pdf, ps, txt, xhtml, xhtml-nochunks.
Currently the only XSL-T processor supported is xsltproc (textproc/libxslt).
For DVI, PDF and PostScript output, PassiveTeX (print/passivetex) is required.
-Author: Tim Waugh <tim@cyberelk.net>
-WWW: http://cyberelk.net/tim/software/xmlto/
+Authors: Tim Waugh <tim@cyberelk.net>, Ondrej Vasik <ovasik@redhat.com>
+WWW: http://cyberelk.net/tim/software/xmlto/
diff --git a/textproc/xmlto/pkg-plist b/textproc/xmlto/pkg-plist
index 6f2d34f491ff..39e390c52778 100644
--- a/textproc/xmlto/pkg-plist
+++ b/textproc/xmlto/pkg-plist
@@ -1,9 +1,6 @@
@comment $FreeBSD$
bin/xmlif
bin/xmlto
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%DATADIR%%/format/docbook/awt
%%DATADIR%%/format/docbook/dvi
%%DATADIR%%/format/docbook/fo
@@ -21,9 +18,14 @@ bin/xmlto
%%DATADIR%%/format/docbook/htmlhelp
%%DATADIR%%/format/docbook/javahelp
@dirrm %%DATADIR%%/format/docbook
+%%PASSIVETEX%%%%DATADIR%%/format/fo/awt
%%PASSIVETEX%%%%DATADIR%%/format/fo/dvi
+%%PASSIVETEX%%%%DATADIR%%/format/fo/mif
+%%PASSIVETEX%%%%DATADIR%%/format/fo/pcl
%%PASSIVETEX%%%%DATADIR%%/format/fo/pdf
%%PASSIVETEX%%%%DATADIR%%/format/fo/ps
+%%PASSIVETEX%%%%DATADIR%%/format/fo/svg
+%%PASSIVETEX%%%%DATADIR%%/format/fo/txt
%%PASSIVETEX%%@dirrm %%DATADIR%%/format/fo
@dirrm %%DATADIR%%/format
%%DATADIR%%/xmlto.mak