aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-27 02:10:03 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-27 02:10:03 +0000
commit2236497d167708afa55e954057ee8c88a8e6848a (patch)
treeefe78ec11221cd68932070d3b5bc3f4d0989cded /textproc
parentfed51b1c955ff122462b6cdfdd3a124db4ec76b0 (diff)
downloadports-2236497d167708afa55e954057ee8c88a8e6848a.tar.gz
ports-2236497d167708afa55e954057ee8c88a8e6848a.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/cole/Makefile18
-rw-r--r--textproc/cole/distinfo1
-rw-r--r--textproc/cole/files/patch-aa40
-rw-r--r--textproc/cole/pkg-comment1
-rw-r--r--textproc/cole/pkg-descr7
-rw-r--r--textproc/cole/pkg-plist13
7 files changed, 81 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 1875af08c2f8..25a93a45387b 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -8,6 +8,7 @@
SUBDIR += catdoc
SUBDIR += cocoon
SUBDIR += code2html
+ SUBDIR += cole
SUBDIR += dict
SUBDIR += diffstat
SUBDIR += docbook
diff --git a/textproc/cole/Makefile b/textproc/cole/Makefile
new file mode 100644
index 000000000000..1a53290b158a
--- /dev/null
+++ b/textproc/cole/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: cole
+# Version required: 2.0.1
+# Date created: 4 November 1999
+# Whom: Maxim Sobolev <sobomax@altavista.net>
+#
+# $FreeBSD$
+#
+
+DISTNAME= cole-2.0.1
+CATEGORIES= textproc
+MASTER_SITES= http://arturo.directmail.org/filters/archive/ \
+ http://homepages.go.com/~sobomax/filtersweb/
+
+MAINTAINER= sobomax@altavista.net
+
+USE_LIBTOOL= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/cole/distinfo b/textproc/cole/distinfo
new file mode 100644
index 000000000000..6abbb2d8a699
--- /dev/null
+++ b/textproc/cole/distinfo
@@ -0,0 +1 @@
+MD5 (cole-2.0.1.tar.gz) = a4e3c3571704447181e2ce045e317d1b
diff --git a/textproc/cole/files/patch-aa b/textproc/cole/files/patch-aa
new file mode 100644
index 000000000000..d7a73dcd6a8b
--- /dev/null
+++ b/textproc/cole/files/patch-aa
@@ -0,0 +1,40 @@
+--- oledecod.c.orig Thu Nov 4 14:11:11 1999
++++ oledecod.c Thu Nov 4 14:16:20 1999
+@@ -39,7 +39,7 @@
+ #include <stdarg.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <ctype.h>
+ #include <sys/types.h>
+ #include <assert.h>
+@@ -575,10 +575,12 @@
+
+ /* reorder subtrees, if there's any */
+ if (node->dir != 0xffffffffUL)
++ {
+ if (node->dir > num_of_pps || !pps_list[node->dir].name[0])
+ return 0;
+ else if (!reorder_pps_tree (&pps_list[node->dir], level + 1))
+ return 0;
++ }
+
+ /* reorder next-link subtree, saving the most next link visited */
+ if (node->next != 0xffffffffUL)
+@@ -593,6 +595,7 @@
+
+ /* move the prev child to the next link and reorder it, if there's any */
+ if (node->previous != 0xffffffffUL)
++ {
+ if (node->previous > num_of_pps || !pps_list[node->previous].name[0])
+ return 0;
+ else
+@@ -602,6 +605,7 @@
+ if (!reorder_pps_tree (&pps_list[*last_next_link_visited], level))
+ return 0;
+ }
++ }
+
+ return 1;
+ }
diff --git a/textproc/cole/pkg-comment b/textproc/cole/pkg-comment
new file mode 100644
index 000000000000..50acdb65b038
--- /dev/null
+++ b/textproc/cole/pkg-comment
@@ -0,0 +1 @@
+A free C OLE library
diff --git a/textproc/cole/pkg-descr b/textproc/cole/pkg-descr
new file mode 100644
index 000000000000..cbd5407f6008
--- /dev/null
+++ b/textproc/cole/pkg-descr
@@ -0,0 +1,7 @@
+Cole is a free C OLE library. Using cole, you can access Microsoft' `Structured
+Storage' files. The most popular Microsoft's programs generate `Structured
+Storage' files, incluiding the Microsoft' suite for offices. StarDivision'
+suite (StarOffice) generate `Structured Storage' files too. FlashPix file
+format is `Structured Storage' too.
+
+WWW: http://arturo.directmail.org/filtersweb/
diff --git a/textproc/cole/pkg-plist b/textproc/cole/pkg-plist
new file mode 100644
index 000000000000..23569068424d
--- /dev/null
+++ b/textproc/cole/pkg-plist
@@ -0,0 +1,13 @@
+bin/cole-config
+bin/cole_extract
+bin/cole_isfs
+bin/cole_isfs_fast
+bin/cole_tree
+include/cole/cole.h
+lib/libcole.a
+lib/libcole.so
+lib/libcole.so.2
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
+share/aclocal/cole.m4
+@dirrm include/cole