aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorDaniel Gerzo <danger@FreeBSD.org>2011-06-15 09:30:35 +0000
committerDaniel Gerzo <danger@FreeBSD.org>2011-06-15 09:30:35 +0000
commit4c10f7ab8275fbfb2ee4a4f40bc391708f50a99f (patch)
tree6fbbeba841aa2c52e78872ca5a2f64a2039ebdc8 /textproc
parent86efbe511820aec81d69bdb9e4a357a1914c9dc3 (diff)
downloadports-4c10f7ab8275fbfb2ee4a4f40bc391708f50a99f.tar.gz
ports-4c10f7ab8275fbfb2ee4a4f40bc391708f50a99f.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/sphinxsearch-devel/Makefile1
-rw-r--r--textproc/sphinxsearch-devel/files/patch-src-sphinxstd.h20
2 files changed, 21 insertions, 0 deletions
diff --git a/textproc/sphinxsearch-devel/Makefile b/textproc/sphinxsearch-devel/Makefile
index 0f4e4066a09d..bf3413fd6eda 100644
--- a/textproc/sphinxsearch-devel/Makefile
+++ b/textproc/sphinxsearch-devel/Makefile
@@ -9,6 +9,7 @@
PORTNAME= sphinxsearch
PORTVERSION= 2.0.1b
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= textproc databases
MASTER_SITES= http://sphinxsearch.com/files/
diff --git a/textproc/sphinxsearch-devel/files/patch-src-sphinxstd.h b/textproc/sphinxsearch-devel/files/patch-src-sphinxstd.h
new file mode 100644
index 000000000000..27c28f4b79b1
--- /dev/null
+++ b/textproc/sphinxsearch-devel/files/patch-src-sphinxstd.h
@@ -0,0 +1,20 @@
+--- src/sphinxstd.h~ 2011-04-01 16:50:14.000000000 +0000
++++ src/sphinxstd.h 2011-06-15 09:22:46.000000000 +0000
+@@ -1922,6 +1922,8 @@
+ T ReadValue() const
+ {
+ assert ( m_pValue );
++ if (!m_pValue)
++ return 0;
+ Lock();
+ T val = *m_pValue;
+ Unlock();
+@@ -1930,6 +1932,8 @@
+ void WriteValue ( const T& tNewValue )
+ {
+ assert ( m_pValue );
++ if (!m_pValue)
++ return;
+ Lock();
+ *m_pValue = tNewValue;
+ Unlock();