aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-16 16:24:07 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-16 16:24:07 +0000
commit76617ec7981b5e85f129f60fef47aa1b7afb364e (patch)
tree4ee810d52d3458fd75581dcc23cef2bbb530bfb5 /textproc
parent4d3a277c01814a92332d1aecf9f49488d7ecf82e (diff)
downloadports-76617ec7981b5e85f129f60fef47aa1b7afb364e.tar.gz
ports-76617ec7981b5e85f129f60fef47aa1b7afb364e.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-trex/Makefile32
-rw-r--r--textproc/py-trex/distinfo1
-rw-r--r--textproc/py-trex/files/patch-pytrex.py7
-rw-r--r--textproc/py-trex/pkg-comment1
-rw-r--r--textproc/py-trex/pkg-descr4
-rw-r--r--textproc/py-trex/pkg-plist1
7 files changed, 47 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 9a4143579a94..01cfb3a9aa8f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -125,6 +125,7 @@
SUBDIR += py-expat
SUBDIR += py-martel
SUBDIR += py-mxTextTools
+ SUBDIR += py-trex
SUBDIR += py-xml
SUBDIR += rand
SUBDIR += rman
diff --git a/textproc/py-trex/Makefile b/textproc/py-trex/Makefile
new file mode 100644
index 000000000000..94a0af0df707
--- /dev/null
+++ b/textproc/py-trex/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# New ports collection Makefile for: PyTREX
+# Date created: Mar 16, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trex
+PORTVERSION= 0.5.0
+CATEGORIES= textproc python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pytrex
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pytrex-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyexpat.so:${PORTSDIR}/textproc/py-expat
+
+USE_PYTHON= yes
+
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/pytrex.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pytrex.py ${PREFIX}/bin/pytrex
+
+.include <bsd.port.mk>
diff --git a/textproc/py-trex/distinfo b/textproc/py-trex/distinfo
new file mode 100644
index 000000000000..f6bf071d7f11
--- /dev/null
+++ b/textproc/py-trex/distinfo
@@ -0,0 +1 @@
+MD5 (pytrex-0.5.0.tgz) = 220d34d6b686c06b1ec41e6dd8f5a454
diff --git a/textproc/py-trex/files/patch-pytrex.py b/textproc/py-trex/files/patch-pytrex.py
new file mode 100644
index 000000000000..ecbca98e04f3
--- /dev/null
+++ b/textproc/py-trex/files/patch-pytrex.py
@@ -0,0 +1,7 @@
+--- pytrex.py.orig Sat Mar 17 00:00:31 2001
++++ pytrex.py Sat Mar 17 00:02:26 2001
+@@ -1,3 +1,4 @@
++#!%%LOCALBASE%%/bin/python
+ # PyTREX: A clean-room implementation of TREX in Python
+ # by James Tauber
+ #
diff --git a/textproc/py-trex/pkg-comment b/textproc/py-trex/pkg-comment
new file mode 100644
index 000000000000..0819ad6a99b3
--- /dev/null
+++ b/textproc/py-trex/pkg-comment
@@ -0,0 +1 @@
+Python implementation of Tree Regular Expressions for XML (TREX)
diff --git a/textproc/py-trex/pkg-descr b/textproc/py-trex/pkg-descr
new file mode 100644
index 000000000000..71f1ddb4ce45
--- /dev/null
+++ b/textproc/py-trex/pkg-descr
@@ -0,0 +1,4 @@
+PyTREX is a Python implementation of TREX, an XML schema language.
+
+WWW: http://pytrex.sourceforge.net/
+TREX WWW: http://thaiopensource.com/trex/
diff --git a/textproc/py-trex/pkg-plist b/textproc/py-trex/pkg-plist
new file mode 100644
index 000000000000..bac6191feff2
--- /dev/null
+++ b/textproc/py-trex/pkg-plist
@@ -0,0 +1 @@
+bin/pytrex