aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-10-17 07:44:35 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-10-17 07:44:35 +0000
commit9035c4a09f619348058113946b96ffac97a07bc4 (patch)
tree06d852546db3d4070ecd78ece73585fe1dfc64cf /textproc
parent44bb04370f3aefc27b76049d9da6345dceb58add (diff)
downloadports-9035c4a09f619348058113946b96ffac97a07bc4.tar.gz
ports-9035c4a09f619348058113946b96ffac97a07bc4.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-RTF-Writer/Makefile27
-rw-r--r--textproc/p5-RTF-Writer/distinfo1
-rw-r--r--textproc/p5-RTF-Writer/pkg-descr16
-rw-r--r--textproc/p5-RTF-Writer/pkg-plist9
5 files changed, 54 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index f1a8088de5c0..583e10d83c8d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -216,6 +216,7 @@
SUBDIR += p5-RDF-Core
SUBDIR += p5-RDF-Notation3
SUBDIR += p5-RDFStore
+ SUBDIR += p5-RTF-Writer
SUBDIR += p5-Regex-PreSuf
SUBDIR += p5-Regexp-Common
SUBDIR += p5-SVG
diff --git a/textproc/p5-RTF-Writer/Makefile b/textproc/p5-RTF-Writer/Makefile
new file mode 100644
index 000000000000..ee7b49fb0196
--- /dev/null
+++ b/textproc/p5-RTF-Writer/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: textproc/p5-RTF-Writer
+# Date created: Oct 15th 2003
+# Whom: clsung@dragon2.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= RTF-Writer
+PORTVERSION= 1.09
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= RTF
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Perl module for generating documents in Rich Text Format
+
+BUILD_DEPENDS= ${SITE_PERL}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= RTF::Writer.3 \
+ RTF::Writer::TableRowDecl.3 \
+ RTF::Cookbook.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-RTF-Writer/distinfo b/textproc/p5-RTF-Writer/distinfo
new file mode 100644
index 000000000000..161727cfaec8
--- /dev/null
+++ b/textproc/p5-RTF-Writer/distinfo
@@ -0,0 +1 @@
+MD5 (RTF-Writer-1.09.tar.gz) = 137e0af769d36ff95b759429dbbcfa57
diff --git a/textproc/p5-RTF-Writer/pkg-descr b/textproc/p5-RTF-Writer/pkg-descr
new file mode 100644
index 000000000000..79f036fcd044
--- /dev/null
+++ b/textproc/p5-RTF-Writer/pkg-descr
@@ -0,0 +1,16 @@
+This module is for generating documents in Rich Text Format.
+
+This module is a class; an object belonging to this class
+acts like an output filehandle, and calling methods on it
+causes RTF text to be written.
+
+Incidentally, this module also exports a few useful functions,
+upon request.
+
+The following documentation assumes some familiarity with
+the RTF Specification. Users not already intimately
+familiar with RTF should look at RTF::Cookbook.
+
+--
+Sean M. Burke.
+sburke@cpan.org
diff --git a/textproc/p5-RTF-Writer/pkg-plist b/textproc/p5-RTF-Writer/pkg-plist
new file mode 100644
index 000000000000..7f5097f7dc51
--- /dev/null
+++ b/textproc/p5-RTF-Writer/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/RTF/Writer/.packlist
+%%SITE_PERL%%/RTF/Cookbook.pod
+%%SITE_PERL%%/RTF/Writer.pm
+%%SITE_PERL%%/RTF/Writer.pod
+%%SITE_PERL%%/RTF/Writer/TableRowDecl.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/RTF/Writer
+@dirrm %%SITE_PERL%%/RTF/Writer
+@dirrm %%SITE_PERL%%/RTF
+@unexec rmdir %D/%%SITE_PERL%%/RTF 2>/dev/null || true