aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-07-26 12:25:46 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-07-26 12:25:46 +0000
commitab098bfa3d001f187e0db9889ddee496074b6b8f (patch)
treeb435d6f78aad5f535f16b879583ccc2c1f8aa552 /textproc
parent519dacca72eb1640b13f1a75f4c2f331c9cd49f6 (diff)
downloadports-ab098bfa3d001f187e0db9889ddee496074b6b8f.tar.gz
ports-ab098bfa3d001f187e0db9889ddee496074b6b8f.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/denature/Makefile5
-rw-r--r--textproc/diffsplit/Makefile5
-rw-r--r--textproc/diffsplit/pkg-descr2
-rw-r--r--textproc/markdown/Makefile5
-rw-r--r--textproc/p5-PPI-HTML/Makefile8
-rw-r--r--textproc/p5-Perl-MinimumVersion/Makefile2
-rw-r--r--textproc/p5-Plagger/Makefile4
-rw-r--r--textproc/p5-Text-ASCIITable/Makefile8
-rw-r--r--textproc/p5-UML-Class-Simple/Makefile2
-rw-r--r--textproc/p5-XML-Catalog/Makefile11
-rw-r--r--textproc/p5-XML-DBMS/Makefile11
-rw-r--r--textproc/p5-XML-FOAF/Makefile9
-rw-r--r--textproc/p5-XML-Filter-GenericChunk/Makefile14
-rw-r--r--textproc/p5-XML-Handler-Trees/Makefile9
-rw-r--r--textproc/p5-XML-SAXDriver-Sablotron/Makefile8
15 files changed, 31 insertions, 72 deletions
diff --git a/textproc/denature/Makefile b/textproc/denature/Makefile
index a6f60d229dec..a57284814694 100644
--- a/textproc/denature/Makefile
+++ b/textproc/denature/Makefile
@@ -26,8 +26,9 @@ MAN1= denature.1
PLIST_FILES= bin/denature
post-patch:
- @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}| ; \
- s|%%JAVA_HOME%%|${JAVA_HOME}|" ${WRKSRC}/denature
+ @${REINPLACE_CMD} -i '' -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
+ -e 's|%%JAVA_HOME%%|${JAVA_HOME}|' \
+ ${WRKSRC}/denature
do-build:
cd ${WRKSRC} && ${POD2MAN} denature > denature.1
diff --git a/textproc/diffsplit/Makefile b/textproc/diffsplit/Makefile
index 88678d2c1f6e..0968ee7dd035 100644
--- a/textproc/diffsplit/Makefile
+++ b/textproc/diffsplit/Makefile
@@ -16,14 +16,13 @@ NO_BUILD= YES
NO_WRKSUBDIR= YES
PLIST_FILES= bin/diffsplit
USE_PERL5= YES
+USES= shebangfix
+SHEBANG_FILES= diffsplit
do-extract:
@${MKDIR} ${WRKDIR}
@${CP} ${DISTDIR}/${DIST_SUBDIR}/diffsplit ${WRKDIR}
-do-patch:
- @${PERL} -pi -e "s:/usr/bin/perl:${PERL5}:g" ${WRKDIR}/diffsplit
-
do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/diffsplit ${PREFIX}/bin
diff --git a/textproc/diffsplit/pkg-descr b/textproc/diffsplit/pkg-descr
index 666e1198665f..c58e640b6574 100644
--- a/textproc/diffsplit/pkg-descr
+++ b/textproc/diffsplit/pkg-descr
@@ -1,4 +1,4 @@
This script splits up a unified diff into separate patch files,
each of which patches one source file.
-WWW: http://www.pathname.com/~quinlan/software/diffsplit/
+WWW: http://www.pathname.com/~quinlan/software/diffsplit/
diff --git a/textproc/markdown/Makefile b/textproc/markdown/Makefile
index cd3bbcfe3862..170741971fe6 100644
--- a/textproc/markdown/Makefile
+++ b/textproc/markdown/Makefile
@@ -14,6 +14,8 @@ COMMENT= A text-to-HTML conversion tool for web writers
USE_ZIP= yes
USE_PERL5= yes
NO_BUILD= yes
+USES= shebangfix
+SHEBANG_FILES= Markdown.pl
.if !defined(NOPORTDOCS)
PORTDOCS= License.text Markdown-Readme.text
@@ -21,9 +23,6 @@ PORTDOCS= License.text Markdown-Readme.text
PLIST_FILES= bin/markdown
-post-patch:
- ${PERL} -pi -e "s#/usr/bin/perl#${PERL}#" ${WRKSRC}/Markdown.pl
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/Markdown.pl ${PREFIX}/bin/markdown
.if !defined(NOPORTDOCS)
diff --git a/textproc/p5-PPI-HTML/Makefile b/textproc/p5-PPI-HTML/Makefile
index 859693297809..a2967a9320bc 100644
--- a/textproc/p5-PPI-HTML/Makefile
+++ b/textproc/p5-PPI-HTML/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: textproc/p5-PPI-HTML
-# Date created: 24 March 2005
-# Whom: Lars Thegler <lth@FreeBSD.org>
-#
+# Created by: Lars Thegler <lth@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= PPI-HTML
PORTVERSION= 1.08
@@ -25,6 +21,6 @@ PERL_CONFIGURE= yes
MAN3= PPI::HTML.3
post-patch:
- @${PERL} -pi -e '$$_="" if m/Test::More/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' '/Test::More/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/textproc/p5-Perl-MinimumVersion/Makefile b/textproc/p5-Perl-MinimumVersion/Makefile
index 5a77c57b65cb..56127fad3fc4 100644
--- a/textproc/p5-Perl-MinimumVersion/Makefile
+++ b/textproc/p5-Perl-MinimumVersion/Makefile
@@ -25,6 +25,6 @@ MAN1= perlver.1
MAN3= Perl::MinimumVersion.3
post-patch:
- @${PERL} -pi -e '$$_="" if m/Test::/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e '/Test::/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/textproc/p5-Plagger/Makefile b/textproc/p5-Plagger/Makefile
index c09946da6451..fe4f0b9ccaed 100644
--- a/textproc/p5-Plagger/Makefile
+++ b/textproc/p5-Plagger/Makefile
@@ -555,8 +555,8 @@ MAN3= Plagger.3 \
Plagger::Template.3
post-patch:
- ${PERL} -pi -e '$$_ = "" if m|auto_install|' ${WRKSRC}/Makefile.PL
- ${RM} ${WRKSRC}/lib/Plagger/Plugin/Publish/Feed.pm.orig
+ @${REINPLACE_CMD} -i '' '/auto_install/d' ${WRKSRC}/Makefile.PL
+ @${RM} ${WRKSRC}/lib/Plagger/Plugin/Publish/Feed.pm.orig
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
diff --git a/textproc/p5-Text-ASCIITable/Makefile b/textproc/p5-Text-ASCIITable/Makefile
index 4dd27017e3b4..a9cf486b4d7d 100644
--- a/textproc/p5-Text-ASCIITable/Makefile
+++ b/textproc/p5-Text-ASCIITable/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: textproc/p5-Text-ASCIITable
-# Date created: 20 April 2005
-# Whom: Lars Thegler <lth@FreeBSD.org>
-#
+# Created by: Lars Thegler <lth@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Text-ASCIITable
PORTVERSION= 0.20
@@ -22,7 +18,7 @@ MAN3= Text::ASCIITable.3 \
post-extract:
@${MKDIR} ${WRKSRC}/example
@${MV} ${WRKSRC}/ansi-example.pl ${WRKSRC}/example
- @${PERL} -pi -e '$$_="" if m|ansi-example.pl|' ${WRKSRC}/MANIFEST
+ @${REINPLACE_CMD} -i '' '/ansi-example.pl/d' ${WRKSRC}/MANIFEST
post-install:
.if !defined(NOPORTDOCS)
diff --git a/textproc/p5-UML-Class-Simple/Makefile b/textproc/p5-UML-Class-Simple/Makefile
index 0facf4b30423..af5f7fe904aa 100644
--- a/textproc/p5-UML-Class-Simple/Makefile
+++ b/textproc/p5-UML-Class-Simple/Makefile
@@ -26,6 +26,6 @@ MAN1= umlclass.pl.1
MAN3= UML::Class::Simple.3
post-patch:
- ${PERL} -pi -e '$$_="" if /auto_install/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' '/auto_install/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Catalog/Makefile b/textproc/p5-XML-Catalog/Makefile
index efcf58457371..2d10c8c906a5 100644
--- a/textproc/p5-XML-Catalog/Makefile
+++ b/textproc/p5-XML-Catalog/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: XML::Catalog
-# Date created: Jan 24, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= XML-Catalog
PORTVERSION= 0.02
@@ -22,10 +17,8 @@ BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
+USE_DOS2UNIX= Catalog.pm
MAN3= XML::Catalog.3
-post-patch:
- ${PERL} -pi -e 's/\r//' ${WRKSRC}/Catalog.pm
-
.include <bsd.port.mk>
diff --git a/textproc/p5-XML-DBMS/Makefile b/textproc/p5-XML-DBMS/Makefile
index 3bfc66c8698e..4e3f419d2eeb 100644
--- a/textproc/p5-XML-DBMS/Makefile
+++ b/textproc/p5-XML-DBMS/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: XML::DBMS
-# Date created: 18 Dec 2001
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= XML-DBMS
PORTVERSION= 1.03
@@ -24,10 +20,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/${PORTNAME}
PERL_CONFIGURE= yes
-
-post-extract:
- @${FIND} ${WRKSRC} -type f | \
- ${XARGS} ${PERL} -pi -e 's/\x0D(?=\x0A)//g'
+USE_DOS2UNIX= yes
post-install:
.ifndef(NOPORTDOCS)
diff --git a/textproc/p5-XML-FOAF/Makefile b/textproc/p5-XML-FOAF/Makefile
index 19a24001aae2..6011e5efd428 100644
--- a/textproc/p5-XML-FOAF/Makefile
+++ b/textproc/p5-XML-FOAF/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: textproc/p5-XML-FOAF
-# Date created: 2006-09-25
-# Whom: Masahiro Teramoto <markun@onohara.to>
-#
+# Created by: Masahiro Teramoto <markun@onohara.to>
# $FreeBSD$
-#
PORTNAME= XML-FOAF
PORTVERSION= 0.04
@@ -26,7 +22,4 @@ PERL_CONFIGURE= yes
MAN3= XML::FOAF.3 \
XML::FOAF::Person.3
-post-patch:
- ${PERL} -pi -e '$$_ = "" if m|auto_install|' ${WRKSRC}/Makefile.PL
-
.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Filter-GenericChunk/Makefile b/textproc/p5-XML-Filter-GenericChunk/Makefile
index eb1735088e2b..dc95787a7f32 100644
--- a/textproc/p5-XML-Filter-GenericChunk/Makefile
+++ b/textproc/p5-XML-Filter-GenericChunk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: XML::Filter::GenericChunk
-# Date created: 2.7.2003
-# Whom: Hansjoerg Pehofer <hansjoerg.pehofer@uibk.ac.at>
-#
+# Created by: Hansjoerg Pehofer <hansjoerg.pehofer@uibk.ac.at>
# $FreeBSD$
-#
PORTNAME= XML-Filter-GenericChunk
PORTVERSION= 0.07
@@ -24,9 +20,9 @@ MAN3= XML::Filter::CharacterChunk.3 \
XML::Filter::GenericChunk.3
post-patch:
- ${PERL} -pi -e '$$_="" if /use warnings/;' \
- ${WRKSRC}/t/02filter.t \
- ${WRKSRC}/CharacterChunk.pm \
- ${WRKSRC}/GenericChunk.pm
+ @${REINPLACE_CMD} -i '' '/use warnings/d' \
+ ${WRKSRC}/t/02filter.t \
+ ${WRKSRC}/CharacterChunk.pm \
+ ${WRKSRC}/GenericChunk.pm
.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Handler-Trees/Makefile b/textproc/p5-XML-Handler-Trees/Makefile
index 3a718a99e928..007ef774ef1a 100644
--- a/textproc/p5-XML-Handler-Trees/Makefile
+++ b/textproc/p5-XML-Handler-Trees/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: XML::Handler::Trees
-# Date created: 22 Nov 2001
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= XML-Handler-Trees
PORTVERSION= 0.02
@@ -15,10 +11,11 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= PerlSAX handlers for building tree structures
PERL_CONFIGURE= yes
+USE_DOS2UNIX= Trees.pm
MAN3= XML::Handler::Trees.3
post-extract:
- @${CHMOD} +w ${WRKSRC}/Trees.pm && ${PERL} -pi -e 's|\r||' ${WRKSRC}/Trees.pm
+ @${CHMOD} +w ${WRKSRC}/Trees.pm
.include <bsd.port.mk>
diff --git a/textproc/p5-XML-SAXDriver-Sablotron/Makefile b/textproc/p5-XML-SAXDriver-Sablotron/Makefile
index 852256521bcf..3e5af1dfe25c 100644
--- a/textproc/p5-XML-SAXDriver-Sablotron/Makefile
+++ b/textproc/p5-XML-SAXDriver-Sablotron/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: XML-SAXDriver-Sablotron
-# Date created: 30 May 2002
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= XML-SAXDriver-Sablotron
PORTVERSION= 0.30
@@ -23,6 +19,6 @@ PERL_CONFIGURE= yes
MAN3= XML::SAXDriver::Sablotron.3
pre-patch:
- @${PERL} -pi -e 's!^use warnings;!!;' ${WRKSRC}/Sablotron.pm
+ @${REINPLACE_CMD} -i '' '/use warnings/d' ${WRKSRC}/Sablotron.pm
.include <bsd.port.mk>