aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-21 00:26:09 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-21 00:26:09 +0000
commitb6a2fd887a31d5b4e0d96ae164b6c38609c9d187 (patch)
treed8cd98dbdd8e4d1cc9f6fbbc4a68c58594331066 /textproc
parent98fdd8ed25d8ab2df9e981bc84ffee357111fc33 (diff)
downloadports-b6a2fd887a31d5b4e0d96ae164b6c38609c9d187.tar.gz
ports-b6a2fd887a31d5b4e0d96ae164b6c38609c9d187.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-ANSITable/Makefile38
-rw-r--r--textproc/p5-Text-ANSITable/distinfo3
-rw-r--r--textproc/p5-Text-ANSITable/pkg-descr20
-rw-r--r--textproc/p5-Text-ANSITable/pkg-plist14
5 files changed, 76 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 8373d04adc3f..12d4866196e9 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -864,6 +864,7 @@
SUBDIR += p5-Test-Perl-Critic
SUBDIR += p5-Text-ANSI-Util
SUBDIR += p5-Text-ANSI-WideUtil
+ SUBDIR += p5-Text-ANSITable
SUBDIR += p5-Text-ASCIIMathML
SUBDIR += p5-Text-ASCIITable
SUBDIR += p5-Text-Affixes
diff --git a/textproc/p5-Text-ANSITable/Makefile b/textproc/p5-Text-ANSITable/Makefile
new file mode 100644
index 000000000000..ea16b060899a
--- /dev/null
+++ b/textproc/p5-Text-ANSITable/Makefile
@@ -0,0 +1,38 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Text-ANSITable
+PORTVERSION= 0.501
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Create nice formatted tables using extended ASCII and ANSI colors
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Border-Style>=0:devel/p5-Border-Style \
+ p5-Color-RGB-Util>=0.591:devel/p5-Color-RGB-Util \
+ p5-Color-Theme-Role>=0:devel/p5-Color-Theme-Role \
+ p5-Function-Fallback-CoreOrPP>=0:devel/p5-Function-Fallback-CoreOrPP \
+ p5-JSON-MaybeXS>=0:converters/p5-JSON-MaybeXS \
+ p5-Log-ger>=0.23:devel/p5-Log-ger \
+ p5-Module-List>=0:devel/p5-Module-List \
+ p5-Moo>=0:devel/p5-Moo \
+ p5-Package-MoreUtil>=0.590:devel/p5-Package-MoreUtil \
+ p5-Parse-VarName>=0:devel/p5-Parse-VarName \
+ p5-Term-App-Roles>=0.02:devel/p5-Term-App-Roles \
+ p5-Text-ANSI-Util>=0.22:textproc/p5-Text-ANSI-Util \
+ p5-namespace-clean>=0:devel/p5-namespace-clean
+TEST_DEPENDS= p5-Test-Exception>=0:devel/p5-Test-Exception \
+ p5-Test-Needs>=0:devel/p5-Test-Needs
+
+USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-ANSITable/distinfo b/textproc/p5-Text-ANSITable/distinfo
new file mode 100644
index 000000000000..6e0824cf53af
--- /dev/null
+++ b/textproc/p5-Text-ANSITable/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1550423138
+SHA256 (Text-ANSITable-0.501.tar.gz) = 23b3ee9d7072cff302e5e2923a320e86bbb3cc3161100d8363aee8bcee6dba03
+SIZE (Text-ANSITable-0.501.tar.gz) = 58804
diff --git a/textproc/p5-Text-ANSITable/pkg-descr b/textproc/p5-Text-ANSITable/pkg-descr
new file mode 100644
index 000000000000..9a2493e8096b
--- /dev/null
+++ b/textproc/p5-Text-ANSITable/pkg-descr
@@ -0,0 +1,20 @@
+Text::ANSITable is yet another text table formatter module like Text::ASCIITable
+or Text::SimpleTable, with the following differences:
+- Colors and color themes: ANSI color codes will be used by default (even 256
+ and 24bit colors), but will degrade to lower color depth and black/white
+ according to terminal support.
+- Box-drawing characters: Box-drawing characters will be used by default, but
+ will degrade to using normal ASCII characters if terminal does not support them.
+- Unicode and wide character support: Border styles using Unicode characters
+ (double lines, bold/heavy lines, brick style, etc). Columns containing wide
+ characters stay aligned. (Note: support for wide characters requires
+ Text::ANSI::WideUtil which is currently set as an optional prereq, so you'll
+ need to install it explicitly or set your CPAN client to install 'recommends'
+ prereq).
+
+Compared to Text::ASCIITable, it uses lower_case method/attr names instead of
+CamelCase, and it uses arrayref for columns and add_row. When specifying border
+styles, the order of characters are slightly different. More fine-grained
+options to customize appearance.
+
+WWW: https://metacpan.org/release/Text-ANSITable
diff --git a/textproc/p5-Text-ANSITable/pkg-plist b/textproc/p5-Text-ANSITable/pkg-plist
new file mode 100644
index 000000000000..4d56df916cf5
--- /dev/null
+++ b/textproc/p5-Text-ANSITable/pkg-plist
@@ -0,0 +1,14 @@
+bin/ansitable-list-border-styles
+bin/ansitable-list-color-themes
+bin/ansitable-list-style-sets
+%%SITE_PERL%%/Text/ANSITable.pm
+%%SITE_PERL%%/Text/ANSITable/BorderStyle/Default.pm
+%%SITE_PERL%%/Text/ANSITable/ColorTheme/Default.pm
+%%SITE_PERL%%/Text/ANSITable/StyleSet/AltRow.pm
+%%PERL5_MAN1%%/ansitable-list-border-styles.1.gz
+%%PERL5_MAN1%%/ansitable-list-color-themes.1.gz
+%%PERL5_MAN1%%/ansitable-list-style-sets.1.gz
+%%PERL5_MAN3%%/Text::ANSITable.3.gz
+%%PERL5_MAN3%%/Text::ANSITable::BorderStyle::Default.3.gz
+%%PERL5_MAN3%%/Text::ANSITable::ColorTheme::Default.3.gz
+%%PERL5_MAN3%%/Text::ANSITable::StyleSet::AltRow.3.gz