aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2001-08-22 17:46:52 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2001-08-22 17:46:52 +0000
commit548afcb921e5dd38af105d942c4c440da7e02a8f (patch)
tree445e5e44fadbf85581d20747fdb88502b7593706 /textproc
parent750e1d4d53ba80f78b0a7ca5425eb81709fbfe7f (diff)
downloadports-548afcb921e5dd38af105d942c4c440da7e02a8f.tar.gz
ports-548afcb921e5dd38af105d942c4c440da7e02a8f.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/urlview/Makefile4
-rw-r--r--textproc/urlview/files/patch-url_handler.sh34
2 files changed, 38 insertions, 0 deletions
diff --git a/textproc/urlview/Makefile b/textproc/urlview/Makefile
index eb6132466295..203b7b686b9e 100644
--- a/textproc/urlview/Makefile
+++ b/textproc/urlview/Makefile
@@ -24,4 +24,8 @@ MAINTAINER= obrien@FreeBSD.org
GNU_CONFIGURE= yes
MAN1= urlview.1
+post-patch:
+ ${PERL} -pi.prefix -e 's.!!PREFIX!!.${PREFIX}.g' \
+ ${WRKSRC}/url_handler.sh
+
.include <bsd.port.mk>
diff --git a/textproc/urlview/files/patch-url_handler.sh b/textproc/urlview/files/patch-url_handler.sh
new file mode 100644
index 000000000000..99a26639c5cb
--- /dev/null
+++ b/textproc/urlview/files/patch-url_handler.sh
@@ -0,0 +1,34 @@
+--- url_handler.sh.orig Tue Jul 4 03:14:30 2000
++++ url_handler.sh Wed Aug 22 10:42:49 2001
+@@ -1,4 +1,4 @@
+-#! /bin/bash
++#! /bin/sh
+
+ # Copyright (c) 1998 Martin Schulze <joey@debian.org>
+ # Slightly modified by Luis Francisco Gonzalez <luisgh@debian.org>
+@@ -28,11 +28,11 @@
+ # VT: Launch in the same terminal
+
+ # The lists of programs to be executed are
+-https_prgs="/usr/X11R6/bin/netscape:XW /usr/bin/lynx:XT"
+-http_prgs="/usr/bin/lynx:XT /usr/X11R6/bin/netscape:XW"
+-mailto_prgs="/usr/bin/mutt:VT /usr/bin/elm:VT /usr/bin/pine:VT /usr/bin/mail:VT"
+-gopher_prgs="/usr/bin/lynx:XT /usr/bin/gopher:XT"
+-ftp_prgs="/usr/bin/lynx:XT /usr/bin/ncftp:XT"
++https_prgs="!!PREFIX!!/bin/netscape:XW !!PREFIX!!/bin/lynx:XT !!PREFIX!!/bin/w3m:XT"
++http_prgs="!!PREFIX!!/bin/netscape:XW !!PREFIX!!/bin/lynx:XT !!PREFIX!!/bin/w3m:XT !!PREFIX!!/bin/links:XT"
++mailto_prgs="!!PREFIX!!/bin/mutt:VT !!PREFIX!!/bin/elm:VT !!PREFIX!!/bin/pine:VT /usr/bin/mail:VT"
++gopher_prgs="!!PREFIX!!/bin/lynx:XT !!PREFIX!!/bin/gopher:XT"
++ftp_prgs="!!PREFIX!!/bin/lynx:XT !!PREFIX!!/bin/ncftp2:XT !!PREFIX!!/bin/ncftp3:XT !!PREFIX!!/bin/ncftp:XT"
+
+ # Program used as an xterm (if it doesn't support -T you'll need to change
+ # the command line in getprg)
+@@ -42,7 +42,7 @@
+ ###########################################################################
+ # Change bellow this at your own risk
+ ###########################################################################
+-function getprg()
++getprg()
+ {
+ local ele tag prog
+