aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorJohn Fieber <jfieber@FreeBSD.org>1997-06-22 21:06:40 +0000
committerJohn Fieber <jfieber@FreeBSD.org>1997-06-22 21:06:40 +0000
commit6f830a7cfc5f90c197f1c6d4abc8e46d0c5d8195 (patch)
tree04d13a9b639a9ddc34e4935608368751319a5673 /textproc
parentd3f311ee72696462c0562d44010aa4c3f5551cb5 (diff)
downloadports-6f830a7cfc5f90c197f1c6d4abc8e46d0c5d8195.tar.gz
ports-6f830a7cfc5f90c197f1c6d4abc8e46d0c5d8195.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/docbook/Makefile44
-rw-r--r--textproc/docbook/pkg-comment1
-rw-r--r--textproc/docbook/pkg-descr13
-rw-r--r--textproc/docbook/pkg-plist23
4 files changed, 81 insertions, 0 deletions
diff --git a/textproc/docbook/Makefile b/textproc/docbook/Makefile
new file mode 100644
index 000000000000..9d6bb008b2e7
--- /dev/null
+++ b/textproc/docbook/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: docbook
+# Version required: 3.0
+# Date created: June 19, 1997
+# Whom: jfieber
+#
+# $Id$
+#
+
+DISTNAME= docbook-3.0
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.ora.com/pub/davenport/
+
+MAINTAINER= jfieber@FreeBSD.ORG
+
+DISTFILES= docbk241.tar.Z docbk30.tar.Z
+
+NO_MTREE= yes
+NO_EXTRACT= yes
+NO_BUILD= yes
+NO_PATCH= yes
+NO_CONFIGURE= yes
+NO_WRKDIR= yes
+
+RUN_DEPENDS= ${ISOCAT}:${PORTSDIR}/textproc/iso8879
+
+INSTDIR= ${PREFIX}/share/sgml/docbook
+ISOCAT= ${PREFIX}/share/sgml/iso8879/catalog
+
+pre-install:
+ @[ -d ${INSTDIR}/2.4.1 ] || ${MKDIR} ${INSTDIR}/2.4.1
+ @[ -d ${INSTDIR}/3.0 ] || ${MKDIR} ${INSTDIR}/3.0
+
+do-install:
+ @zcat ${DISTDIR}/docbk241.tar.Z |(cd ${INSTDIR}/2.4.1; pax -r)
+ @${INSTALL_DATA} ${FILESDIR}/catalog241 ${INSTDIR}/2.4.1/catalog
+ @echo "CATALOG \"${ISOCAT}\"" >> ${INSTDIR}/2.4.1/catalog
+ @zcat ${DISTDIR}/docbk30.tar.Z |(cd ${INSTDIR}/3.0; pax -r)
+ @${INSTALL_DATA} ${FILESDIR}/catalog30 ${INSTDIR}/3.0/catalog
+ @echo "CATALOG \"${ISOCAT}\"" >> ${INSTDIR}/3.0/catalog
+ @chmod ${SHAREMODE} ${INSTDIR}/2.4.1/*
+ @chmod ${SHAREMODE} ${INSTDIR}/3.0/*
+ @chown -R ${SHAREOWN}.${SHAREGRP} ${INSTDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/docbook/pkg-comment b/textproc/docbook/pkg-comment
new file mode 100644
index 000000000000..ca11a0177c19
--- /dev/null
+++ b/textproc/docbook/pkg-comment
@@ -0,0 +1 @@
+An SGML DTD designed for computer documentation
diff --git a/textproc/docbook/pkg-descr b/textproc/docbook/pkg-descr
new file mode 100644
index 000000000000..151378081a36
--- /dev/null
+++ b/textproc/docbook/pkg-descr
@@ -0,0 +1,13 @@
+The DocBook DTD defines structural and content-based SGML markup
+for computer documentation, with a primary emphasis on software
+documentation and related classes of technical documents. Its
+main high-level hierarchical structures are for books, reference
+entries (for example, ``man pages''), and articles. It is
+maintained by the Davenport Group (about which see the Davenport
+archive at http://www.ora.com/davenport/ or
+ftp://ftp.ora.com/pub/davenport/).
+
+This port contains DocBook versions 2.4.1 and 3.0.
+
+John Fieber
+jfieber@FreeBSD.org
diff --git a/textproc/docbook/pkg-plist b/textproc/docbook/pkg-plist
new file mode 100644
index 000000000000..6c0f7fb304d2
--- /dev/null
+++ b/textproc/docbook/pkg-plist
@@ -0,0 +1,23 @@
+share/sgml/docbook/2.4.1/241chg.txt
+share/sgml/docbook/2.4.1/calstbl.mod
+share/sgml/docbook/2.4.1/dbgenent.mod
+share/sgml/docbook/2.4.1/dbhier.mod
+share/sgml/docbook/2.4.1/dbpool.mod
+share/sgml/docbook/2.4.1/docbook.cat
+share/sgml/docbook/2.4.1/docbook.dcl
+share/sgml/docbook/2.4.1/docbook.dtd
+share/sgml/docbook/2.4.1/catalog
+share/sgml/docbook/3.0/30chg.txt
+share/sgml/docbook/3.0/40issues.txt
+share/sgml/docbook/3.0/announce.txt
+share/sgml/docbook/3.0/cals-tbl.dtd
+share/sgml/docbook/3.0/dbgenent.mod
+share/sgml/docbook/3.0/dbhier.mod
+share/sgml/docbook/3.0/dbpool.mod
+share/sgml/docbook/3.0/docbook.cat
+share/sgml/docbook/3.0/docbook.dcl
+share/sgml/docbook/3.0/docbook.dtd
+share/sgml/docbook/3.0/catalog
+@dirrm share/sgml/docbook/2.4.1
+@dirrm share/sgml/docbook/3.0
+@dirrm share/sgml/docbook