aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-07-05 19:29:51 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-07-05 19:29:51 +0000
commit77887bedcca1b149cc345f39a7b0ebb8f19385ed (patch)
tree5e0b23abaad26849d3d348fef0d683a4ac62bdc2 /textproc
parent3cb09cc3c18e9d2b224af252cbf0331f7ed62a4b (diff)
downloadports-77887bedcca1b149cc345f39a7b0ebb8f19385ed.tar.gz
ports-77887bedcca1b149cc345f39a7b0ebb8f19385ed.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/sdcv/Makefile65
-rw-r--r--textproc/sdcv/distinfo3
-rw-r--r--textproc/sdcv/files/patch-configure11
-rw-r--r--textproc/sdcv/pkg-descr8
-rw-r--r--textproc/sdcv/pkg-plist6
6 files changed, 94 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index d32ea00844d8..1cb1302cf476 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -765,6 +765,7 @@
SUBDIR += scim-table-imengine
SUBDIR += scr2txt
SUBDIR += scrollkeeper
+ SUBDIR += sdcv
SUBDIR += sdf
SUBDIR += sdocbook-xml
SUBDIR += senna
diff --git a/textproc/sdcv/Makefile b/textproc/sdcv/Makefile
new file mode 100644
index 000000000000..3ea70a220973
--- /dev/null
+++ b/textproc/sdcv/Makefile
@@ -0,0 +1,65 @@
+# Ports collection makefile for: sdcv
+# Date created: 2005/07/07
+# Whom: chinsan <chinsan.tw@gmail.com>
+# $FreeBSD$
+#
+
+PORTNAME= sdcv
+PORTVERSION= 0.4.2
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= A text-based utility for work with dictionaries in StarDict's format
+
+USE_BZIP2= yes
+#USE_GCC= 3.3+
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= glib20
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+MAN1= sdcv.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Doesn't build on FreeBSD 4.x
+.endif
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+BROKEN= Doesn't build on 64-bit platforms
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
+ ${WRKSRC}/doc/sdcv.1
+ @${REINPLACE_CMD} -e '1425 s, install-data,,' \
+ ${WRKSRC}/po/Makefile.in.in
+ @${REINPLACE_CMD} -e 's, getopt.h,,g' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e '146 s|()|(int, char * const [], const char *)|g' \
+ ${WRKSRC}/src/getopt.h
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
+ ${WRKSRC}/src/sdcv.cpp
+ @${REINPLACE_CMD} -e 's,@mandir@/uk,@mandir@,' \
+ ${WRKSRC}/doc/uk/Makefile.in
+.if !defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} -e 's,@USE_NLS@,yes,g' ${WRKSRC}/po/Makefile.in.in
+ @${REINPLACE_CMD} -e 's, getopt.h,,g; s,@USE_NLS@,yes,g' \
+ ${WRKSRC}/src/Makefile.in
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/sdcv/distinfo b/textproc/sdcv/distinfo
new file mode 100644
index 000000000000..49f006bfa62a
--- /dev/null
+++ b/textproc/sdcv/distinfo
@@ -0,0 +1,3 @@
+MD5 (sdcv-0.4.2.tar.bz2) = f624662b333daa5da2d3e99cef519f17
+SHA256 (sdcv-0.4.2.tar.bz2) = a164f079e93986814ea2d39f3a49cf9d1b71b01aad908254457fe3d0ded9deb2
+SIZE (sdcv-0.4.2.tar.bz2) = 181384
diff --git a/textproc/sdcv/files/patch-configure b/textproc/sdcv/files/patch-configure
new file mode 100644
index 000000000000..19612671e98f
--- /dev/null
+++ b/textproc/sdcv/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Mon Apr 24 18:57:24 2006
++++ configure Fri May 5 17:24:17 2006
+@@ -5745,6 +5745,8 @@
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_GETTEXT 1
++USE_NLS=yes
++#define ENABLE_NLS 1
+ _ACEOF
+
+
diff --git a/textproc/sdcv/pkg-descr b/textproc/sdcv/pkg-descr
new file mode 100644
index 000000000000..736e4c5e7532
--- /dev/null
+++ b/textproc/sdcv/pkg-descr
@@ -0,0 +1,8 @@
+SDCV(StarDict under Console Version) is simple, cross-platform text-based
+utility for work with dictionaries in StarDict's format.
+
+The word from "list of words" may be string with leading '/' for using Fuzzy
+search algorithm, string may contain '?' and '*' for using regexp search.
+It work in interactive and not interactive mode.
+
+WWW: http://sdcv.sourceforge.net/
diff --git a/textproc/sdcv/pkg-plist b/textproc/sdcv/pkg-plist
new file mode 100644
index 000000000000..6e3bf9d0938a
--- /dev/null
+++ b/textproc/sdcv/pkg-plist
@@ -0,0 +1,6 @@
+bin/sdcv
+%%NLS%%share/locale/ru/LC_MESSAGES/sdcv.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/sdcv.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/sdcv.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/sdcv.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/sdcv.mo