aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-29 21:44:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-29 21:44:00 +0000
commit7fd3acb105b2b975e66885ca5beeab93c9669b2a (patch)
tree011774294cc6e178f63e4f1cd0cfb9d1b9809688 /textproc
parent0859e46a4397bc30a7a83882a72cfb092eced4a7 (diff)
downloadports-7fd3acb105b2b975e66885ca5beeab93c9669b2a.tar.gz
ports-7fd3acb105b2b975e66885ca5beeab93c9669b2a.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/hs-bytestring-csv/Makefile38
-rw-r--r--textproc/hs-bytestring-csv/distinfo3
-rw-r--r--textproc/hs-bytestring-csv/pkg-descr4
-rw-r--r--textproc/hs-bytestring-csv/pkg-plist16
5 files changed, 62 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 2a5688987809..7e2ccf027bc1 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -205,6 +205,7 @@
SUBDIR += highlight
SUBDIR += hil-aspell
SUBDIR += hr-aspell
+ SUBDIR += hs-bytestring-csv
SUBDIR += hs-haxml
SUBDIR += hs-stringsearch
SUBDIR += hsb-aspell
diff --git a/textproc/hs-bytestring-csv/Makefile b/textproc/hs-bytestring-csv/Makefile
new file mode 100644
index 000000000000..64d21868c846
--- /dev/null
+++ b/textproc/hs-bytestring-csv/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: bytestring-csv
+# Date created: November 25, 2008
+# Whom: Samy Al Bahra <sbahra@kerneled.org>
+#
+# $FreeBSD$
+
+PORTNAME= bytestring-csv
+PORTVERSION= 0.1.2
+CATEGORIES= textproc haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/ \
+ http://carte.kerneled.org/mirror/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= sbahra@kerneled.org
+COMMENT= Parse CSV formatted data efficiently with Haskell
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ hs-dlist>=0.4.1:${PORTSDIR}/devel/hs-dlist
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+CABAL= ${LOCALBASE}/bin/runghc Setup.lhs
+GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${SUBDIR}
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+
+do-build:
+ cd ${WRKSRC} && ${CABAL} build && ${CABAL} register --gen-script
+
+do-install:
+ cd ${WRKSRC} && ${CABAL} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
+
+.include <bsd.port.mk>
diff --git a/textproc/hs-bytestring-csv/distinfo b/textproc/hs-bytestring-csv/distinfo
new file mode 100644
index 000000000000..fbea8e1055ea
--- /dev/null
+++ b/textproc/hs-bytestring-csv/distinfo
@@ -0,0 +1,3 @@
+MD5 (bytestring-csv-0.1.2.tar.gz) = 45adcabc345af6bc8201e254a7de0683
+SHA256 (bytestring-csv-0.1.2.tar.gz) = 19480f2f60c474b18ef507a657daa63b18a40f97a3171883cf9d4b33169df874
+SIZE (bytestring-csv-0.1.2.tar.gz) = 76022
diff --git a/textproc/hs-bytestring-csv/pkg-descr b/textproc/hs-bytestring-csv/pkg-descr
new file mode 100644
index 000000000000..5f0dd82cf93f
--- /dev/null
+++ b/textproc/hs-bytestring-csv/pkg-descr
@@ -0,0 +1,4 @@
+A small library that allows you to parse CSV formatted data efficiently
+with Haskell.
+
+WWW: http://code.haskell.org/~dons/code/bytestring-csv
diff --git a/textproc/hs-bytestring-csv/pkg-plist b/textproc/hs-bytestring-csv/pkg-plist
new file mode 100644
index 000000000000..b387328cd569
--- /dev/null
+++ b/textproc/hs-bytestring-csv/pkg-plist
@@ -0,0 +1,16 @@
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/libHSbytestring-csv-%%PORTVERSION%%.a
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/HSbytestring-csv-%%PORTVERSION%%.o
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Text/CSV/ByteString.hi
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Text/CSV/ByteString/Lex.hi
+%%SUBDIR%%/register.sh
+share/doc/bytestring-csv-%%PORTVERSION%%/LICENSE
+@dirrm share/doc/bytestring-csv-%%PORTVERSION%%
+@dirrm lib/bytestring-csv-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Text/CSV/ByteString
+@dirrm lib/bytestring-csv-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Text/CSV
+@dirrm lib/bytestring-csv-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Text
+@dirrm lib/bytestring-csv-%%PORTVERSION%%/ghc-%%GHC_VERSION%%
+@dirrm lib/bytestring-csv-%%PORTVERSION%%
+@exec /bin/sh %D/%%SUBDIR%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister bytestring-csv
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old