aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-11-02 17:51:34 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-11-02 17:51:34 +0000
commit800d5c32a34a968e7b3a48354e8d8ea7fe1f10de (patch)
tree36b6cdf9732709e1db13b1a76b30e9dc8465b6ae /textproc
parente008a338baac117ee05f891ed800e2d2cb90454a (diff)
downloadports-800d5c32a34a968e7b3a48354e8d8ea7fe1f10de.tar.gz
ports-800d5c32a34a968e7b3a48354e8d8ea7fe1f10de.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xmlformat/Makefile52
-rw-r--r--textproc/xmlformat/pkg-plist26
2 files changed, 30 insertions, 48 deletions
diff --git a/textproc/xmlformat/Makefile b/textproc/xmlformat/Makefile
index 0667eba68fa6..01643e6e5efb 100644
--- a/textproc/xmlformat/Makefile
+++ b/textproc/xmlformat/Makefile
@@ -3,39 +3,47 @@
PORTNAME= xmlformat
PORTVERSION= 1.04
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://www.kitebird.com/software/xmlformat/
MAINTAINER= hrs@FreeBSD.org
COMMENT= An XML Document Formatter
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
NO_BUILD= yes
-USES= perl5
+USES= perl5 shebangfix
+
+SHEBANG_FILES= ${WRKSRC}/xmlformat.pl
+PLIST_FILES= bin/xmlformat
+PORTDOCS_root= BUGS ChangeLog INSTALL LICENSE README TODO
+PORTDOCS_docs= docs/API docs/catalog.xml \
+ docs/tutorial.html docs/tutorial.pdf docs/tutorial.xml \
+ docs/xmlformat.conf docs/xmlformat.html docs/xmlformat.pdf \
+ docs/xmlformat.xml
+PORTDOCS= ${PORTDOCS_root} ${PORTDOCS_docs:S,^docs/,,}
+PORTEXAMPLES= doc1.xml doc2.conf1 doc2.conf2 doc2.conf3 \
+ doc2.conf4 doc2.xml
-DOCSRCDIR1= ${WRKSRC}
-DOC_FILES1= BUGS ChangeLog INSTALL LICENSE README TODO
+OPTIONS_DEFINE= DOCS EXAMPLES
-DOCSRCDIR2= ${WRKSRC}/docs
-DOCSDIR2= ${DOCSDIR}/docs
-DOC_FILES2= API catalog.xml \
- tutorial.html tutorial.pdf tutorial.xml \
- xmlformat.conf xmlformat.html xmlformat.pdf xmlformat.xml
+.include <bsd.port.options.mk>
-EXSRCDIR= ${WRKSRC}/docs/examples
-EXDIR= ${DOCSDIR}/docs/examples
-EX_FILES= doc1.xml doc2.conf1 doc2.conf2 doc2.conf3 \
- doc2.conf4 doc2.xml
-
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/xmlformat.pl ${PREFIX}/bin/xmlformat
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES1:S,^,${DOCSRCDIR1}/,} ${DOCSDIR}
- ${MKDIR} ${DOCSDIR2}
- ${INSTALL_DATA} ${DOC_FILES2:S,^,${DOCSRCDIR2}/,} ${DOCSDIR2}
- ${MKDIR} ${EXDIR}
- ${INSTALL_DATA} ${EX_FILES:S,^,${EXSRCDIR}/,} ${EXDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/xmlformat.pl \
+ ${STAGEDIR}${PREFIX}/bin/xmlformat
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} ${PORTDOCS_root} ${PORTDOCS_docs} \
+ ${STAGEDIR}${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/docs/examples && \
+ ${INSTALL_DATA} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/textproc/xmlformat/pkg-plist b/textproc/xmlformat/pkg-plist
deleted file mode 100644
index 90a0b1ac88b8..000000000000
--- a/textproc/xmlformat/pkg-plist
+++ /dev/null
@@ -1,26 +0,0 @@
-@comment $FreeBSD$
-bin/xmlformat
-%%PORTDOCS%%%%DOCSDIR%%/docs/examples/doc2.conf1
-%%PORTDOCS%%%%DOCSDIR%%/docs/examples/doc2.conf2
-%%PORTDOCS%%%%DOCSDIR%%/docs/examples/doc2.conf3
-%%PORTDOCS%%%%DOCSDIR%%/docs/examples/doc2.conf4
-%%PORTDOCS%%%%DOCSDIR%%/docs/examples/doc1.xml
-%%PORTDOCS%%%%DOCSDIR%%/docs/examples/doc2.xml
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/examples
-%%PORTDOCS%%%%DOCSDIR%%/docs/API
-%%PORTDOCS%%%%DOCSDIR%%/docs/catalog.xml
-%%PORTDOCS%%%%DOCSDIR%%/docs/tutorial.html
-%%PORTDOCS%%%%DOCSDIR%%/docs/tutorial.pdf
-%%PORTDOCS%%%%DOCSDIR%%/docs/tutorial.xml
-%%PORTDOCS%%%%DOCSDIR%%/docs/xmlformat.conf
-%%PORTDOCS%%%%DOCSDIR%%/docs/xmlformat.html
-%%PORTDOCS%%%%DOCSDIR%%/docs/xmlformat.pdf
-%%PORTDOCS%%%%DOCSDIR%%/docs/xmlformat.xml
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
-%%PORTDOCS%%%%DOCSDIR%%/BUGS
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%@dirrm %%DOCSDIR%%