aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-10-21 18:37:14 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-10-21 18:37:14 +0000
commit5a4433e41d686f191f450f807e7cd55a44e96684 (patch)
tree33135108223e705475dbf2fd26965e010f52f4c4 /textproc
parent76a11d95bcf91848268fc58cf2df88e0ed903371 (diff)
downloadports-5a4433e41d686f191f450f807e7cd55a44e96684.tar.gz
ports-5a4433e41d686f191f450f807e7cd55a44e96684.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/intltool/Makefile9
-rw-r--r--textproc/intltool/distinfo2
-rw-r--r--textproc/intltool/pkg-descr21
-rw-r--r--textproc/intltool/pkg-plist26
5 files changed, 33 insertions, 26 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b6bc34b5d471..43762bc4aa49 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -65,6 +65,7 @@
SUBDIR += htmlsection
SUBDIR += info2html
SUBDIR += info_to_html
+ SUBDIR += intltool
SUBDIR += isearch
SUBDIR += iso12083
SUBDIR += iso8879
diff --git a/textproc/intltool/Makefile b/textproc/intltool/Makefile
index 82bc52419df3..1fb3d82783d2 100644
--- a/textproc/intltool/Makefile
+++ b/textproc/intltool/Makefile
@@ -1,12 +1,12 @@
-# New ports collection makefile for: xml-i18n-tools
+# New ports collection makefile for: intltool
# Date created: 19th January 2001
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= xml-i18n-tools
-PORTVERSION= 0.9
+PORTNAME= intltool
+PORTVERSION= 0.11
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/${PORTNAME}
@@ -16,4 +16,7 @@ MAINTAINER= gnome@FreeBSD.org
USE_GMAKE= yes
USE_LIBTOOL= yes
+MAN8= intltool-extract.8 intltool-merge.8 intltool-prepare.8 \
+ intltoolize.8
+
.include <bsd.port.mk>
diff --git a/textproc/intltool/distinfo b/textproc/intltool/distinfo
index c56b0ff516f1..b2c2ef97c52d 100644
--- a/textproc/intltool/distinfo
+++ b/textproc/intltool/distinfo
@@ -1 +1 @@
-MD5 (xml-i18n-tools-0.9.tar.gz) = c61a011d959b257168f297cb65f2b980
+MD5 (intltool-0.11.tar.gz) = 462d441d42aae7639d8637899eabd6e4
diff --git a/textproc/intltool/pkg-descr b/textproc/intltool/pkg-descr
index f24ca36963ae..b8fb6ebf9394 100644
--- a/textproc/intltool/pkg-descr
+++ b/textproc/intltool/pkg-descr
@@ -1,17 +1,16 @@
The module contains some utility scripts and assorted auto* magic for
-internationalizing various kinds of XML files. This supersedes the
-earlier scripts that I (Kenneth) distributed to be checked into each
-module. In addition, it has an additional merging feature, currently
-only for oaf files. This feature might be extented to handle .desktop
-files and MIME files in the future.
+internationalizing various kinds of XML files.
* Features
-o Automatically extracts translatable strings from oaf, glade, bonobo
- ui, nautilus theme and other XML files into the po files.
-
-o Automatically merges translations from po files back into .oaf files
- (encoding to be 7-bit clean). I can also extend this merging
- mechanism to support other types of XML files.
+o Extract translatable strings from various source files (.xml.in,
+ .glade, .desktop.in, .server.in, .oaf.in).
+
+o Collect the extracted strings together with messages from traditional
+ source files (.c, .h) in po/$(PACKAGE).pot.
+
+o Merge back the translations from .po files into .xml, .desktop and
+ .oaf files. This merge step will happen at build resp. installation
+ time.
WWW: http://www.gnome.org/
diff --git a/textproc/intltool/pkg-plist b/textproc/intltool/pkg-plist
index 4449c1861dcc..c0d95eb4d736 100644
--- a/textproc/intltool/pkg-plist
+++ b/textproc/intltool/pkg-plist
@@ -1,13 +1,17 @@
-bin/xml-i18n-extract
-bin/xml-i18n-merge
-bin/xml-i18n-prepare
+bin/intltool-extract
+bin/intltool-merge
+bin/intltool-prepare
+bin/intltool-unicodify
+bin/intltool-update
+bin/intltoolize
bin/xml-i18n-toolize
-bin/xml-i18n-unicodify
-bin/xml-i18n-update
+share/aclocal/intltool.m4
share/aclocal/xml-i18n-tools.m4
-share/xml-i18n-tools/xml-i18n-extract.in
-share/xml-i18n-tools/xml-i18n-merge.in
-share/xml-i18n-tools/xml-i18n-po-Makefile.in.in-patch-1
-share/xml-i18n-tools/xml-i18n-po-Makefile.in.in-patch-2
-share/xml-i18n-tools/xml-i18n-update.in
-@dirrm share/xml-i18n-tools
+share/intltool/intltool-extract.in
+share/intltool/intltool-merge.in
+share/intltool/intltool-po-Makefile.in.in-patch-1
+share/intltool/intltool-po-Makefile.in.in-patch-2
+share/intltool/intltool-update.in
+share/intltool/xml-i18n-po-Makefile.in.in-patch-1
+share/intltool/xml-i18n-po-Makefile.in.in-patch-2
+@dirrm share/intltool