aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-10-13 19:01:04 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-10-13 19:01:04 +0000
commit1336528d1003db9c191207d756172496ed737adf (patch)
treec1c0d68043de749a4a62c255c25c2ae07825a51d /textproc
parent71774664d548f65acc6062da10c0fcd1881946c8 (diff)
downloadports-1336528d1003db9c191207d756172496ed737adf.tar.gz
ports-1336528d1003db9c191207d756172496ed737adf.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-Atom-Filter/Makefile31
-rw-r--r--textproc/p5-XML-Atom-Filter/distinfo2
-rw-r--r--textproc/p5-XML-Atom-Filter/pkg-descr4
-rw-r--r--textproc/p5-XML-Atom-Filter/pkg-plist7
5 files changed, 45 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 2347e6f60f07..67c0d0807804 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -446,6 +446,7 @@
SUBDIR += p5-WordNet-QueryData
SUBDIR += p5-WordNet-Similarity
SUBDIR += p5-XML-Atom
+ SUBDIR += p5-XML-Atom-Filter
SUBDIR += p5-XML-Atom-Syndication
SUBDIR += p5-XML-AutoWriter
SUBDIR += p5-XML-Catalog
diff --git a/textproc/p5-XML-Atom-Filter/Makefile b/textproc/p5-XML-Atom-Filter/Makefile
new file mode 100644
index 000000000000..54b0e1d993d3
--- /dev/null
+++ b/textproc/p5-XML-Atom-Filter/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: textproc/p5-XML-Atom-Filter
+# Date created: 13 October 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Atom-Filter
+PORTVERSION= 0.05
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Easy creation of command line Atom processing tools
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/Atom.pm:${PORTSDIR}/textproc/p5-XML-Atom
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Atom::Filter.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= Port requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-Atom-Filter/distinfo b/textproc/p5-XML-Atom-Filter/distinfo
new file mode 100644
index 000000000000..bad765eeaa41
--- /dev/null
+++ b/textproc/p5-XML-Atom-Filter/distinfo
@@ -0,0 +1,2 @@
+MD5 (XML-Atom-Filter-0.05.tar.gz) = ac2b70fb1154b8343c44594e63e37f8c
+SIZE (XML-Atom-Filter-0.05.tar.gz) = 4748
diff --git a/textproc/p5-XML-Atom-Filter/pkg-descr b/textproc/p5-XML-Atom-Filter/pkg-descr
new file mode 100644
index 000000000000..7593b66ed2cd
--- /dev/null
+++ b/textproc/p5-XML-Atom-Filter/pkg-descr
@@ -0,0 +1,4 @@
+XML::Atom::Filter supports creation of command line tools to filter and
+process Atom feeds.
+
+WWW: http://search.cpan.org/dist/XML-Atom-Filter/
diff --git a/textproc/p5-XML-Atom-Filter/pkg-plist b/textproc/p5-XML-Atom-Filter/pkg-plist
new file mode 100644
index 000000000000..419f06c9b6c3
--- /dev/null
+++ b/textproc/p5-XML-Atom-Filter/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/XML/Atom/Filter.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Atom/Filter/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Atom/Filter 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Atom 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/XML/Atom 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/XML 2>/dev/null || true