aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-11-22 22:54:25 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-11-22 22:54:25 +0000
commit40a0e44ddff0389749551d686931a88ddcecac66 (patch)
tree1a0b4c90ae0dc9ab4b15d6a5bfe5f2dc5770838c /textproc
parentb9a8b337cdbcaaa6915c3d032e382e405cc92291 (diff)
downloadports-40a0e44ddff0389749551d686931a88ddcecac66.tar.gz
ports-40a0e44ddff0389749551d686931a88ddcecac66.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-SAX-Expat/Makefile28
-rw-r--r--textproc/p5-XML-SAX-Expat/distinfo1
-rw-r--r--textproc/p5-XML-SAX-Expat/pkg-comment1
-rw-r--r--textproc/p5-XML-SAX-Expat/pkg-descr8
-rw-r--r--textproc/p5-XML-SAX-Expat/pkg-plist7
6 files changed, 46 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 1e8cb3cddc87..2b0cfe89d1ff 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -153,6 +153,7 @@
SUBDIR += p5-XML-Parser
SUBDIR += p5-XML-RSS
SUBDIR += p5-XML-SAX
+ SUBDIR += p5-XML-SAX-Expat
SUBDIR += p5-XML-Sablotron
SUBDIR += p5-XML-Simple
SUBDIR += p5-XML-SimpleObject
diff --git a/textproc/p5-XML-SAX-Expat/Makefile b/textproc/p5-XML-SAX-Expat/Makefile
new file mode 100644
index 000000000000..b43a3c17a636
--- /dev/null
+++ b/textproc/p5-XML-SAX-Expat/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: XML::SAX::Expat
+# Date created: 19 Nov 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-SAX-Expat
+PORTVERSION= 0.05
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/NamespaceSupport.pm:${PORTSDIR}/textproc/p5-XML-NamespaceSupport
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::SAX::Expat.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-SAX-Expat/distinfo b/textproc/p5-XML-SAX-Expat/distinfo
new file mode 100644
index 000000000000..d616dd309d5f
--- /dev/null
+++ b/textproc/p5-XML-SAX-Expat/distinfo
@@ -0,0 +1 @@
+MD5 (XML-SAX-Expat-0.05.tar.gz) = 5a9b3a0c381360e4b84151ad7137800d
diff --git a/textproc/p5-XML-SAX-Expat/pkg-comment b/textproc/p5-XML-SAX-Expat/pkg-comment
new file mode 100644
index 000000000000..a54a304accf2
--- /dev/null
+++ b/textproc/p5-XML-SAX-Expat/pkg-comment
@@ -0,0 +1 @@
+Simple API for XML
diff --git a/textproc/p5-XML-SAX-Expat/pkg-descr b/textproc/p5-XML-SAX-Expat/pkg-descr
new file mode 100644
index 000000000000..723bc03b8e19
--- /dev/null
+++ b/textproc/p5-XML-SAX-Expat/pkg-descr
@@ -0,0 +1,8 @@
+XML::SAX consists of several framework classes for using and building
+Perl SAX2 XML parsers, filters, and drivers. It is designed around the
+need to be able to "plug in" different SAX parsers to an application
+without requiring programmer intervention. Those of you familiar with
+the DBI will be right at home. Some of the designs come from the Java
+JAXP specification (SAX part), only without the javaness.
+
+WWW: http://search.cpan.org/search?dist=XML-SAX-Expat
diff --git a/textproc/p5-XML-SAX-Expat/pkg-plist b/textproc/p5-XML-SAX-Expat/pkg-plist
new file mode 100644
index 000000000000..ed38d8103585
--- /dev/null
+++ b/textproc/p5-XML-SAX-Expat/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/SAX/Expat/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/Expat.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML/SAX 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/SAX/Expat
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/SAX 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true