aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-31 12:30:16 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-31 12:30:16 +0000
commit5f0e6ef2d725d3af4f5ed1f1e643d27e871e09b0 (patch)
tree0c79b060469b64f8b47e46bef3d7a4c40e2cf460 /textproc
parent80fdc440650a550bd98b765b8d95b532e24ad689 (diff)
downloadports-5f0e6ef2d725d3af4f5ed1f1e643d27e871e09b0.tar.gz
ports-5f0e6ef2d725d3af4f5ed1f1e643d27e871e09b0.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ruby-nqxml/Makefile34
-rw-r--r--textproc/ruby-nqxml/distinfo1
-rw-r--r--textproc/ruby-nqxml/pkg-comment1
-rw-r--r--textproc/ruby-nqxml/pkg-descr6
-rw-r--r--textproc/ruby-nqxml/pkg-plist29
6 files changed, 72 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 765a2e9b3c7e..800501a78d8a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -135,6 +135,7 @@
SUBDIR += ruby-csv
SUBDIR += ruby-erb
SUBDIR += ruby-html-parser
+ SUBDIR += ruby-nqxml
SUBDIR += ruby-qt2xml
SUBDIR += ruby-rdtool
SUBDIR += ruby-rss
diff --git a/textproc/ruby-nqxml/Makefile b/textproc/ruby-nqxml/Makefile
new file mode 100644
index 000000000000..14605a446666
--- /dev/null
+++ b/textproc/ruby-nqxml/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: NQXML
+# Date created: 10 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nqxml
+PORTVERSION= 0.5.1
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.io.com/~jimm/downloads/nqxml/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= ChangeLog README Credits TODO
+
+do-install:
+ cd ${WRKSRC} && ${RUBY} install.rb
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-nqxml/distinfo b/textproc/ruby-nqxml/distinfo
new file mode 100644
index 000000000000..803332556e1c
--- /dev/null
+++ b/textproc/ruby-nqxml/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/nqxml-0.5.1.tar.gz) = 2d0913408e868b51082938f600bc1ea3
diff --git a/textproc/ruby-nqxml/pkg-comment b/textproc/ruby-nqxml/pkg-comment
new file mode 100644
index 000000000000..9ea8949903f5
--- /dev/null
+++ b/textproc/ruby-nqxml/pkg-comment
@@ -0,0 +1 @@
+A pure Ruby implementasion of XML tokenizer/parser/writer
diff --git a/textproc/ruby-nqxml/pkg-descr b/textproc/ruby-nqxml/pkg-descr
new file mode 100644
index 000000000000..ec17df265135
--- /dev/null
+++ b/textproc/ruby-nqxml/pkg-descr
@@ -0,0 +1,6 @@
+NQXML is a pure Ruby implementation of an XML tokenizer, a SAX-style
+streaming XML parser, a DOM-style tree parser, and an XML writer.
+``NQ'' for ``Not Quite''.
+
+Author: Jim Menard <jimm@io.com>
+WWW: http://www.io.com/~jimm/downloads/nqxml/index.html
diff --git a/textproc/ruby-nqxml/pkg-plist b/textproc/ruby-nqxml/pkg-plist
new file mode 100644
index 000000000000..22230e03c2b6
--- /dev/null
+++ b/textproc/ruby-nqxml/pkg-plist
@@ -0,0 +1,29 @@
+%%RUBY_SITELIBDIR%%/nqxml/document.rb
+%%RUBY_SITELIBDIR%%/nqxml/domparser.rb
+%%RUBY_SITELIBDIR%%/nqxml/entities.rb
+%%RUBY_SITELIBDIR%%/nqxml/error.rb
+%%RUBY_SITELIBDIR%%/nqxml/info.rb
+%%RUBY_SITELIBDIR%%/nqxml/parser.rb
+%%RUBY_SITELIBDIR%%/nqxml/streamingparser.rb
+%%RUBY_SITELIBDIR%%/nqxml/tokenizer.rb
+%%RUBY_SITELIBDIR%%/nqxml/treeparser.rb
+%%RUBY_SITELIBDIR%%/nqxml/utils.rb
+%%RUBY_SITELIBDIR%%/nqxml/writer.rb
+@dirrm %%RUBY_SITELIBDIR%%/nqxml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nqxml/data.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nqxml/doc.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nqxml/dumpXML.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nqxml/parseTestStream.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nqxml/parseTestTree.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nqxml/printEntityClassNames.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nqxml/reverseTags.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nqxml/reverseText.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nqxml/write.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nqxml/writeManualDoc.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nqxml/writeParsedDoc.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/nqxml
+%%PORTDOCS%%%%RUBY_DOCDIR%%/nqxml/ChangeLog
+%%PORTDOCS%%%%RUBY_DOCDIR%%/nqxml/Credits
+%%PORTDOCS%%%%RUBY_DOCDIR%%/nqxml/README
+%%PORTDOCS%%%%RUBY_DOCDIR%%/nqxml/TODO
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/nqxml