aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-11-26 03:54:01 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-11-26 03:54:01 +0000
commit837ca6f4dc401bd6ac67cd9361614388b9f5d3b3 (patch)
tree992bd4b2b22d8ff80952eb5060b282b274e3318a /textproc
parentac94c20eb3a2c14b7604745fd3e0e29c22b825cb (diff)
downloadports-837ca6f4dc401bd6ac67cd9361614388b9f5d3b3.tar.gz
ports-837ca6f4dc401bd6ac67cd9361614388b9f5d3b3.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/nltk_lite/Makefile30
-rw-r--r--textproc/nltk_lite/distinfo3
-rw-r--r--textproc/nltk_lite/pkg-descr11
4 files changed, 45 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b4fef505b5f3..dcd67809abf4 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -268,6 +268,7 @@
SUBDIR += nl-aspell
SUBDIR += nl-ispell
SUBDIR += nltk
+ SUBDIR += nltk_lite
SUBDIR += nn-aspell
SUBDIR += nunnimcax
SUBDIR += nux
diff --git a/textproc/nltk_lite/Makefile b/textproc/nltk_lite/Makefile
new file mode 100644
index 000000000000..0acc82a3632c
--- /dev/null
+++ b/textproc/nltk_lite/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: nltk_lite
+# Date created: Sat Nov 26 11:13:22 CST 2005
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= nltk_lite
+PORTVERSION= 0.5
+CATEGORIES= textproc python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:C/_.*//}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Lightweight Natural language toolkit written in python
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+USE_PYTHON_PREFIX= yes
+
+.include <bsd.port.pre.mk>
+
+post-install:
+ @${FIND} ${PYTHON_SITELIBDIR}/nltk_lite ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PYTHON_SITELIBDIR}/nltk_lite -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/textproc/nltk_lite/distinfo b/textproc/nltk_lite/distinfo
new file mode 100644
index 000000000000..7989f28d5402
--- /dev/null
+++ b/textproc/nltk_lite/distinfo
@@ -0,0 +1,3 @@
+MD5 (nltk_lite-0.5.tar.gz) = 9f126b59ac7f5e86690c7d52c93aaa22
+SHA256 (nltk_lite-0.5.tar.gz) = aec8493fe386795fc834c558b95dbd3adc7ff486d761c61b8410ca3ddd132f65
+SIZE (nltk_lite-0.5.tar.gz) = 216772
diff --git a/textproc/nltk_lite/pkg-descr b/textproc/nltk_lite/pkg-descr
new file mode 100644
index 000000000000..f0d38efeae58
--- /dev/null
+++ b/textproc/nltk_lite/pkg-descr
@@ -0,0 +1,11 @@
+NLTK-Lite is a new collection of lightweight NLP modules designed for
+maximum simplicity and efficiency. NLTK-Lite only covers the simple
+variants of standard data structures and tasks. Simplicity and
+efficiency are valued over generality and extensibility.
+
+NLTK-Lite is primarily intended to facilitate teaching NLP to students
+having limited programming experience. The focus is on teaching Python
+together with the help of NLP recipes, instead of teaching students to
+use a large set of specialized classes that lock them in to using NLTK.
+
+WWW: http://nltk.sourceforge.net/