aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-10-31 12:46:33 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-10-31 12:46:33 +0000
commita3a9120155ab843486a3748fc90af2c36aebf6f6 (patch)
tree276dbc127afcb6cc8d5451e855468dd9dfa43933 /textproc
parentffa94017d6c39ee2d5c2afd81d3bea30c7ae7fb7 (diff)
downloadports-a3a9120155ab843486a3748fc90af2c36aebf6f6.tar.gz
ports-a3a9120155ab843486a3748fc90af2c36aebf6f6.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/dbacl/Makefile40
-rw-r--r--textproc/dbacl/distinfo1
-rw-r--r--textproc/dbacl/pkg-descr11
-rw-r--r--textproc/dbacl/pkg-plist25
5 files changed, 78 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 47e16ca0cf37..cd26aa068057 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -43,6 +43,7 @@
SUBDIR += cy-aspell
SUBDIR += da-aspell
SUBDIR += dadadodo
+ SUBDIR += dbacl
SUBDIR += dico
SUBDIR += dict
SUBDIR += dictfmt
diff --git a/textproc/dbacl/Makefile b/textproc/dbacl/Makefile
new file mode 100644
index 000000000000..e25de501f70e
--- /dev/null
+++ b/textproc/dbacl/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: dbacl
+# Date created: 2003-10-30
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbacl
+PORTVERSION= 1.4
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Digramic Bayesian classifier
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+PROGRAMS= bayesol dbacl mailinspect
+SCRIPTS= mailcross
+MAN1= bayesol.1 dbacl.1 mailcross.1 mailinspect.1
+DOCS= AUTHORS ChangeLog README dbacl.ps email.html tutorial.html
+EXAMPLES= sample*.txt japanese.txt example*.risk toy.risk prop.pl
+
+do-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_PROGRAM} ${PROGRAMS} ${PREFIX}/bin && \
+ ${INSTALL_SCRIPT} ${SCRIPTS} ${PREFIX}/bin && \
+ ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1 && \
+ ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/dbacl/distinfo b/textproc/dbacl/distinfo
new file mode 100644
index 000000000000..181725f54ef1
--- /dev/null
+++ b/textproc/dbacl/distinfo
@@ -0,0 +1 @@
+MD5 (dbacl-1.4.tar.gz) = 4505b6c1e16f3abf2613a5281240dab1
diff --git a/textproc/dbacl/pkg-descr b/textproc/dbacl/pkg-descr
new file mode 100644
index 000000000000..59d38cbfbb90
--- /dev/null
+++ b/textproc/dbacl/pkg-descr
@@ -0,0 +1,11 @@
+dbacl is a digramic Bayesian text classifier. Given some text,
+it calculates the posterior probabilities that the input resembles
+one of any number of previously learned document collections.
+It can be used to sort incoming email into arbitrary categories
+such as spam, work, and play, or simply to distinguish an English text
+from a French text. It fully supports international character sets,
+and uses sophisticated statistical models based on the
+Maximum Entropy Principle.
+
+Author: Laird A. Breyer <laird@lbreyer.com>
+WWW: http://dbacl.sourceforge.net/
diff --git a/textproc/dbacl/pkg-plist b/textproc/dbacl/pkg-plist
new file mode 100644
index 000000000000..1b119b242c24
--- /dev/null
+++ b/textproc/dbacl/pkg-plist
@@ -0,0 +1,25 @@
+@comment $FreeBSD$
+bin/bayesol
+bin/dbacl
+bin/mailcross
+bin/mailinspect
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/dbacl.ps
+%%PORTDOCS%%%%DOCSDIR%%/email.html
+%%PORTDOCS%%%%DOCSDIR%%/tutorial.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%EXAMPLESDIR%%/example1.risk
+%%EXAMPLESDIR%%/example2.risk
+%%EXAMPLESDIR%%/example3.risk
+%%EXAMPLESDIR%%/japanese.txt
+%%EXAMPLESDIR%%/prop.pl
+%%EXAMPLESDIR%%/sample1.txt
+%%EXAMPLESDIR%%/sample2.txt
+%%EXAMPLESDIR%%/sample3.txt
+%%EXAMPLESDIR%%/sample4.txt
+%%EXAMPLESDIR%%/sample5.txt
+%%EXAMPLESDIR%%/sample6.txt
+%%EXAMPLESDIR%%/toy.risk
+@dirrm %%EXAMPLESDIR%%