aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2015-01-08 11:35:31 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2015-01-08 11:35:31 +0000
commita507bb58616963ad803f07ef14f50fc434b3931a (patch)
tree9ba112c97c4488bfeeea47abf1c93dc1c258974d /textproc
parent809a68913c7ef34604ede277f3e43028e35550f9 (diff)
downloadports-a507bb58616963ad803f07ef14f50fc434b3931a.tar.gz
ports-a507bb58616963ad803f07ef14f50fc434b3931a.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/elasticsearch-plugin-head/Makefile27
-rw-r--r--textproc/elasticsearch-plugin-head/distinfo2
-rw-r--r--textproc/elasticsearch-plugin-head/pkg-descr4
-rw-r--r--textproc/elasticsearch-plugin-head/pkg-plist145
5 files changed, 179 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 34b919e55f75..1cf76b10a374 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -140,6 +140,7 @@
SUBDIR += el-aspell
SUBDIR += el-hyphen
SUBDIR += elasticsearch
+ SUBDIR += elasticsearch-plugin-head
SUBDIR += elasticsearch-plugin-hq
SUBDIR += elasticsearch-plugin-marvel
SUBDIR += emacs-wiki
diff --git a/textproc/elasticsearch-plugin-head/Makefile b/textproc/elasticsearch-plugin-head/Makefile
new file mode 100644
index 000000000000..35ddae109b28
--- /dev/null
+++ b/textproc/elasticsearch-plugin-head/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= head
+PORTVERSION= 2014.11.16
+CATEGORIES= textproc
+PKGNAMEPREFIX= elasticsearch-plugin-
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= ElasticSearch Head Plugin
+
+LICENSE= APACHE20
+
+RUN_DEPENDS:= elasticsearch>=0.90.9:${PORTSDIR}/textproc/elasticsearch
+
+USE_GITHUB= yes
+GH_ACCOUNT= mobz
+GH_PROJECT= elasticsearch-head
+GH_COMMIT= 3706e79
+GH_TAGNAME= ${GH_COMMIT}
+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins/head/_site
+ cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins/head/_site
+
+.include <bsd.port.mk>
diff --git a/textproc/elasticsearch-plugin-head/distinfo b/textproc/elasticsearch-plugin-head/distinfo
new file mode 100644
index 000000000000..79ef3279991b
--- /dev/null
+++ b/textproc/elasticsearch-plugin-head/distinfo
@@ -0,0 +1,2 @@
+SHA256 (head-2014.11.16.tar.gz) = d7895b58351c62b0c3821fdefe1b9e431891aec8fcd93f9fe4889041fe9d68d7
+SIZE (head-2014.11.16.tar.gz) = 842373
diff --git a/textproc/elasticsearch-plugin-head/pkg-descr b/textproc/elasticsearch-plugin-head/pkg-descr
new file mode 100644
index 000000000000..c70ce8383420
--- /dev/null
+++ b/textproc/elasticsearch-plugin-head/pkg-descr
@@ -0,0 +1,4 @@
+Head is a web front end for browsing and interacting with an
+ElasticSearch cluster.
+
+WWW: http://mobz.github.io/elasticsearch-head/
diff --git a/textproc/elasticsearch-plugin-head/pkg-plist b/textproc/elasticsearch-plugin-head/pkg-plist
new file mode 100644
index 000000000000..14b0d4d18a14
--- /dev/null
+++ b/textproc/elasticsearch-plugin-head/pkg-plist
@@ -0,0 +1,145 @@
+lib/elasticsearch/plugins/head/_site/Gruntfile.js
+lib/elasticsearch/plugins/head/_site/LICENCE
+lib/elasticsearch/plugins/head/_site/README.textile
+lib/elasticsearch/plugins/head/_site/dist/app.css
+lib/elasticsearch/plugins/head/_site/dist/app.js
+lib/elasticsearch/plugins/head/_site/dist/base/favicon.png
+lib/elasticsearch/plugins/head/_site/dist/base/loading.gif
+lib/elasticsearch/plugins/head/_site/dist/base/reset.css
+lib/elasticsearch/plugins/head/_site/dist/fonts/FontAwesome.otf
+lib/elasticsearch/plugins/head/_site/dist/fonts/fontawesome-webfont.eot
+lib/elasticsearch/plugins/head/_site/dist/fonts/fontawesome-webfont.svg
+lib/elasticsearch/plugins/head/_site/dist/fonts/fontawesome-webfont.ttf
+lib/elasticsearch/plugins/head/_site/dist/fonts/fontawesome-webfont.woff
+lib/elasticsearch/plugins/head/_site/dist/i18n.js
+lib/elasticsearch/plugins/head/_site/dist/lang/en_strings.js
+lib/elasticsearch/plugins/head/_site/dist/lang/fr_strings.js
+lib/elasticsearch/plugins/head/_site/dist/lang/pt_strings.js
+lib/elasticsearch/plugins/head/_site/dist/vendor.css
+lib/elasticsearch/plugins/head/_site/dist/vendor.js
+lib/elasticsearch/plugins/head/_site/elasticsearch-head.sublime-project
+lib/elasticsearch/plugins/head/_site/grunt_fileSets.js
+lib/elasticsearch/plugins/head/_site/index.html
+lib/elasticsearch/plugins/head/_site/package.json
+lib/elasticsearch/plugins/head/_site/src/app/app.css
+lib/elasticsearch/plugins/head/_site/src/app/app.js
+lib/elasticsearch/plugins/head/_site/src/app/base/boot.js
+lib/elasticsearch/plugins/head/_site/src/app/base/favicon.png
+lib/elasticsearch/plugins/head/_site/src/app/base/loading.gif
+lib/elasticsearch/plugins/head/_site/src/app/base/reset.css
+lib/elasticsearch/plugins/head/_site/src/app/data/boolQuery.js
+lib/elasticsearch/plugins/head/_site/src/app/data/dataSourceInterface.js
+lib/elasticsearch/plugins/head/_site/src/app/data/metaData.js
+lib/elasticsearch/plugins/head/_site/src/app/data/metaDataFactory.js
+lib/elasticsearch/plugins/head/_site/src/app/data/model/model.js
+lib/elasticsearch/plugins/head/_site/src/app/data/model/modelSpec.js
+lib/elasticsearch/plugins/head/_site/src/app/data/query.js
+lib/elasticsearch/plugins/head/_site/src/app/data/queryDataSourceInterface.js
+lib/elasticsearch/plugins/head/_site/src/app/data/resultDataSourceInterface.js
+lib/elasticsearch/plugins/head/_site/src/app/lang/en_strings.js
+lib/elasticsearch/plugins/head/_site/src/app/lang/fr_strings.js
+lib/elasticsearch/plugins/head/_site/src/app/lang/pt_strings.js
+lib/elasticsearch/plugins/head/_site/src/app/services/cluster/cluster.js
+lib/elasticsearch/plugins/head/_site/src/app/services/cluster/clusterSpec.js
+lib/elasticsearch/plugins/head/_site/src/app/services/clusterState/clusterState.js
+lib/elasticsearch/plugins/head/_site/src/app/services/clusterState/clusterStateSpec.js
+lib/elasticsearch/plugins/head/_site/src/app/services/preferences/preferenceSpec.js
+lib/elasticsearch/plugins/head/_site/src/app/services/preferences/preferences.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/abstractField/abstractField.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/abstractField/abstractField.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/abstractPanel/abstractPanel.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/abstractPanel/abstractPanel.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/abstractWidget/abstractWidget.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/anyRequest/anyRequest.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/anyRequest/anyRequest.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/browser/browser.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/browser/browser.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/button/button.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/button/button.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/button/buttonDemo.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/checkField/checkField.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/checkField/checkFieldDemo.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/checkField/checkFieldSpec.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/clusterConnect/clusterConnect.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/clusterConnect/clusterConnect.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/clusterConnect/clusterConnectSpec.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/clusterOverview/clusterOverview.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/clusterOverview/clusterOverview.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/csvTable/csvTable.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/dateHistogram/dateHistogram.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/dialogPanel/dialogPanel.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/draggablePanel/draggablePanel.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/filterBrowser/filterBrowser.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/filterBrowser/filterBrowser.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/header/header.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/header/header.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/helpPanel/helpPanel.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/indexOverview/indexOverview.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/indexSelector/indexSelector.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/infoPanel/infoPanel.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/infoPanel/infoPanel.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/jsonPanel/jsonPanel.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/jsonPanel/jsonPanel.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/jsonPretty/jsonPretty.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/jsonPretty/jsonPretty.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/menuButton/menuButton.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/menuButton/menuButton.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/menuPanel/menuPanel.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/menuPanel/menuPanel.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/nodesView/nodesView.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/nodesView/nodesView.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/nodesView/nodesViewDemo.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/page/page.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/panelForm/panelForm.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/panelForm/panelForm.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/queryFilter/queryFilter.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/queryFilter/queryFilter.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/refreshButton/refreshButton.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/refreshButton/refreshButtonDemo.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/refreshButton/refreshButtonSpec.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/resultTable/resultTable.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/selectMenuPanel/selectMenuPanel.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/selectMenuPanel/selectMenuPanel.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/sidebarSection/sidebarSection.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/sidebarSection/sidebarSection.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/splitButton/splitButton.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/splitButton/splitButton.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/splitButton/splitButtonDemo.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/structuredQuery/structuredQuery.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/structuredQuery/structuredQuery.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/table/table.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/table/table.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/textField/textField.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/textField/textFieldDemo.js
+lib/elasticsearch/plugins/head/_site/src/app/ui/toolbar/toolbar.css
+lib/elasticsearch/plugins/head/_site/src/app/ui/toolbar/toolbar.js
+lib/elasticsearch/plugins/head/_site/src/app/ux/class.js
+lib/elasticsearch/plugins/head/_site/src/app/ux/dragdrop.js
+lib/elasticsearch/plugins/head/_site/src/app/ux/fieldCollection.js
+lib/elasticsearch/plugins/head/_site/src/app/ux/observable.js
+lib/elasticsearch/plugins/head/_site/src/app/ux/singleton.js
+lib/elasticsearch/plugins/head/_site/src/app/ux/singletonSpec.js
+lib/elasticsearch/plugins/head/_site/src/app/ux/table.css
+lib/elasticsearch/plugins/head/_site/src/app/ux/templates/templateSpec.js
+lib/elasticsearch/plugins/head/_site/src/app/ux/templates/templates.js
+lib/elasticsearch/plugins/head/_site/src/vendor/dateRangeParser/date-range-parser.js
+lib/elasticsearch/plugins/head/_site/src/vendor/font-awesome/css/font-awesome.css
+lib/elasticsearch/plugins/head/_site/src/vendor/font-awesome/css/font-awesome.min.css
+lib/elasticsearch/plugins/head/_site/src/vendor/font-awesome/fonts/FontAwesome.otf
+lib/elasticsearch/plugins/head/_site/src/vendor/font-awesome/fonts/fontawesome-webfont.eot
+lib/elasticsearch/plugins/head/_site/src/vendor/font-awesome/fonts/fontawesome-webfont.svg
+lib/elasticsearch/plugins/head/_site/src/vendor/font-awesome/fonts/fontawesome-webfont.ttf
+lib/elasticsearch/plugins/head/_site/src/vendor/font-awesome/fonts/fontawesome-webfont.woff
+lib/elasticsearch/plugins/head/_site/src/vendor/graphael/g.raphael.standalone.js
+lib/elasticsearch/plugins/head/_site/src/vendor/i18n/i18n.js
+lib/elasticsearch/plugins/head/_site/src/vendor/joey/joey.js
+lib/elasticsearch/plugins/head/_site/src/vendor/jquery/jquery.js
+lib/elasticsearch/plugins/head/_site/src/vendor/nohtml/jquery-nohtml.js
+lib/elasticsearch/plugins/head/_site/test/demo.html
+lib/elasticsearch/plugins/head/_site/test/generators/conflictingField.sh
+lib/elasticsearch/plugins/head/_site/test/generators/delete_all_indices.sh
+lib/elasticsearch/plugins/head/_site/test/generators/multi_type.sh
+lib/elasticsearch/plugins/head/_site/test/generators/twitter_feed.sh
+lib/elasticsearch/plugins/head/_site/test/generators/twitter_river.sh
+lib/elasticsearch/plugins/head/_site/test/perf.html
+lib/elasticsearch/plugins/head/_site/test/spec/specHelper.js