aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2008-04-19 07:46:27 +0000
committerThierry Thomas <thierry@FreeBSD.org>2008-04-19 07:46:27 +0000
commitda789f6807736d094f3996ec70f97a8bc252037f (patch)
treed471e241146c9a8f5669df44f46d9c846549cc2e /textproc
parent225d2115e9df3991134b1c6d08fbd2beb0f77c9e (diff)
downloadports-da789f6807736d094f3996ec70f97a8bc252037f.tar.gz
ports-da789f6807736d094f3996ec70f97a8bc252037f.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/aspell/Makefile12
-rw-r--r--textproc/aspell/files/patch-gen_mk-static-filter.pl11
2 files changed, 21 insertions, 2 deletions
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index a9e4460622cf..6ee822b611b9 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aspell
PORTVERSION= 0.60.6
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= aspell
@@ -23,7 +24,6 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-dict-dir=${DATADIR} \
--enable-docdir=${DOCSDIR} \
- --enable-curses=ncursesw \
--enable-static
PTHREAD_CFLAGS= # Disable threading
PTHREAD_LIBS= # libaspell may be used by unthreaded apps.
@@ -84,6 +84,14 @@ INFO= aspell-dev aspell
CFLAGS+= -O
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 602107
+CONFIGURE_ARGS+= --disable-wide-curses
+.else
+CONFIGURE_ARGS+= --enable-curses=ncursesw
+.endif
+
pre-everything::
@${ECHO_MSG} ""
.if !defined(WITH_ISPELL)
@@ -123,4 +131,4 @@ inst-dicten:
>> ${TMPPLIST}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/aspell/files/patch-gen_mk-static-filter.pl b/textproc/aspell/files/patch-gen_mk-static-filter.pl
new file mode 100644
index 000000000000..7ff663380b20
--- /dev/null
+++ b/textproc/aspell/files/patch-gen_mk-static-filter.pl
@@ -0,0 +1,11 @@
+--- gen/mk-static-filter.pl.orig 2007-12-03 07:43:09.000000000 +0100
++++ gen/mk-static-filter.pl 2008-04-18 22:34:26.000000000 +0200
+@@ -159,7 +159,7 @@
+ printf STATICFILTERS "\n const KeyInfo * ".${$filter}{"NAME"}."_options_begin = ".
+ ${$filter}{"NAME"}."_options;\n";
+ # If structure is empty, set options_end to same as options_begin.
+- if (%{$filter}) {
++ if ($firstopt) {
+ printf STATICFILTERS "\n const KeyInfo * ".${$filter}{"NAME"}."_options_end = ".
+ ${$filter}{"NAME"}."_options;\n";
+ } else {