aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-26 05:58:46 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-26 05:58:46 +0000
commit4063cea348b00971a70335299bcc52c12fabcc1d (patch)
treeed7e1bd418e465d0baf0a72733a27420e0367231 /textproc
parent2f46a82cfc1b0f5531b58297f16223829d0ae513 (diff)
downloadports-4063cea348b00971a70335299bcc52c12fabcc1d.tar.gz
ports-4063cea348b00971a70335299bcc52c12fabcc1d.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/Makefile32
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/distinfo1
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/pkg-comment1
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/pkg-descr2
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/pkg-plist50
6 files changed, 87 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4ce18f7dc2da..9299dc66929b 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -70,6 +70,7 @@
SUBDIR += no-ispell
SUBDIR += openjade
SUBDIR += p5-Spreadsheet-ParseExcel
+ SUBDIR += p5-Spreadsheet-WriteExcel
SUBDIR += p5-Text-CSV_XS
SUBDIR += p5-Text-Template
SUBDIR += p5-XML-DOM
diff --git a/textproc/p5-Spreadsheet-WriteExcel/Makefile b/textproc/p5-Spreadsheet-WriteExcel/Makefile
new file mode 100644
index 000000000000..d87b5c9f0b1a
--- /dev/null
+++ b/textproc/p5-Spreadsheet-WriteExcel/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Spreadsheet::WriteExcel
+# Date created: 25 Dec 2000
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Spreadsheet-WriteExcel
+PORTVERSION= 0.23
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Spreadsheet
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+USE_PERL5= yes
+
+MAN3= Spreadsheet::WriteExcel::Worksheet.3 \
+ Spreadsheet::WriteExcel::BIFFwriter.3 \
+ Spreadsheet::WriteExcel::OLEwriter.3 \
+ Spreadsheet::WriteExcel::Workbook.3 \
+ Spreadsheet::WriteExcel::examples::WorkbookBig.3 \
+ Spreadsheet::WriteExcel.3 Spreadsheet::WriteExcel::Format.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL PREFIX=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Spreadsheet-WriteExcel/distinfo b/textproc/p5-Spreadsheet-WriteExcel/distinfo
new file mode 100644
index 000000000000..2d0728139c95
--- /dev/null
+++ b/textproc/p5-Spreadsheet-WriteExcel/distinfo
@@ -0,0 +1 @@
+MD5 (Spreadsheet-WriteExcel-0.23.tar.gz) = 1ce062729ee4b82982c250c7afe12596
diff --git a/textproc/p5-Spreadsheet-WriteExcel/pkg-comment b/textproc/p5-Spreadsheet-WriteExcel/pkg-comment
new file mode 100644
index 000000000000..df38cbf98a01
--- /dev/null
+++ b/textproc/p5-Spreadsheet-WriteExcel/pkg-comment
@@ -0,0 +1 @@
+Write formatted text and numbers to a cross-platform Excel binary file.
diff --git a/textproc/p5-Spreadsheet-WriteExcel/pkg-descr b/textproc/p5-Spreadsheet-WriteExcel/pkg-descr
new file mode 100644
index 000000000000..56ce6c0d76b8
--- /dev/null
+++ b/textproc/p5-Spreadsheet-WriteExcel/pkg-descr
@@ -0,0 +1,2 @@
+Spreadsheet::WriteExcel - Write formatted text and numbers to a
+cross-platform Excel binary file.
diff --git a/textproc/p5-Spreadsheet-WriteExcel/pkg-plist b/textproc/p5-Spreadsheet-WriteExcel/pkg-plist
new file mode 100644
index 000000000000..7ddeb459dee9
--- /dev/null
+++ b/textproc/p5-Spreadsheet-WriteExcel/pkg-plist
@@ -0,0 +1,50 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Spreadsheet/WriteExcel/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel.pm
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/BIFFwriter.pm
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/Format.pm
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/OLEwriter.pm
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/Workbook.pm
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/Worksheet.pm
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/WriteExcel.html
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/examples.html
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/index.html
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/merge1.gif
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/merge2.gif
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/number_formats1.html
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/number_formats2.html
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/regions.gif
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/simple.gif
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/stocks.gif
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/textwrap.gif
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/tpj.html
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/tpj0503-0004-01.gif
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/tpj0503-0004-02.gif
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/tpj0503-0004-03.gif
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/tpj0503-0004-04.gif
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/tpj0503-0004-05.gif
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/win32ole.gif
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/Big.pm
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/WorkbookBig.pm
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/big.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/cgi.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/copyformat.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/csv2xls.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/easter_egg.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/formats.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/merge1.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/merge2.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/ms_time.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/regions.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/simple.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/stocks.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/tab2xls.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/textwrap.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/win32ole.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/writeA1.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/writemany.pl
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Spreadsheet/WriteExcel
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Spreadsheet 2>/dev/null || true