aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2010-11-20 16:12:54 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2010-11-20 16:12:54 +0000
commit4f0b0085fa07c43515fdd47f14ab21ff930c2f49 (patch)
treefe8c874dbd608bf81ebb297b8157cd1336c88734 /textproc
parentd86c6170e2b14fa2882e2b26cfe21285bd802137 (diff)
downloadports-4f0b0085fa07c43515fdd47f14ab21ff930c2f49.tar.gz
ports-4f0b0085fa07c43515fdd47f14ab21ff930c2f49.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/estraier/Makefile39
-rw-r--r--textproc/estraier/distinfo6
-rw-r--r--textproc/estraier/files/patch-Makefile.in11
-rw-r--r--textproc/estraier/pkg-descr2
4 files changed, 25 insertions, 33 deletions
diff --git a/textproc/estraier/Makefile b/textproc/estraier/Makefile
index 40a584e391a8..297e9fc3f922 100644
--- a/textproc/estraier/Makefile
+++ b/textproc/estraier/Makefile
@@ -6,54 +6,57 @@
#
PORTNAME= estraier
-PORTVERSION= 1.2.29
-PORTREVISION= 4
+PORTVERSION= 1.2.30
CATEGORIES= textproc
-MASTER_SITES= SF \
- http://estraier.sourceforge.net/
-
+MASTER_SITES= http://fallabs.com/estraier/
MAINTAINER= ports@FreeBSD.org
COMMENT= A full-text search system for personal use
LIB_DEPENDS= qdbm.14:${PORTSDIR}/databases/qdbm
-USE_ICONV= yes
+OPTIONS= CHASEN "Japanese Morphological Analysis Support" Off \
+ MECAB "Part-of-Speech and Morphological Analyzer" Off \
+ KAKASI "Language processing filter/converter" On
+USE_ICONV= yes
GNU_CONFIGURE= yes
-
CONFIGURE_ARGS= --with-sysqdbm \
--enable-dlfilter \
--enable-devel
-
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/include ${PTHREAD_LIBS}"
-OPTIONS= CHASEN "Japanese Morphological Analysis Support" Off \
- MECAB "Part-of-Speech and Morphological Analyzer" Off \
- KAKASI "Language processing filter/converter" On
-
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_CHASEN)
+.if defined(WITH_CHASEN)
LIB_DEPENDS+= chasen.2:${PORTSDIR}/japanese/chasen-base
-
CONFIGURE_ARGS+= --enable-chasen
.endif
-.if ${ARCH} == i386 && defined(WITH_MECAB)
+.if defined(WITH_MECAB) && ${ARCH} == "i386"
LIB_DEPENDS+= mecab.1:${PORTSDIR}/japanese/mecab
-
CONFIGURE_ARGS+= --enable-mecab
.endif
.if !defined(WITHOUT_KAKASI)
LIB_DEPENDS+= kakasi.3:${PORTSDIR}/japanese/kakasi
-
CONFIGURE_ARGS+= --enable-kakasi
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-O2|${CFLAGS}|' ${WRKSRC}/configure ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|-lc ||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|-O2|@CFLAGS@|g ; \
+ s|HOME|LOCALBASE|g ; \
+ s|:/usr/local/lib||g ; \
+ s|-I/usr/local/include|${PTHREAD_CFLAGS}|g ; \
+ s|-L/usr/local/lib|${PTHREAD_LIBS}|g' ${WRKSRC}/Makefile.in
+
+post-install:
+.for file in estindex estmbtomh estserver estsiutil estxview
+ @${STRIP_CMD} ${PREFIX}/bin/${file}
+.endfor
.include <bsd.port.post.mk>
diff --git a/textproc/estraier/distinfo b/textproc/estraier/distinfo
index c790e80fb430..3ded43b0750a 100644
--- a/textproc/estraier/distinfo
+++ b/textproc/estraier/distinfo
@@ -1,3 +1,3 @@
-MD5 (estraier-1.2.29.tar.gz) = 50577e59b949c25499d78ab0eb1c1d0e
-SHA256 (estraier-1.2.29.tar.gz) = fa0c1dba51e4c317c843e007ade1ae071f3891b68b0c4568de48d44626bf9724
-SIZE (estraier-1.2.29.tar.gz) = 410823
+MD5 (estraier-1.2.30.tar.gz) = 5b59ca42689919fd2af6da7697f14173
+SHA256 (estraier-1.2.30.tar.gz) = 13cc5dc9d8c00938539cad65f910b2e74d5d81cfef5796d3794a139526937ede
+SIZE (estraier-1.2.30.tar.gz) = 501480
diff --git a/textproc/estraier/files/patch-Makefile.in b/textproc/estraier/files/patch-Makefile.in
deleted file mode 100644
index b09d993bc7db..000000000000
--- a/textproc/estraier/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.bak Wed May 17 08:19:28 2006
-+++ Makefile.in Wed May 17 08:19:59 2006
-@@ -43,7 +43,7 @@
- -D_XOPEN_SOURCE_EXTENDED=1 -D_GNU_SOURCE=1 -D__EXTENSIONS__=1 -D_HPUX_SOURCE=1
- CFLAGS = -Wall -fsigned-char $(RELCFLAGS)
- LIBS = -L./qdbm -lqdbm @LIBS@
--LDFLAGS = -L. -L./qdbm -L$(HOME)/lib -L/usr/local/lib $(LIBS)
-+LDFLAGS = -L. -L./qdbm -L$(HOME)/lib -L/usr/local/lib $(LIBS) $(PTHREAD_LIBS)
- LDENV = LD_RUN_PATH=/lib:/usr/lib:$(HOME)/lib:/usr/local/lib
- lpath = $(HOME)/lib:/usr/local/lib:$(LD_LIBRARY_PATH):$(DYLD_LIBRARY_PATH):$(SHLIB_PATH)
- RUNENV = LD_LIBRARY_PATH="$(lpath)" DYLD_LIBRARY_PATH="$(lpath)" SHLIB_PATH="$(lpath)"
diff --git a/textproc/estraier/pkg-descr b/textproc/estraier/pkg-descr
index 7434dac46912..96d4328f8dca 100644
--- a/textproc/estraier/pkg-descr
+++ b/textproc/estraier/pkg-descr
@@ -4,4 +4,4 @@ words. The principal purpose of Estraier is to realize a full-text search
system of a web site. It functions similarly to Google, but for a personal
web site or sites in an intranet.
-WWW: http://estraier.sourceforge.net/
+WWW: http://fallabs.com/estraier/