aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /textproc
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadports-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
ports-074ea5282a00d556c73d86231bec5444990597dc.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ctpp2/Makefile12
-rw-r--r--textproc/ctpp2/files/patch-src-CTPP2StringIconvOutputCollector.cpp20
-rw-r--r--textproc/ctpp2/files/patch-src-functions-FnIconv.cpp20
-rw-r--r--textproc/estraier/Makefile13
-rw-r--r--textproc/gmetadom/files/patch-GdomeSmartDOMGdomeString.cc11
-rw-r--r--textproc/goldendict/files/patch-bgl_babylon.cc14
-rw-r--r--textproc/goldendict/files/patch-iconv.cc14
-rw-r--r--textproc/hyperestraier/Makefile8
-rw-r--r--textproc/p5-Text-Unaccent/Makefile6
-rw-r--r--textproc/p5-XML-TinyXML/Makefile6
-rw-r--r--textproc/simplexml/Makefile4
-rw-r--r--textproc/simplexml/files/patch-cmake__FindIconv.cmake61
-rw-r--r--textproc/wbxml2/Makefile13
-rw-r--r--textproc/wbxml2/files/patch-cmake-modules-FindIconv.cmake32
-rw-r--r--textproc/xmlppm/files/patch-IFile.cpp11
15 files changed, 161 insertions, 84 deletions
diff --git a/textproc/ctpp2/Makefile b/textproc/ctpp2/Makefile
index f226da73cfa0..54bb662c9ca1 100644
--- a/textproc/ctpp2/Makefile
+++ b/textproc/ctpp2/Makefile
@@ -3,14 +3,14 @@
PORTNAME= ctpp2
PORTVERSION= 2.8.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc devel
MASTER_SITES= http://ctpp.havoc.ru/download/
MAINTAINER= vg@FreeBSD.org
COMMENT= C++ library to use templates in C/C++ projects, version 2
-USES= cmake gettext iconv:build compiler:c++11-lang
+USES= cmake gettext iconv compiler:c++11-lang
USE_LDCONFIG= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
@@ -41,4 +41,10 @@ OPTIMIZATION_CMAKE_OFF= -DENABLE_OPTIMIZATION=OFF
PORTDOCS= template_language.html
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+CMAKE_ARGS+= -DSKIP_ICONV_LIRARY:STRING=ON
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/ctpp2/files/patch-src-CTPP2StringIconvOutputCollector.cpp b/textproc/ctpp2/files/patch-src-CTPP2StringIconvOutputCollector.cpp
new file mode 100644
index 000000000000..8fa6c070dd53
--- /dev/null
+++ b/textproc/ctpp2/files/patch-src-CTPP2StringIconvOutputCollector.cpp
@@ -0,0 +1,20 @@
+--- src/CTPP2StringIconvOutputCollector.cpp.orig 2012-08-02 07:22:44 UTC
++++ src/CTPP2StringIconvOutputCollector.cpp
+@@ -56,7 +56,7 @@ StringIconvOutputCollector::StringIconvO
+ throw CTPPCharsetRecodeException(sSrcEnc.c_str(), sDstEnc.c_str());
+ }
+
+-#if (_LIBICONV_VERSION >= 0x0108)
++#if (_LIBICONV_VERSION >= 0x0108) || defined(__FreeBSD__)
+ int iFlag = 1;
+ // Discard illegal characters
+ if (iFlags & C_ICONV_DISCARD_ILSEQ) { iconvctl(oIconv, ICONV_SET_DISCARD_ILSEQ, &iFlag); }
+@@ -85,7 +85,7 @@ INT_32 StringIconvOutputCollector::Colle
+ size_t iDstLength = CTPP_ESCAPE_BUFFER_LEN;
+
+ char aDstData[CTPP_ESCAPE_BUFFER_LEN];
+-#if defined(linux) || defined(__APPLE__)
++#if defined(linux) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__DragonFly__)
+ char * aSrcData = (char *)vData;
+ #else
+ const char * aSrcData = (const char *)vData;
diff --git a/textproc/ctpp2/files/patch-src-functions-FnIconv.cpp b/textproc/ctpp2/files/patch-src-functions-FnIconv.cpp
new file mode 100644
index 000000000000..6c30f7cb2691
--- /dev/null
+++ b/textproc/ctpp2/files/patch-src-functions-FnIconv.cpp
@@ -0,0 +1,20 @@
+--- src/functions/FnIconv.cpp.orig 2012-08-02 07:22:44 UTC
++++ src/functions/FnIconv.cpp
+@@ -145,7 +145,7 @@ INT_32 FnIconv::Handler(CDT *
+ }
+ }
+
+-#if (_LIBICONV_VERSION >= 0x0108)
++#if (_LIBICONV_VERSION >= 0x0108) || defined(__FreeBSD__)
+ int iFlag = 1;
+ // Discard illegal characters
+ if (iFlags & C_ICONV_DISCARD_ILSEQ)
+@@ -173,7 +173,7 @@ INT_32 FnIconv::Handler(CDT *
+ size_t iDstLength = CTPP_ESCAPE_BUFFER_LEN;
+
+ char aDstData[CTPP_ESCAPE_BUFFER_LEN];
+-#if defined(linux) || defined(__APPLE__)
++#if defined(linux) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__DragonFly__)
+ char * aSrcData = (char *)sWhat.data();
+ #else
+ const char * aSrcData = (const char *)sWhat.data();
diff --git a/textproc/estraier/Makefile b/textproc/estraier/Makefile
index 518995fa1eec..6ae5798f132e 100644
--- a/textproc/estraier/Makefile
+++ b/textproc/estraier/Makefile
@@ -3,7 +3,7 @@
PORTNAME= estraier
PORTVERSION= 1.2.30
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= http://fallabs.com/estraier/
@@ -24,7 +24,7 @@ CONFIGURE_ARGS= --with-sysqdbm \
--enable-dlfilter \
--enable-devel
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lpthread -L${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/include
CHASEN_LIB_DEPENDS= libchasen.so:${PORTSDIR}/japanese/chasen-base
CHASEN_CONFIGURE_ENABLE= chasen
@@ -40,14 +40,15 @@ CONFIGURE_ARGS+= --enable-mecab
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|-lc||' -e 's|-liconv|${ICONV_LIB}|' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
- 's|-lc ||g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
- 's|-O2|@CFLAGS@|g ; \
+ 's|$$(RELCFLAGS)|@CFLAGS@| ; \
+ s|^LDFLAGS =|& @LDFLAGS@ | ; \
s|HOME|LOCALBASE|g ; \
s|:/usr/local/lib||g ; \
s|-I/usr/local/include||g ; \
- s|-L/usr/local/lib|-lpthread|g' ${WRKSRC}/Makefile.in
+ s|-L/usr/local/lib||g' ${WRKSRC}/Makefile.in
post-install:
.for file in estindex estmbtomh estserver estsiutil estxview
diff --git a/textproc/gmetadom/files/patch-GdomeSmartDOMGdomeString.cc b/textproc/gmetadom/files/patch-GdomeSmartDOMGdomeString.cc
deleted file mode 100644
index ea4e3b550e41..000000000000
--- a/textproc/gmetadom/files/patch-GdomeSmartDOMGdomeString.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gdome_cpp_smart/basic/GdomeSmartDOMGdomeString.cc.orig Wed Apr 2 12:36:39 2003
-+++ src/gdome_cpp_smart/basic/GdomeSmartDOMGdomeString.cc Wed Apr 2 12:37:21 2003
-@@ -95,7 +95,7 @@
-
- while (inBytesLeft > 0) {
- //cout << "before: " << (void*) inbuf << " " << inBytesLeft << " " << (void*) outbuf << " " << outBytesLeft << endl;
-- size_t iconv_res = iconv(cd, &inbuf, &inBytesLeft, &outbuf, &outBytesLeft);
-+ size_t iconv_res = iconv(cd, (const char**)&inbuf, &inBytesLeft, &outbuf, &outBytesLeft);
- //cout << "after: " << (void*) inbuf << " " << inBytesLeft << " " << (void*) outbuf << " " << outBytesLeft << endl;
-
- unsigned n = outbuf - outbuf0;
diff --git a/textproc/goldendict/files/patch-bgl_babylon.cc b/textproc/goldendict/files/patch-bgl_babylon.cc
index fc170af97e0d..7c185934881c 100644
--- a/textproc/goldendict/files/patch-bgl_babylon.cc
+++ b/textproc/goldendict/files/patch-bgl_babylon.cc
@@ -8,17 +8,3 @@
#include<iconv.h>
#include <QTextDocument>
-@@ -648,13 +648,8 @@
-
- inbufbytes = s.size();
- outbufbytes = s.size() * 6;
--#ifdef _WIN32
- const char *inbuf;
- inbuf = s.data();
--#else
-- char *inbuf;
-- inbuf = (char *)s.data();
--#endif
- outbuf = (char*)malloc( outbufbytes + 1 );
- memset( outbuf, '\0', outbufbytes + 1 );
- defbuf = outbuf;
diff --git a/textproc/goldendict/files/patch-iconv.cc b/textproc/goldendict/files/patch-iconv.cc
deleted file mode 100644
index d32904bee641..000000000000
--- a/textproc/goldendict/files/patch-iconv.cc
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./iconv.cc.orig 2010-12-04 00:12:46.000000000 +0300
-+++ ./iconv.cc 2010-12-28 11:46:37.208721626 +0300
-@@ -44,11 +44,7 @@
- throw( exIncorrectSeq, exOther )
- {
- size_t result = iconv( state,
-- #ifdef __WIN32
- (char const **)&inBuf,
-- #else
-- (char **)&inBuf,
-- #endif
- &inBytesLeft,
- (char **)&outBuf, &outBytesLeft );
-
diff --git a/textproc/hyperestraier/Makefile b/textproc/hyperestraier/Makefile
index e06feea1aa81..70cca9d69caa 100644
--- a/textproc/hyperestraier/Makefile
+++ b/textproc/hyperestraier/Makefile
@@ -4,7 +4,7 @@
PORTNAME= hyperestraier
PORTVERSION= 1.4.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF
@@ -23,7 +23,7 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-bzip2 --disable-zlib
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= LZO MECAB
@@ -39,8 +39,10 @@ MECAB_RUN_DEPENDS= ${LOCALBASE}/lib/mecab/dic/ipadic/matrix.bin:${PORTSDIR}/japa
post-patch:
@${REINPLACE_CMD} -e 's|@libdir@/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
+ -e 's/@MYCFLAGS@/@CFLAGS@ -Wall -fPIC -fsigned-char/' \
${WRKSRC}/Makefile.in
- ${RM} -f ${WRKSRC}/doc/intro-en.html~ ${WRKSRC}/doc/intro-ja.html~
+ @${REINPLACE_CMD} 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/configure
+ @${RM} -f ${WRKSRC}/doc/intro-en.html~ ${WRKSRC}/doc/intro-ja.html~
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libestraier.so
diff --git a/textproc/p5-Text-Unaccent/Makefile b/textproc/p5-Text-Unaccent/Makefile
index 4c14eb20a0a9..d203942ed022 100644
--- a/textproc/p5-Text-Unaccent/Makefile
+++ b/textproc/p5-Text-Unaccent/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Text-Unaccent
PORTVERSION= 1.08
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,6 +15,8 @@ LICENSE= GPLv2
USES= iconv perl5
USE_PERL5= configure
-CFLAGS+= -DICONV_CONST=const
+
+post-patch:
+ @${REINPLACE_CMD} 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/textproc/p5-XML-TinyXML/Makefile b/textproc/p5-XML-TinyXML/Makefile
index 5a8c40f31bd1..729059105a16 100644
--- a/textproc/p5-XML-TinyXML/Makefile
+++ b/textproc/p5-XML-TinyXML/Makefile
@@ -3,7 +3,7 @@
PORTNAME= XML-TinyXML
PORTVERSION= 0.34
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,6 +14,8 @@ COMMENT= Little and efficient Perl module to manage xml data
USES= iconv perl5
USE_PERL5= configure
-MAKE_ARGS+= LIBS='-L${LOCALBASE}/lib' INC='-I. -I${LOCALBASE}/include'
+CONFIGURE_ARGS= LIBS="-L${LOCALBASE}/lib ${ICONV_LIB}" \
+ INC="-I. -I${LOCALBASE}/include"
+CFLAGS+= -DUSE_ICONV
.include <bsd.port.mk>
diff --git a/textproc/simplexml/Makefile b/textproc/simplexml/Makefile
index 2a7eb66fa516..dba29260a152 100644
--- a/textproc/simplexml/Makefile
+++ b/textproc/simplexml/Makefile
@@ -3,6 +3,7 @@
PORTNAME= simplexml
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://bitbucket.org/klepa/simplexml/get/
DISTNAME= ${PORTVERSION}
@@ -24,7 +25,6 @@ CMAKE_ARGS+= -DDEBUG_MODE:BOOL=ON
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|; \
- /set.*CMAKE_BUILD_TYPE/d' ${WRKSRC}/CMakeLists.txt \
- ${WRKSRC}/cmake/FindIconv.cmake
+ /set.*CMAKE_BUILD_TYPE/d' ${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/textproc/simplexml/files/patch-cmake__FindIconv.cmake b/textproc/simplexml/files/patch-cmake__FindIconv.cmake
index a7d1db0ad0db..b52dadbd0a2f 100644
--- a/textproc/simplexml/files/patch-cmake__FindIconv.cmake
+++ b/textproc/simplexml/files/patch-cmake__FindIconv.cmake
@@ -1,11 +1,60 @@
---- cmake/FindIconv.cmake.orig 2014-09-03 02:19:35 UTC
+--- cmake/FindIconv.cmake.orig 2010-08-17 10:55:45 UTC
+++ cmake/FindIconv.cmake
-@@ -40,7 +40,7 @@
+@@ -30,45 +30,29 @@
+ # also defined, but not for general use are
+ # Iconv_LIBRARY, where to find the Iconv library.
+
++include(CheckFunctionExists)
++
+ set(ICONV_H iconv.h)
+
+
+ find_path(ICONV_INCLUDE_DIR ${ICONV_H}
+- PATHS /usr/local/include
+- /usr/include
+- NO_DEFAULT_PATH
DOC "Path to the ${ICONV_H} file"
)
-find_library(Iconv_LIBRARY NAMES iconv
-+find_library(Iconv_LIBRARY NAMES iconv c
- PATHS /usr/local/lib
- /usr/lib
- NO_DEFAULT_PATH
+- PATHS /usr/local/lib
+- /usr/lib
+- NO_DEFAULT_PATH
+- DOC "Library for character set conversion"
+-)
+-
+-if(ICONV_INCLUDE_DIR AND Iconv_LIBRARY)
+- set(Iconv_FOUND TRUE)
+-else(ICONV_INCLUDE_DIR AND Iconv_LIBRARY)
+- set(Iconv_FOUND FALSE)
+-endif(ICONV_INCLUDE_DIR AND Iconv_LIBRARY)
++if(ICONV_INCLUDE_DIR)
++ check_function_exists(iconv Iconv_FOUND)
++ if(NOT Iconv_FOUND)
++ find_library(Iconv_LIBRARY NAMES iconv libiconv libiconv-2)
++ if(Iconv_LIBRARY)
++ set(Iconv_FOUND TRUE)
++ endif(Iconv_LIBRARY)
++ endif(NOT Iconv_FOUND)
++endif(ICONV_INCLUDE_DIR)
+
+ if(Iconv_FOUND)
+ if(NOT Iconv_FIND_QUIETLY)
+- message(STATUS "Found Iconv: ${Iconv_LIBARY}")
++ message(STATUS "Found Iconv: ${Iconv_LIBRARY}")
+ endif(NOT Iconv_FIND_QUIETLY)
+-else(Iconv_FOUND)
+- if("${CMAKE_SYSTEM_NAME}" MATCHES "FreeBSD")
+- if(NOT Iconv_FIND_QUIETLY)
+- if(Iconv_FIND_REQUIRED)
+- message(FATAL_ERROR "Could not find the Iconv Library")
+- else(Iconv_FIND_REQUIRED)
+- message(STATUS "Could not find the Iconv Library")
+- endif(Iconv_FIND_REQUIRED)
+- endif(NOT Iconv_FIND_QUIETLY)
+- else("${CMAKE_SYSTEM_NAME}" MATCHES "FreeBSD")
+- set(Iconv_LIBRARY "")
+- endif("${CMAKE_SYSTEM_NAME}" MATCHES "FreeBSD")
+ endif(Iconv_FOUND)
+
+ mark_as_advanced(ICONV_INCLUDE_DIR Iconv_LIBRARY)
diff --git a/textproc/wbxml2/Makefile b/textproc/wbxml2/Makefile
index 3713431d068e..0f280bad6eb3 100644
--- a/textproc/wbxml2/Makefile
+++ b/textproc/wbxml2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wbxml2
PORTVERSION= 0.10.9
+PORTREVISION= 1
CATEGORIES= textproc devel
MASTER_SITES= SF/libwbxml/libwbxml/${PORTVERSION}
DISTNAME= libwbxml-${PORTVERSION}
@@ -15,22 +16,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
-WRKSRC= ${WRKDIR}/libwbxml-${PORTVERSION}
-CONFIGURE_WRKSRC= ${WRKDIR}/libwbxml-${PORTVERSION}/build
-BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
-INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
-
-USES= cmake iconv tar:bzip2
-CMAKE_SOURCE_PATH= ..
+USES= cmake:outsource iconv tar:bzip2
USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/libwbxml-${PORTVERSION}
DOCSDIR= ${PREFIX}/share/doc/libwbxml
OPTIONS_DEFINE= DOCS
-post-extract:
- @${MKDIR} ${CONFIGURE_WRKSRC}
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in AUTHORS BUGS ChangeLog NEWS README References THANKS TODO
diff --git a/textproc/wbxml2/files/patch-cmake-modules-FindIconv.cmake b/textproc/wbxml2/files/patch-cmake-modules-FindIconv.cmake
new file mode 100644
index 000000000000..1b8a36387d22
--- /dev/null
+++ b/textproc/wbxml2/files/patch-cmake-modules-FindIconv.cmake
@@ -0,0 +1,32 @@
+--- cmake/modules/FindIconv.cmake.orig 2011-01-08 16:22:19 UTC
++++ cmake/modules/FindIconv.cmake
+@@ -6,6 +6,8 @@
+ #
+ # Copyright (c) 2010 Michael Bell <michael.bell@web.de>
+
++include(CheckFunctionExists)
++
+ if (ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
+ # Already in cache, be silent
+ set(ICONV_FIND_QUIETLY TRUE)
+@@ -13,11 +15,15 @@ endif (ICONV_INCLUDE_DIR AND ICONV_LIBRA
+
+ find_path(ICONV_INCLUDE_DIR iconv.h)
+
+-find_library(ICONV_LIBRARIES NAMES iconv libiconv libiconv-2 c)
+-
+-if (ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
+- set (ICONV_FOUND TRUE)
+-endif (ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
++if (ICONV_INCLUDE_DIR)
++ check_function_exists(iconv ICONV_FOUND)
++ if (NOT ICONV_FOUND)
++ find_library(ICONV_LIBRARIES NAMES iconv libiconv libiconv-2)
++ if (ICONV_LIBRARIES)
++ set (ICONV_FOUND TRUE)
++ endif (ICONV_LIBRARIES)
++ endif (NOT ICONV_FOUND)
++endif (ICONV_INCLUDE_DIR)
+
+ set(CMAKE_REQUIRED_INCLUDES ${ICONV_INCLUDE_DIR})
+ set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBRARIES})
diff --git a/textproc/xmlppm/files/patch-IFile.cpp b/textproc/xmlppm/files/patch-IFile.cpp
deleted file mode 100644
index 110f3136c7a3..000000000000
--- a/textproc/xmlppm/files/patch-IFile.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/IFile.cpp.orig Thu Jun 10 04:16:13 2004
-+++ src/IFile.cpp Tue Aug 17 23:21:02 2004
-@@ -73,7 +73,7 @@
- writing the output. Then flush the file. */
- void ifflush(IFILE* ifile) {
- static char outbuf[BUFFSIZE];
-- char* inptr = ifile->buf;
-+ const char* inptr = ifile->buf;
- char* outptr = outbuf;
- size_t insz = ifile->bufsiz;
- size_t outsz;