aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-25 16:56:45 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-25 16:56:45 +0000
commit309551a29415977fbeb0ebae8e5a96fb237ea369 (patch)
tree599c604fdc2d81db2559c26b1aa47f30d19016e3 /textproc
parent25d740c31b0505f920b31424f43219c4f2cdedab (diff)
downloadports-309551a29415977fbeb0ebae8e5a96fb237ea369.tar.gz
ports-309551a29415977fbeb0ebae8e5a96fb237ea369.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-MathML-Entities/Makefile30
-rw-r--r--textproc/p5-MathML-Entities/distinfo3
-rw-r--r--textproc/p5-MathML-Entities/pkg-descr17
-rw-r--r--textproc/p5-MathML-Entities/pkg-plist5
5 files changed, 56 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 61f0c6e47ee2..51bf3d307516 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -366,6 +366,7 @@
SUBDIR += p5-MARC
SUBDIR += p5-MARC-Record
SUBDIR += p5-Makefile-Parser
+ SUBDIR += p5-MathML-Entities
SUBDIR += p5-NetAddr-IP-Find
SUBDIR += p5-Number-Format
SUBDIR += p5-PDF-API2
diff --git a/textproc/p5-MathML-Entities/Makefile b/textproc/p5-MathML-Entities/Makefile
new file mode 100644
index 000000000000..a350b39f13a6
--- /dev/null
+++ b/textproc/p5-MathML-Entities/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-MathML-Entities
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MathML-Entities
+PORTVERSION= 0.13
+CATEGORIES= textproc www math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= MathML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Convert XHTML+MathML Named Entities to Numeric Character References
+
+MAN3= MathML::Entities.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars qw{$$1};$$1/g' \
+ ${WRKSRC}/lib/MathML/Entities.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-MathML-Entities/distinfo b/textproc/p5-MathML-Entities/distinfo
new file mode 100644
index 000000000000..e1ede09b27fb
--- /dev/null
+++ b/textproc/p5-MathML-Entities/distinfo
@@ -0,0 +1,3 @@
+MD5 (MathML-Entities-0.13.tar.gz) = 95d2a4e322bf8061167924323a8873b0
+SHA256 (MathML-Entities-0.13.tar.gz) = 80a79a84a4bcf9742798c31f3f48c07674fd71b890100441a7176281f46233d4
+SIZE (MathML-Entities-0.13.tar.gz) = 17935
diff --git a/textproc/p5-MathML-Entities/pkg-descr b/textproc/p5-MathML-Entities/pkg-descr
new file mode 100644
index 000000000000..c1803cd78c26
--- /dev/null
+++ b/textproc/p5-MathML-Entities/pkg-descr
@@ -0,0 +1,17 @@
+MathML::Entities a content conversion filter for named XHTML+MathML
+entities. There are over two thousand named entities in the XHTML+MathML
+DTD. All the Entities defined in the XHTML+MathML DTD except the five
+"safe" ones (&lt;, &gt;, &amp;, &quot;, &apos;), will be converted to the
+equivalent numeric character references or to utf-8 characters. Named
+entities which are not in the XHTML+MathML DTD are escaped. This makes the
+resulting XHTML (or XHTML+MathML) safe for consumption by non-validating
+XML parsers.
+
+Unlike, HTML::Entities, the mapping between MathML named entities and
+codepoints is many-to-one. Therefore, there's no particular sense in
+having an inverse function, which takes codepoints to named entities.
+
+Based on: HTML::Entities by Koichi Taniguchi <taniguchi@livedoor.jp>
+
+WWW: http://search.cpan.org/dist/MathML-Entities
+Author: Jacques Distler <distler@golem.ph.utexas.edu>
diff --git a/textproc/p5-MathML-Entities/pkg-plist b/textproc/p5-MathML-Entities/pkg-plist
new file mode 100644
index 000000000000..a245c2f48f31
--- /dev/null
+++ b/textproc/p5-MathML-Entities/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/MathML/Entities.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MathML/Entities/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MathML/Entities
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MathML
+@dirrmtry %%SITE_PERL%%/MathML