aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
commit642be1b81d8342d3a3323f43bcf5a0bd87a5d363 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /textproc
parentbcaced2c93b58d27ca266602f4049df6ba6becb3 (diff)
downloadports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.tar.gz
ports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/exempi/Makefile2
-rw-r--r--textproc/freexl/Makefile2
-rw-r--r--textproc/kmflcomp/Makefile2
-rw-r--r--textproc/odt2txt/Makefile3
-rw-r--r--textproc/p5-XML-Sablotron/Makefile2
-rw-r--r--textproc/sablotron/Makefile2
-rw-r--r--textproc/unrtf/Makefile2
-rw-r--r--textproc/xalan-c/Makefile2
-rw-r--r--textproc/xerces-c2/Makefile1
-rw-r--r--textproc/xmlppm/Makefile2
10 files changed, 11 insertions, 9 deletions
diff --git a/textproc/exempi/Makefile b/textproc/exempi/Makefile
index bd59fb72e744..f09b40d80c4e 100644
--- a/textproc/exempi/Makefile
+++ b/textproc/exempi/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_AUTOTOOLS= libtool
USE_GNOME= ltverhack
CONFIGURE_ARGS= --enable-unittest=no
-CONFIGURE_ENV= LIBS="-liconv"
+CONFIGURE_ENV= LIBS="${ICONV_LIB}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USES= pathfix iconv
diff --git a/textproc/freexl/Makefile b/textproc/freexl/Makefile
index ce0f9caeb6cc..69a69f427a73 100644
--- a/textproc/freexl/Makefile
+++ b/textproc/freexl/Makefile
@@ -14,7 +14,7 @@ USE_GMAKE= yes
USES= iconv
CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS+=CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
diff --git a/textproc/kmflcomp/Makefile b/textproc/kmflcomp/Makefile
index 05a2b066fd5f..1f4333848432 100644
--- a/textproc/kmflcomp/Makefile
+++ b/textproc/kmflcomp/Makefile
@@ -26,7 +26,7 @@ USE_LDCONFIG= yes
USES= iconv
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
DOCSDIR= ${PREFIX}/share/doc/kmfl/${PORTNAME}
DOCS= ${DISTDIR}/${DIST_SUBDIR}/KMFL-Compiler.sxw \
diff --git a/textproc/odt2txt/Makefile b/textproc/odt2txt/Makefile
index f18dac99c4d1..76d4a54bce1c 100644
--- a/textproc/odt2txt/Makefile
+++ b/textproc/odt2txt/Makefile
@@ -27,7 +27,8 @@ PLIST_FILES= bin/odt2txt
MAN1= odt2txt.1
post-patch:
- ${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' \
+ -e 's#-liconv#${ICONV_LIB}#' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/odt2txt ${PREFIX}/bin/odt2txt
diff --git a/textproc/p5-XML-Sablotron/Makefile b/textproc/p5-XML-Sablotron/Makefile
index d1bd82194987..12cc3efd4b90 100644
--- a/textproc/p5-XML-Sablotron/Makefile
+++ b/textproc/p5-XML-Sablotron/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= sablot.70:${PORTSDIR}/textproc/sablotron
USES= iconv perl5
USE_PERL5= configure
-CONFIGURE_ARGS= LIBS='-L${LOCALBASE}/lib -lexpat -lsablot -liconv' \
+CONFIGURE_ARGS= LIBS='-L${LOCALBASE}/lib -lexpat -lsablot ${ICONV_LIB}' \
INC='-I${LOCALBASE}/include' \
EXPATLIBPATH='${LOCALBASE}/lib' \
EXPATINCPATH='${LOCALBASE}/include' \
diff --git a/textproc/sablotron/Makefile b/textproc/sablotron/Makefile
index d9f18ff23d11..5b6547506e99 100644
--- a/textproc/sablotron/Makefile
+++ b/textproc/sablotron/Makefile
@@ -36,7 +36,7 @@ PLIST_SUB+= SHLIB_MAJOR="${SHLIB_MAJOR}"
CONFIGURE_ENV= LIBTOOL=${LIBTOOL}
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lexpat -liconv
+LDFLAGS+= -L${LOCALBASE}/lib -lexpat ${ICONV_LIB}
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USES= iconv perl5
diff --git a/textproc/unrtf/Makefile b/textproc/unrtf/Makefile
index 14ea76f3d00f..09f202b05782 100644
--- a/textproc/unrtf/Makefile
+++ b/textproc/unrtf/Makefile
@@ -27,7 +27,7 @@ PLIST_FILES= bin/unrtf \
PLIST_DIRS= %%DATADIR%%
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
post-patch:
@${FIND} -X ${WRKSRC} -type f -and -name "*.[1h]" | ${XARGS} \
diff --git a/textproc/xalan-c/Makefile b/textproc/xalan-c/Makefile
index b821a6c57d1b..e058846cde89 100644
--- a/textproc/xalan-c/Makefile
+++ b/textproc/xalan-c/Makefile
@@ -89,7 +89,7 @@ MAKE_ENV+= ICUROOT=${ICUROOT}
PLIST_SUB+= ICUDEP=""
.else
USES+= iconv
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
PLIST_SUB+= ICUDEP="@comment "
.endif
diff --git a/textproc/xerces-c2/Makefile b/textproc/xerces-c2/Makefile
index 85080c1b2801..11d9f46468ba 100644
--- a/textproc/xerces-c2/Makefile
+++ b/textproc/xerces-c2/Makefile
@@ -115,6 +115,7 @@ post-patch:
@${REINPLACE_CMD} -e 's#CP = -cp -p#CP = -cp#' \
${WRKSRC}/src/xercesc/Makefile.incl
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ -e 's|-liconv|${ICONV_LIB}|' \
${WRKSRC}/src/xercesc/Makefile.incl \
${WRKSRC}/src/xercesc/runConfigure
@${SED} -i '' 's| /\* argV\[\] \*/|* argV|' \
diff --git a/textproc/xmlppm/Makefile b/textproc/xmlppm/Makefile
index 64fa5c3f8115..a27694bbb0cc 100644
--- a/textproc/xmlppm/Makefile
+++ b/textproc/xmlppm/Makefile
@@ -22,7 +22,7 @@ USES= iconv
USE_GMAKE= yes
MAKE_ARGS= CC="${CXX}" CFLAGS="${CXXFLAGS}" \
CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lexpat -liconv"
+ LDFLAGS="-L${LOCALBASE}/lib -lexpat ${ICONV_LIB}"
GNU_CONFIGURE= yes
.if !defined(NOPORTDOCS)