aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorJeremy Chadwick <koitsu@FreeBSD.org>2008-11-02 01:32:14 +0000
committerJeremy Chadwick <koitsu@FreeBSD.org>2008-11-02 01:32:14 +0000
commit6c8915f3688f5916b4b403a42802a159ae964136 (patch)
tree040073138d13ada38b45f5956734b678b4f94a1d /textproc
parentda0e1e77c6540fc4eb79e74a34ceacebefd59484 (diff)
downloadports-6c8915f3688f5916b4b403a42802a159ae964136.tar.gz
ports-6c8915f3688f5916b4b403a42802a159ae964136.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/hs-stringsearch/Makefile37
-rw-r--r--textproc/hs-stringsearch/distinfo3
-rw-r--r--textproc/hs-stringsearch/pkg-descr5
-rw-r--r--textproc/hs-stringsearch/pkg-plist15
5 files changed, 61 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index ad2dbfd06657..878eac974940 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -206,6 +206,7 @@
SUBDIR += hil-aspell
SUBDIR += hr-aspell
SUBDIR += hs-haxml
+ SUBDIR += hs-stringsearch
SUBDIR += hsb-aspell
SUBDIR += htdig
SUBDIR += html
diff --git a/textproc/hs-stringsearch/Makefile b/textproc/hs-stringsearch/Makefile
new file mode 100644
index 000000000000..a4186284b99c
--- /dev/null
+++ b/textproc/hs-stringsearch/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: stringsearch
+# Date created: November 1, 2008
+# Whom: Samy Al Bahra <sbahra@kerneled.org>
+#
+# $FreeBSD$
+
+PORTNAME= stringsearch
+PORTVERSION= 0.2.1.1
+CATEGORIES= textproc haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/stringsearch/${PORTVERSION}/ \
+ http://kerneled.org/tmp/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= sbahra@kerneled.org
+COMMENT= Boyer-Moore/Knuth-Morris-Pratt string search library
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+CABAL= ${LOCALBASE}/bin/runghc Setup.lhs
+GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${SUBDIR}
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+
+do-build:
+ cd ${WRKSRC} && ${CABAL} build && ${CABAL} register --gen-script
+
+do-install:
+ cd ${WRKSRC} && ${CABAL} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
+
+.include <bsd.port.mk>
diff --git a/textproc/hs-stringsearch/distinfo b/textproc/hs-stringsearch/distinfo
new file mode 100644
index 000000000000..9f8145afff96
--- /dev/null
+++ b/textproc/hs-stringsearch/distinfo
@@ -0,0 +1,3 @@
+MD5 (stringsearch-0.2.1.1.tar.gz) = aec3ca2a0a81f793df69133fc7716404
+SHA256 (stringsearch-0.2.1.1.tar.gz) = 48d31d88f5bd749d7c41da6cd6666513d499ff9d3243e4d2b59ae3235c8d829a
+SIZE (stringsearch-0.2.1.1.tar.gz) = 8206
diff --git a/textproc/hs-stringsearch/pkg-descr b/textproc/hs-stringsearch/pkg-descr
new file mode 100644
index 000000000000..35e9b67bc1fe
--- /dev/null
+++ b/textproc/hs-stringsearch/pkg-descr
@@ -0,0 +1,5 @@
+This library provides Boyer-Moore and Knuth-Morris-Pratt string search
+implementations for Haskell bytestrings (with support for all strict and
+lazy ByteString permutations).
+
+WWW: http://hackage.haskell.org/cgi-bin/hackage-scripts/package/stringsearch
diff --git a/textproc/hs-stringsearch/pkg-plist b/textproc/hs-stringsearch/pkg-plist
new file mode 100644
index 000000000000..b7b3a8d0040d
--- /dev/null
+++ b/textproc/hs-stringsearch/pkg-plist
@@ -0,0 +1,15 @@
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/libHSstringsearch-%%PORTVERSION%%.a
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/HSstringsearch-%%PORTVERSION%%.o
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Data/ByteString/Search/BoyerMoore.hi
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Data/ByteString/Search/KnuthMorrisPratt.hi
+%%SUBDIR%%/register.sh
+share/doc/stringsearch-%%PORTVERSION%%/LICENSE
+@dirrm share/doc/stringsearch-%%PORTVERSION%%
+@dirrm lib/stringsearch-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Data/ByteString/Search
+@dirrm lib/stringsearch-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Data/ByteString
+@dirrm lib/stringsearch-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Data
+@dirrm lib/stringsearch-%%PORTVERSION%%/ghc-%%GHC_VERSION%%
+@dirrm lib/stringsearch-%%PORTVERSION%%
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister stringsearch
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old