aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>2006-05-23 15:48:25 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>2006-05-23 15:48:25 +0000
commit6cc4e2a4b206b89f181cca140cfba777dc6265de (patch)
tree00a0ef403c75f26297d44fcd6396530ac765b3f8 /textproc
parent2798ac3b4749dde7390e1923084093d3eae23740 (diff)
downloadports-6cc4e2a4b206b89f181cca140cfba777dc6265de.tar.gz
ports-6cc4e2a4b206b89f181cca140cfba777dc6265de.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ispell/Makefile11
-rw-r--r--textproc/ispell/scripts/configure6
2 files changed, 15 insertions, 2 deletions
diff --git a/textproc/ispell/Makefile b/textproc/ispell/Makefile
index 2fb41c331169..4ce55419276e 100644
--- a/textproc/ispell/Makefile
+++ b/textproc/ispell/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= ispell
PORTVERSION?= 3.2.06
-PORTREVISION?= 14
+PORTREVISION?= 15
CATEGORIES+= textproc
MASTER_SITES= http://fmg-www.cs.ucla.edu/geoff/tars/ \
http://distfiles.opendarwin.org/
@@ -44,7 +44,8 @@ pre-everything::
@${ECHO_MSG} '* Use make-flag: *'
# @${ECHO_MSG} '* - Afrikaans ISPELL_AF=yes *'
@${ECHO_MSG} '* - British ISPELL_BRITISH=yes *'
- @${ECHO_MSG} '* (replaces the American dictionary) *'
+ @${ECHO_MSG} '* (replaces the American dictionary, specify also *'
+ @${ECHO_MSG} '* ISPELL_INCLAMERICAN=yes to have both) *'
@${ECHO_MSG} '* - Brazilian Portuguese ISPELL_BR=yes *'
@${ECHO_MSG} '* - Bulgarian ISPELL_BG=yes *'
@${ECHO_MSG} '* - Dutch ISPELL_NL=yes *'
@@ -63,6 +64,9 @@ pre-everything::
.else
.if defined(ISPELL_BRITISH)
SCRIPTS_ENV+= ISPELL_BRITISH=${ISPELL_BRITISH}
+.if defined(ISPELL_INCLAMERICAN)
+SCRIPTS_ENV+= ISPELL_INCLAMERICAN=${ISPELL_INCLAMERICAN}
+.endif
.endif
.if defined(ISPELL_IT)
ITDISTFILE= ispell-it2001.tgz
@@ -333,6 +337,9 @@ post-install:
.endif
.if defined(ISPELL_BRITISH)
@${CAT} ${MASTERDIR}/pkg-plist.british >> ${TMPPLIST}
+.if defined(ISPELL_INCLAMERICAN)
+ @${CAT} ${MASTERDIR}/pkg-plist.am >> ${TMPPLIST}
+.endif
.else
@${CAT} ${MASTERDIR}/pkg-plist.am >> ${TMPPLIST}
.endif
diff --git a/textproc/ispell/scripts/configure b/textproc/ispell/scripts/configure
index 5c4f10fdc3d5..7d5036e17cc6 100644
--- a/textproc/ispell/scripts/configure
+++ b/textproc/ispell/scripts/configure
@@ -14,6 +14,12 @@ cd $WRKSRC || exit 1;
sed -e s:/usr/local:$PREFIX: <local.h.samp >local.h || exit 1;
echo "#undef NO8BIT" >> local.h
+
+if [ ! -z "ISPELL_INCLAMERICAN" ] && \
+ [ "$ISPELL_INCLAMERICAN" = "YES" -o "$ISPELL_INCLAMERICAN" = "yes" ]; then
+ LOCAL="{american,MASTERDICTS=american.med+,HASHFILES=americanmed+.hash,EXTRADICT=/usr/share/dict/words}"
+ fi
+
if [ ! -z "$ISPELL_BRITISH" ] && \
[ "$ISPELL_BRITISH" = "YES" -o "$ISPELL_BRITISH" = "yes" ]; then
echo "#define LANGUAGES \"{british,MASTERDICTS=british.xlg,HASHFILES=britishxlg.hash,EXTRADICT=}$LOCAL\"" >>local.h ||exit 1;