aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-15 02:31:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-15 02:31:28 +0000
commit982aa704c10b267d6ec53fb545edd2dde57b8324 (patch)
tree08b1c1ff196da97f945c0ab7b0c9760b55807ff2 /textproc
parentb67a28791a0371d8bde0cfa4e774b3aac5411530 (diff)
downloadports-982aa704c10b267d6ec53fb545edd2dde57b8324.tar.gz
ports-982aa704c10b267d6ec53fb545edd2dde57b8324.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libxml2/Makefile10
-rw-r--r--textproc/libxml2/distinfo2
-rw-r--r--textproc/libxml2/files/patch-aa36
-rw-r--r--textproc/libxml2/files/patch-ad12
-rw-r--r--textproc/libxml2/files/patch-configure18
-rw-r--r--textproc/libxml2/files/patch-python::Makefile.in6
-rw-r--r--textproc/libxml2/files/patch-python::tests::Makefile.in12
7 files changed, 52 insertions, 44 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index ac9f8375c231..3feac8619e9e 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libxml2
-PORTVERSION= 2.5.9
+PORTVERSION= 2.5.10
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.5
@@ -26,7 +26,7 @@ USE_REINPLACE= yes
CONFIGURE_ARGS= --with-iconv=${LOCALBASE} \
--with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= xml2-config.1 xmllint.1 xmlcatalog.1
MAN3= libxml.3
@@ -34,6 +34,7 @@ MAN3= libxml.3
.if !defined(WITHOUT_PYTHON)
USE_PYTHON= yes
PLIST_SUB+= PYTHON:=""
+CONFIGURE_ARGS+= --with-python=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-python
PLIST_SUB+= PYTHON:="@comment "
@@ -69,12 +70,13 @@ pre-everything::
@${ECHO_MSG} " WITHOUT_PYTHON=yes Turns off Python support"
@${ECHO_MSG} " WITH_THREADS=yes Turns on pthread support"
@${ECHO_MSG} " WITH_SCHEMA=yes Turns on XML Schema support"
- @${ECHO_MSG} " WITH_MEM_DEBUG=yes Turns on memory debugging"
+ @${ECHO_MSG} " WITH_MEM_DEBUG=yes Turns on memory debugging (DEVELOPERS ONLY!)"
@${ECHO_MSG} " WITH_XMLLINT_HIST=yes Turns on history for xmllint"
- @${ECHO_MSG} " WITH_THREAD_ALLOC=yes Turns on per-thread memory"
+ @${ECHO_MSG} " WITH_THREAD_ALLOC=yes Turns on per-thread memory (DEVELOPERS ONLY!)"
@${ECHO_MSG} ""
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/catalog.c ${WRKSRC}/xmlcatalog.c
+
.include <bsd.port.mk>
diff --git a/textproc/libxml2/distinfo b/textproc/libxml2/distinfo
index c67c83cc7195..d7bc5676ac14 100644
--- a/textproc/libxml2/distinfo
+++ b/textproc/libxml2/distinfo
@@ -1 +1 @@
-MD5 (gnome2/libxml2-2.5.9.tar.bz2) = 43dab6e1682b80af1d0773a0a3b33cea
+MD5 (gnome2/libxml2-2.5.10.tar.bz2) = cb2934ee74ff4349b0005d8fa29a7532
diff --git a/textproc/libxml2/files/patch-aa b/textproc/libxml2/files/patch-aa
index 19dfe4f4dfbf..09476deebc19 100644
--- a/textproc/libxml2/files/patch-aa
+++ b/textproc/libxml2/files/patch-aa
@@ -1,47 +1,47 @@
---- Makefile.in.orig Tue Nov 19 00:01:49 2002
-+++ Makefile.in Tue Nov 19 00:04:06 2002
-@@ -137,7 +137,7 @@
- Z_CFLAGS = @Z_CFLAGS@
- Z_LIBS = @Z_LIBS@
+--- Makefile.in.orig Thu Aug 14 22:02:48 2003
++++ Makefile.in Thu Aug 14 22:04:43 2003
+@@ -153,7 +153,7 @@
+ install_sh = @install_sh@
+ pythondir = @pythondir@
-SUBDIRS = include . doc example @PYTHON_SUBDIR@
+SUBDIRS = include . doc example @WITH_PYTHON_TRUE@ @PYTHON_SUBDIR@
DIST_SUBDIRS = include . doc example python
-@@ -154,7 +154,7 @@
+@@ -171,7 +171,7 @@
lib_LTLIBRARIES = libxml2.la
libxml2_la_LIBADD = @THREAD_LIBS@ @Z_LIBS@ $(ICONV_LIBS) -lm
-libxml2_la_LDFLAGS = -version-info @LIBXML_VERSION_INFO@
+libxml2_la_LDFLAGS = -version-info 5:0:0
- @WITH_TRIO_SOURCES_TRUE@libxml2_la_SOURCES = @WITH_TRIO_SOURCES_TRUE@SAX.c entities.c encoding.c error.c parserInternals.c \
+
+ @WITH_TRIO_SOURCES_TRUE@libxml2_la_SOURCES = SAX.c entities.c encoding.c error.c parserInternals.c \
@WITH_TRIO_SOURCES_TRUE@ parser.c tree.c hash.c list.c xmlIO.c xmlmemory.c uri.c \
- @WITH_TRIO_SOURCES_TRUE@ valid.c xlink.c HTMLparser.c HTMLtree.c debugXML.c xpath.c \
-@@ -239,7 +239,7 @@
+@@ -270,7 +270,7 @@
CLEANFILES = xml2Conf.sh
-confexecdir = $(libdir)
+confexecdir = $(sysconfdir)
confexec_DATA = xml2Conf.sh
- EXTRA_DIST = xml2-config.in xml2Conf.sh.in libxml.spec.in libxml.spec \
+ EXTRA_DIST = xml2-config.in xml2Conf.sh.in libxml.spec.in libxml2.spec \
libxml.m4 Copyright check-xml-test-suite.py \
-@@ -257,7 +257,7 @@
+@@ -289,7 +289,7 @@
# Instll the tests program sources as examples
#
BASE_DIR = $(datadir)/doc
-DOC_MODULE = libxml2-$(VERSION)
+DOC_MODULE = libxml2
EXAMPLES_DIR = $(BASE_DIR)/$(DOC_MODULE)/examples
+ subdir = .
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
-@@ -1354,7 +1354,7 @@
- uninstall-confexecDATA uninstall-m4dataDATA \
- uninstall-pkgconfigDATA
- uninstall: uninstall-recursive
+@@ -1034,7 +1034,7 @@
+ check-am: all-am
+ $(MAKE) $(AM_MAKEFLAGS) check-local
+ check: check-recursive
-all-am: Makefile $(LTLIBRARIES) $(PROGRAMS) $(SCRIPTS) $(MANS) $(DATA) \
+all-am: Makefile $(LTLIBRARIES) $(SCRIPTS) $(MANS) $(DATA) \
config.h
- all-redirect: all-recursive-am
- install-strip:
+ install-binPROGRAMS: install-libLTLIBRARIES
+
diff --git a/textproc/libxml2/files/patch-ad b/textproc/libxml2/files/patch-ad
index 950263cfa9fb..6a7282d2c80c 100644
--- a/textproc/libxml2/files/patch-ad
+++ b/textproc/libxml2/files/patch-ad
@@ -1,11 +1,11 @@
---- doc/Makefile.in.orig Sat Mar 31 17:53:38 2001
-+++ doc/Makefile.in Sat Mar 31 17:54:08 2001
-@@ -112,7 +112,7 @@
- Z_CFLAGS = @Z_CFLAGS@
- Z_LIBS = @Z_LIBS@
+--- doc/Makefile.in.orig Thu Aug 14 22:05:15 2003
++++ doc/Makefile.in Thu Aug 14 22:05:46 2003
+@@ -153,7 +153,7 @@
+ pythondir = @pythondir@
+ # The name of the module.
-DOC_MODULE = libxml2-$(VERSION)
+DOC_MODULE = libxml2
# The top-level SGML file.
- DOC_MAIN_SGML_FILE = gnome-xml.sgml
+ DOC_MAIN_XML_FILE = gnome-xml.xml
diff --git a/textproc/libxml2/files/patch-configure b/textproc/libxml2/files/patch-configure
index fc4c106f533f..d954c8093e1f 100644
--- a/textproc/libxml2/files/patch-configure
+++ b/textproc/libxml2/files/patch-configure
@@ -1,9 +1,6 @@
-
-$FreeBSD$
-
---- configure 2002/04/26 07:47:10 1.1
-+++ configure 2002/04/26 07:47:25
-@@ -5539,6 +5539,7 @@
+--- configure.orig Thu Aug 14 20:33:30 2003
++++ configure Thu Aug 14 22:12:01 2003
+@@ -8256,6 +8256,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -11,3 +8,12 @@ $FreeBSD$
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -14275,7 +14276,7 @@
+ fi
+ if test "$with_python" != ""
+ then
+- pythondir='$(PYTHON_SITE_PACKAGES)'
++ pythondir='$(libdir)/python${PYTHON_VERSION}/site-packages'
+ else
+ pythondir='$(libdir)/python${PYTHON_VERSION}/site-packages'
+ fi
diff --git a/textproc/libxml2/files/patch-python::Makefile.in b/textproc/libxml2/files/patch-python::Makefile.in
index 3f25c609648b..e7f8a271b16b 100644
--- a/textproc/libxml2/files/patch-python::Makefile.in
+++ b/textproc/libxml2/files/patch-python::Makefile.in
@@ -1,6 +1,6 @@
---- python/Makefile.in.orig Wed Apr 17 21:43:23 2002
-+++ python/Makefile.in Wed Apr 17 21:44:01 2002
-@@ -141,7 +141,7 @@
+--- python/Makefile.in.orig Thu Aug 14 22:06:11 2003
++++ python/Makefile.in Thu Aug 14 22:06:39 2003
+@@ -161,7 +161,7 @@
-I$(top_srcdir)/include
diff --git a/textproc/libxml2/files/patch-python::tests::Makefile.in b/textproc/libxml2/files/patch-python::tests::Makefile.in
index da65832f2df1..b0b5df548d0e 100644
--- a/textproc/libxml2/files/patch-python::tests::Makefile.in
+++ b/textproc/libxml2/files/patch-python::tests::Makefile.in
@@ -1,9 +1,9 @@
---- python/tests/Makefile.in.orig Wed Apr 17 21:45:40 2002
-+++ python/tests/Makefile.in Wed Apr 17 21:46:32 2002
-@@ -130,7 +130,7 @@
- Z_CFLAGS = @Z_CFLAGS@
- Z_LIBS = @Z_LIBS@
-
+--- python/tests/Makefile.in.orig Thu Aug 14 22:07:15 2003
++++ python/tests/Makefile.in Thu Aug 14 22:07:43 2003
+@@ -150,7 +150,7 @@
+ am__quote = @am__quote@
+ install_sh = @install_sh@
+ pythondir = @pythondir@
-EXAMPLE_DIR = $(datadir)/doc/libxml2-python-$(LIBXML_VERSION)/examples
+EXAMPLE_DIR = $(datadir)/doc/libxml2-python/examples