aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
commit5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /textproc
parent9c92503171817f96d944009b9ea88d3c083c9a45 (diff)
downloadports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.tar.gz
ports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Notes
Notes: svn path=/head/; revision=444324
Diffstat (limited to 'textproc')
-rw-r--r--textproc/clucene/Makefile2
-rw-r--r--textproc/zxing-cpp/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/textproc/clucene/Makefile b/textproc/clucene/Makefile
index 7474e553a31c..bcab28b2796f 100644
--- a/textproc/clucene/Makefile
+++ b/textproc/clucene/Makefile
@@ -16,7 +16,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= ${LOCALBASE}/lib/libboost_regex.a:devel/boost-libs
-USES= cmake ninja
+USES= cmake
USE_LDCONFIG= yes
CMAKE_ARGS= -DBUILD_CONTRIBS_LIB=ON
diff --git a/textproc/zxing-cpp/Makefile b/textproc/zxing-cpp/Makefile
index bb15a44a31d0..48bb54ad45da 100644
--- a/textproc/zxing-cpp/Makefile
+++ b/textproc/zxing-cpp/Makefile
@@ -16,6 +16,6 @@ USE_GITHUB= yes
GH_ACCOUNT= glassechidna
GH_TAGNAME= 97e9c5c
-USES= cmake:outsource gmake iconv
+USES= cmake:outsource iconv
.include <bsd.port.mk>