aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-06-20 13:59:08 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-06-20 13:59:08 +0000
commita057cae1844b524ebf0d2ef535cba9fec1a3c7bd (patch)
tree0e24de223b4575ccd5f3bc8d17907680e6f05b38 /textproc
parentd331103b7c6381a487473515a14037d9a773dacd (diff)
downloadports-a057cae1844b524ebf0d2ef535cba9fec1a3c7bd.tar.gz
ports-a057cae1844b524ebf0d2ef535cba9fec1a3c7bd.zip
Update textproc/tinyxml2 to 5.0.0
- Use PLIST instead of PLIST_FILES - Bump PORTREVISION for shlib change Changes: https://github.com/leethomason/tinyxml2/commits/master
Notes
Notes: svn path=/head/; revision=443975
Diffstat (limited to 'textproc')
-rw-r--r--textproc/tinyxml2/Makefile13
-rw-r--r--textproc/tinyxml2/distinfo6
-rw-r--r--textproc/tinyxml2/pkg-plist9
3 files changed, 16 insertions, 12 deletions
diff --git a/textproc/tinyxml2/Makefile b/textproc/tinyxml2/Makefile
index fc3c757e81b1..d1a700869d9e 100644
--- a/textproc/tinyxml2/Makefile
+++ b/textproc/tinyxml2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tinyxml2
-PORTVERSION= 4.0.1
+PORTVERSION= 5.0.0
PORTEPOCH= 1
CATEGORIES= textproc
@@ -17,20 +17,15 @@ CMAKE_ARGS= -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=ON
USE_LDCONFIG= yes
USES= cmake dos2unix pathfix
-PLIST_FILES= include/tinyxml2.h \
- lib/libtinyxml2.a \
- lib/libtinyxml2.so \
- lib/libtinyxml2.so.${PORTVERSION:R:R} \
- lib/libtinyxml2.so.${PORTVERSION} \
- libdata/pkgconfig/tinyxml2.pc
-PORTEXAMPLES= resources xmltest.cpp
+PLIST_SUB= PORTVERSION=${PORTVERSION} SHLIB_VER=${PORTVERSION:R:R}
+PORTEXAMPLES= *
GH_ACCOUNT= leethomason
USE_GITHUB= yes
post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
- cd ${WRKSRC}/ && ${COPYTREE_SHARE} "${PORTEXAMPLES}" ${STAGEDIR}${EXAMPLESDIR}/
+ cd ${WRKSRC}/ && ${COPYTREE_SHARE} resources ${STAGEDIR}${EXAMPLESDIR}/
do-test:
cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} xmltest && ./xmltest
diff --git a/textproc/tinyxml2/distinfo b/textproc/tinyxml2/distinfo
index 4c1f2cabbd29..aaea0a27d962 100644
--- a/textproc/tinyxml2/distinfo
+++ b/textproc/tinyxml2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1495726911
-SHA256 (leethomason-tinyxml2-4.0.1_GH0.tar.gz) = 14b38ef25cc136d71339ceeafb4856bb638d486614103453eccd323849267f20
-SIZE (leethomason-tinyxml2-4.0.1_GH0.tar.gz) = 344295
+TIMESTAMP = 1497958457
+SHA256 (leethomason-tinyxml2-5.0.0_GH0.tar.gz) = d88cd8cece80162a2d7a1a0801aa4fc771d4ed6b094b475d00f303eda30bc87d
+SIZE (leethomason-tinyxml2-5.0.0_GH0.tar.gz) = 349522
diff --git a/textproc/tinyxml2/pkg-plist b/textproc/tinyxml2/pkg-plist
new file mode 100644
index 000000000000..3156968321ed
--- /dev/null
+++ b/textproc/tinyxml2/pkg-plist
@@ -0,0 +1,9 @@
+include/tinyxml2.h
+lib/cmake/tinyxml2/tinyxml2Config.cmake
+lib/cmake/tinyxml2/tinyxml2Targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/tinyxml2/tinyxml2Targets.cmake
+lib/libtinyxml2.a
+lib/libtinyxml2.so
+lib/libtinyxml2.so.%%SHLIB_VER%%
+lib/libtinyxml2.so.%%PORTVERSION%%
+libdata/pkgconfig/tinyxml2.pc