aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-12 18:57:25 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-12 18:57:25 +0000
commit1f10416736ceac3b645d0b84f9fcdc94e82905c3 (patch)
treed3278878767140b56b246164499c802403088ef6 /textproc
parent0352bcfa983fae6b4284642dfb17605d176916f4 (diff)
downloadports-1f10416736ceac3b645d0b84f9fcdc94e82905c3.tar.gz
ports-1f10416736ceac3b645d0b84f9fcdc94e82905c3.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ruby-qt2xml/Makefile22
-rw-r--r--textproc/ruby-qt2xml/pkg-plist33
2 files changed, 41 insertions, 14 deletions
diff --git a/textproc/ruby-qt2xml/Makefile b/textproc/ruby-qt2xml/Makefile
index 9d6431223225..a76afd1fcac9 100644
--- a/textproc/ruby-qt2xml/Makefile
+++ b/textproc/ruby-qt2xml/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= qt2xml
-PORTVERSION= 0.11
+PORTVERSION= ${RUBY_QT2_PORTVERSION}
CATEGORIES= textproc x11-toolkits ruby
-MASTER_SITES= http://sfns.u-shizuoka-ken.ac.jp/geneng/horie_hp/ruby/
+MASTER_SITES= ${RUBY_QT2_MASTER_SITES}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= ruby-qt2-${PORTVERSION}
+DISTNAME= ${RUBY_QT2_DISTNAME}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
@@ -18,16 +18,14 @@ MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/qt2.so:${RUBY_QT2_PORTDIR}
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/qt2.so:${RUBY_QT2_PORTDIR}
-RUBY_QT2_PORTDIR= ${PORTSDIR}/x11-toolkits/ruby-qt2
-
-MD5_FILE= ${RUBY_QT2_PORTDIR}/distinfo
-
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
USE_GMAKE= yes
-WRKSRC= ${WRKDIR}/qt2/modules/xml
+.include "${.CURDIR}/../../x11-toolkits/ruby-qt2/Makefile.common"
+
+WRKSRC= ${RUBY_QT2_WRKSRC}/modules/xml
CONFIGURE_ARGS= --with-qt2-include=${X11BASE}/include/qt2 \
--with-qt2-lib=${X11BASE}/lib \
--with-qt2=qt2 \
@@ -35,14 +33,10 @@ CONFIGURE_ARGS= --with-qt2-include=${X11BASE}/include/qt2 \
MAKE_ARGS= LOCAL_LIBS=-lgcc
INSTALL_TARGET= site-install
-post-extract:
- cd ${WRKSRC}/examples/domexample && \
- ${RM} domtest1.cc domtest1
-
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_EXAMPLESDIR}/qt2xml
- ${CP} -R ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/qt2xml/
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
.endif
.include <bsd.port.mk>
diff --git a/textproc/ruby-qt2xml/pkg-plist b/textproc/ruby-qt2xml/pkg-plist
index 9766e7b5a0b3..92d153a2206b 100644
--- a/textproc/ruby-qt2xml/pkg-plist
+++ b/textproc/ruby-qt2xml/pkg-plist
@@ -1,9 +1,31 @@
%%RUBY_SITEARCHLIBDIR%%/qt2xml.so
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/domexample/quotes.xml
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/domexample/domtest1.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example1/example1.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example1/example1.ui
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example2/example2.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example2/example2.ui
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example2/example2j.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example2/example2j.ui
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example3/example3.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example3/example3.ui
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example4/example4.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example4/example4.ui
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example5/example5.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example5/example5.ui
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example6/example6.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example6/example6.ui
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/formmaker.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/ui2rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/saxsample/sax.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/saxsample/sample.xml
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/saxsample/sample1.ui
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/xml/tagreader-with-features/fnord.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/xml/tagreader-with-features/structureparser.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/xml/tagreader-with-features/tagreader.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/xml/tagreader/animals.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/xml/tagreader/structureparser.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/xml/tagreader/tagreader.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes/README.orig
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes/quotes.xml
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes/richtext.h.rb
@@ -12,6 +34,17 @@
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes/xmlquotes.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes/marble.png
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/domexample
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example1
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example2
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example3
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example4
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example5
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples/example6
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb/examples
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/qui2rb
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/saxsample
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/xml/tagreader
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/xml/tagreader-with-features
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/xml
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml