aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-11-24 19:06:36 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-11-24 19:06:36 +0000
commit4c5e26eb618d46333e42d3ae4e6efdd26603a306 (patch)
tree4f346ddfa440d30d5d576d866c537addce048aaa /textproc
parent7f99924f6f7ebdc6e08adbfde401c0858e72a499 (diff)
downloadports-4c5e26eb618d46333e42d3ae4e6efdd26603a306.tar.gz
ports-4c5e26eb618d46333e42d3ae4e6efdd26603a306.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-LibRSVG/Makefile31
-rw-r--r--textproc/p5-XML-LibRSVG/distinfo1
-rw-r--r--textproc/p5-XML-LibRSVG/files/patch-Makefile.PL18
-rw-r--r--textproc/p5-XML-LibRSVG/pkg-comment1
-rw-r--r--textproc/p5-XML-LibRSVG/pkg-descr3
-rw-r--r--textproc/p5-XML-LibRSVG/pkg-plist7
7 files changed, 62 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index f5dc41e46f6a..05b88b2d6cd3 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -147,6 +147,7 @@
SUBDIR += p5-XML-Dumper
SUBDIR += p5-XML-Encoding
SUBDIR += p5-XML-Filter-Base
+ SUBDIR += p5-XML-LibRSVG
SUBDIR += p5-XML-LibXML
SUBDIR += p5-XML-LibXSLT
SUBDIR += p5-XML-NamespaceSupport
diff --git a/textproc/p5-XML-LibRSVG/Makefile b/textproc/p5-XML-LibRSVG/Makefile
new file mode 100644
index 000000000000..3bf7c1943994
--- /dev/null
+++ b/textproc/p5-XML-LibRSVG/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: XML::LibRSVG
+# Date created: 20 Nov 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-LibRSVG
+PORTVERSION= 0.01
+CATEGORIES= textproc graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+LIB_DEPENDS= rsvg.1:${PORTSDIR}/graphics/librsvg \
+ freetype.7:${PORTSDIR}/print/freetype2 \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ png.5:${PORTSDIR}/graphics/png \
+ art_lgpl.5:${PORTSDIR}/graphics/libart
+
+PERL_CONFIGURE= yes
+CONFIGURE_ENV= INC='-I${LOCALBASE}/include' LIBS='-L${LOCALBASE}/lib'
+USE_GTK= yes
+
+MAN3= XML::LibRSVG.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-LibRSVG/distinfo b/textproc/p5-XML-LibRSVG/distinfo
new file mode 100644
index 000000000000..35cdd313b693
--- /dev/null
+++ b/textproc/p5-XML-LibRSVG/distinfo
@@ -0,0 +1 @@
+MD5 (XML-LibRSVG-0.01.tar.gz) = cee9a8c88c4931a17e921eee9017288a
diff --git a/textproc/p5-XML-LibRSVG/files/patch-Makefile.PL b/textproc/p5-XML-LibRSVG/files/patch-Makefile.PL
new file mode 100644
index 000000000000..4da5696784f8
--- /dev/null
+++ b/textproc/p5-XML-LibRSVG/files/patch-Makefile.PL
@@ -0,0 +1,18 @@
+--- Makefile.PL.orig Wed Oct 31 02:03:02 2001
++++ Makefile.PL Tue Nov 20 22:26:34 2001
+@@ -4,11 +4,11 @@
+
+ my %config;
+
+-$config{INC} = '';
+-$config{LIBS} = '-lpng';
++$config{INC} = $ENV{INC};
++$config{LIBS} = $ENV{LIBS}.' -lpng';
+
+-chomp($config{INC} .= ' ' . `gtk-config --cflags`);
+-chomp($config{LIBS} .= ' ' .`gtk-config --libs`);
++chomp($config{INC} .= ' ' . `gtk12-config --cflags`);
++chomp($config{LIBS} .= ' ' .`gtk12-config --libs`);
+
+ chomp($config{INC} .= ' ' . `gdk-pixbuf-config --cflags`);
+ chomp($config{LIBS} .= ' ' . `gdk-pixbuf-config --libs`);
diff --git a/textproc/p5-XML-LibRSVG/pkg-comment b/textproc/p5-XML-LibRSVG/pkg-comment
new file mode 100644
index 000000000000..386c37178cb6
--- /dev/null
+++ b/textproc/p5-XML-LibRSVG/pkg-comment
@@ -0,0 +1 @@
+Interface to GNOME's librsvg
diff --git a/textproc/p5-XML-LibRSVG/pkg-descr b/textproc/p5-XML-LibRSVG/pkg-descr
new file mode 100644
index 000000000000..bcfc2f7e8452
--- /dev/null
+++ b/textproc/p5-XML-LibRSVG/pkg-descr
@@ -0,0 +1,3 @@
+This module allows you to do is convert SVG's to PNG's in various ways.
+
+WWW: http://search.cpan.org/search?dist=XML-LibRSVG
diff --git a/textproc/p5-XML-LibRSVG/pkg-plist b/textproc/p5-XML-LibRSVG/pkg-plist
new file mode 100644
index 000000000000..55dbb9821ba9
--- /dev/null
+++ b/textproc/p5-XML-LibRSVG/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/XML/LibRSVG.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/LibRSVG/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/LibRSVG/LibRSVG.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/LibRSVG/LibRSVG.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/LibRSVG
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/XML 2>/dev/null || true