aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2019-09-20 10:28:32 +0000
committerNicola Vitale <nivit@FreeBSD.org>2019-09-20 10:28:32 +0000
commit19bdb169c389a47ae553acc6e9af95c25eb282bb (patch)
tree8ed402bed8ea73dcab497ac95e78a339c14a39a2 /textproc
parent4b6f291d3e326c1d9ec94d81ffa1f359e8c6d795 (diff)
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-towncrier/Makefile27
-rw-r--r--textproc/py-towncrier/distinfo3
-rw-r--r--textproc/py-towncrier/pkg-descr7
4 files changed, 38 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 593c8d2dee33..6b9f060717f6 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1404,6 +1404,7 @@
SUBDIR += py-tinycss
SUBDIR += py-toml
SUBDIR += py-toronado
+ SUBDIR += py-towncrier
SUBDIR += py-trans
SUBDIR += py-transifex-client
SUBDIR += py-translationstring
diff --git a/textproc/py-towncrier/Makefile b/textproc/py-towncrier/Makefile
new file mode 100644
index 000000000000..fe31c3e69e2e
--- /dev/null
+++ b/textproc/py-towncrier/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= towncrier
+PORTVERSION= 19.2.0
+CATEGORIES= textproc
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Building newsfiles for your project
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>=0:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}incremental>=0:devel/py-incremental@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toml>=0:textproc/py-toml@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>=0:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}incremental>=0:devel/py-incremental@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toml>=0:textproc/py-toml@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/textproc/py-towncrier/distinfo b/textproc/py-towncrier/distinfo
new file mode 100644
index 000000000000..71e5e030daa5
--- /dev/null
+++ b/textproc/py-towncrier/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1568909526
+SHA256 (towncrier-19.2.0.tar.gz) = 48251a1ae66d2cf7e6fa5552016386831b3e12bb3b2d08eb70374508c17a8196
+SIZE (towncrier-19.2.0.tar.gz) = 20250
diff --git a/textproc/py-towncrier/pkg-descr b/textproc/py-towncrier/pkg-descr
new file mode 100644
index 000000000000..e589f057bebe
--- /dev/null
+++ b/textproc/py-towncrier/pkg-descr
@@ -0,0 +1,7 @@
+towncrier is a utility to produce useful, summarised news files
+for your project. Rather than reading the Git history as some
+newer tools to produce it, or having one single file which
+developers all write to, towncrier reads "news fragments"
+which contain information useful to end users.
+
+WWW: https://github.com/hawkowl/towncrier