aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-13 09:37:20 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-13 09:37:20 +0000
commit52168317e247ec826988d7f6116ea1a42ed3e076 (patch)
tree633d957fe8531ea201bc90be512680f058898146 /textproc
parentd55e243de2bc52d66682a4c5258b821da82906ba (diff)
downloadports-52168317e247ec826988d7f6116ea1a42ed3e076.tar.gz
ports-52168317e247ec826988d7f6116ea1a42ed3e076.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/html2text/Makefile8
-rw-r--r--textproc/html2text/distinfo3
-rw-r--r--textproc/html2text/files/patch-format.C19
3 files changed, 23 insertions, 7 deletions
diff --git a/textproc/html2text/Makefile b/textproc/html2text/Makefile
index dd2cdec7f170..708bdd926b80 100644
--- a/textproc/html2text/Makefile
+++ b/textproc/html2text/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= html2text
-PORTVERSION= 1.3.1
+PORTVERSION= 1.3.2
CATEGORIES= textproc
MASTER_SITES= http://userpage.fu-berlin.de/~mbayer/tools/ \
ftp://ftp.ibiblio.org/pub/linux/apps/www/converters/
-MAINTAINER= corecode@corecode.ath.cx
+MAINTAINER= ports@FreeBSD.org
COMMENT= Converts HTML documents into plain text
USE_REINPLACE= yes
@@ -25,10 +25,6 @@ DOCS= CHANGES COPYING CREDITS KNOWN_BUGS README TODO
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502000
-BROKEN= "Does not compile"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/echo=/s/ -e//' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^DEBUG/s/^/#/; /^CXXFLAGS/s/=/+=/' \
diff --git a/textproc/html2text/distinfo b/textproc/html2text/distinfo
index 4da2e5b50a66..5d7a6d2b801b 100644
--- a/textproc/html2text/distinfo
+++ b/textproc/html2text/distinfo
@@ -1 +1,2 @@
-MD5 (html2text-1.3.1.tar.gz) = faa3eaeb062540e72d251d6c3fa6cc71
+MD5 (html2text-1.3.2.tar.gz) = 14b091c7c5cb5c3bc2ce19298a0c0e27
+SIZE (html2text-1.3.2.tar.gz) = 131336
diff --git a/textproc/html2text/files/patch-format.C b/textproc/html2text/files/patch-format.C
new file mode 100644
index 000000000000..c1942c85f553
--- /dev/null
+++ b/textproc/html2text/files/patch-format.C
@@ -0,0 +1,19 @@
+--- format.C Mon Jul 29 20:12:13 2002
++++ format.C Thu Feb 5 22:47:07 2004
+@@ -34,7 +34,7 @@
+ /***************************************************************************/
+
+
+-#include <strstream.h>
++#include <strstream>
+
+ #include <stdlib.h>
+ #include <ctype.h>
+@@ -50,6 +50,7 @@
+
+ using std::endl;
+ using std::flush;
++using std::ostrstream;
+
+ #ifndef nelems
+ #define nelems(array) (sizeof(array) / sizeof((array)[0]))